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に]での内容にご注意ください。

訓練手引書

生産する製造業者から : ArduinoからAVRへの間隙の橋渡し

AN-12077

事前必要条件

● ﾊｰﾄﾞｳｪｱ事前必要条件

 - ATmega328P Xplained Mini基板

 - IO1 Xplained Pro拡張基板

 - Arduino Xplained Pro基板

 - ﾏｲｸﾛUSBｹｰﾌﾞﾙ

● ｿﾌﾄｳｪｱ事前必要条件

 - Atmel® Studio 6.2またはそれ以降版

 - Arduino IDE 1.6.0

 - Atmel Studio用Arduino拡張

 - 端末ｳｨﾝﾄﾞｳ拡張

● 予想完了時間

 - 2時間

序説

この実践は豊富な使用者ｲﾝﾀｰﾌｪｰｽとそれが提供する他の優れた開発ﾙｰﾙと共にAtmel Stu 
dioを使ってArduinoを開発する方法を実演します。

Arduinoは柔軟性、使い易いﾊｰﾄﾞｳｪｱとｿﾌﾄｳｪｱに基づく解放ｿｰｽの電子回路試作基盤です。
それは芸術家、設計者、趣味人、そして相互作用的ば物や環境を作成することに興味がある
誰かのために意図されています。Arduinoについての重要な事実はこれらの基板がAtmelﾏｲｸ
ﾛ ｺﾝﾄﾛｰﾗ系統に基づき、基本的なｿﾌﾄｳｪｱはAtmel開発ﾂｰﾙに基づきます。

‘何故Aruduinoから切り替えるべきか?’に対する答えは、Arduino IDEが以下だからです。

● 経験豊富な書き手の能力に対するかなりの制限

● ｺﾝﾊﾟｲﾗ警告とﾃﾞﾊﾞｯｸﾞ能力の不足

● (全ての命令文の後のSerial.println()は数ず）、高度なﾌﾟﾛｼﾞｪｸﾄでの作業時に重荷

● Atmel Studioは統合されたArduino IEDを脱した使用者に対する素晴らしい選択

● それらのArduinoﾗｲﾌﾞﾗﾘのいくつかは正に殆ど価値のない簡便性

従って何故両世界を出来るだけ利用しないのか?。Arduinoはﾃﾞﾊﾞｯｸﾞ能力を持つC/C++の頂
上の包装部(ﾗｯﾊﾟｰ)。どんなArduinoのｽｹｯﾁやﾗｲﾌﾞﾗﾘでも高度なﾌﾟﾛｼﾞｪｸﾄであなた自身の独
自ｺｰﾄﾞと結合することが可能です。

Atmelは趣味人から開発者への移行の橋渡し、助けを提供するための“going pro”共同体につ
いてのArduinoでの独特で特権的位置と責任を持ちます。

Atmel Xplained Mini系統はCとC++への容易な移行に対する完璧な”橋渡し”です。それはArd 
uinoに対して非常に類似した構造を持ち、Arduino基板のも飛渡の機能を提供します。IDEが
正しく構成設定された時にArduinoｽｹｯﾁの走行が可能です。基板上のﾊｰﾄﾞｳｪｱ ﾃﾞﾊﾞｯｶﾞ/書き
込み器も利用可能です。それは非常に一般的なAVR®ﾏｲｸﾛ ｺﾝﾄﾛｰﾗ系統使い、相対的に安
価です。
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この訓練手引き書は4つの課題から成ります。

最初の課題ではATmega328P Xplained MiniをArduino IDEに接続L方法を理解します。

第2の課題ではAtmel StudioのArduino拡張を使ってAtmel StudioでArduinoｽｹｯﾁをを作成し
ます。

第3の課題では直接ｽｹｯﾁを取り入れるようにAtmel Studioを構成設定します。既存Arduinoｽ
ｹｯﾁをAtmel Studioへ移行する方法を検討します。また、Atmel Studioで中断点(ﾌﾞﾚｰｸﾎﾟｲﾝﾄ)
を挿入する方法とﾃﾞﾊﾞｯｸﾞする方法を調べます。

第4の課題ではﾌｧｲﾙを編集して周辺機能(ADC,I2C,SPI)を持つ簡単な応用を作成します。こ
の応用はA/D変換器(ADC)を通し光感知器を読み、I2Cｲﾝﾀｰﾌｪｰｽを通して温度感知器を読
み、そしてSPIｲﾝﾀｰﾌｪｰｽを通してSDｶｰﾄﾞ内にﾃﾞｰﾀを格納します。

図1. ATmega328P Xplained Mini基板
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ｱｲｺﾝ基本識別子

情報 特定の話題について文脈上の情報を提供

助言 有用な助言と技法を強調

実施事項 完了されるべき目標を強調

結果 課題段階の予測される結果を強調

警告 重要な情報を表示

実行 必要時に目的対象の実行されるべき活動を強調
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1. 訓練単位部構造
この訓練素材は以下として各種Atmel配給物を通して取得することができます。

● 通常、Atmel展示室ｳｪﾌﾞ ｻｲﾄ(http://gallery.atmel.com/)で、またはAtmel Studio拡張管理部を使って得られるAtmel Studio拡張
(.vsixﾌｧｲﾙ)

● 通常、Atmel訓練作業中に提供されるAtmel訓練実行物(.exeﾌｧｲﾙ)

配布形式に依存して、この訓練素材によって必要とされる各種資料(実践訓練資料、ﾃﾞｰﾀｼｰﾄ、応用記述、ﾂｰﾙ)は種々の場所で得
られます。

1.1. Atmel Studio拡張 (.vsix)

一旦この拡張がｲﾝｽﾄｰﾙされると、Atmel Studioで”New Example Project from ASF...”を使って種々のﾌﾟﾛｼﾞｪｸﾄを開いて作成するこ
とができます。

この拡張でｲﾝｽﾄｰﾙされたﾌﾟﾛｼﾞｪｸﾄは一般的に”Atmlel Training⇒Ateml Cort. Extension Name”下で得られます。

拡張に依存して利用可能な各種ﾌﾟﾛｼﾞｪｸﾄがあります。

● Hands-on Documentation (実践訓練資料) : 必要とされる資源としての資料を含みます。

● Hands-on Assignment (実践訓練課題) : 開始に必要とされるかもしれない初期ﾌﾟﾛｼﾞｪｸﾄを含みます。

● Hands-on Solution (実践訓練解決策) : この実践訓練に対する解決策である最終的な応用を含みます。

以降の頁でいくつかの資源に対して参照が行われる度に、使用者はHands-on Documentation(実践訓練資料)ﾌﾟﾛｼﾞｪｸﾄ ﾌｫﾙ
ﾀﾞを参照しなければなりません。

1.2. Atmel訓練実行物 (.exe)

実行物がｲﾝｽﾄｰﾙされた場所に依存して、2つの主なﾌｫﾙﾀﾞから成る以下の基本構造を見つけるでしょう。

● AN-12077_Hands-on : 開始と解決策に必要とされるかもしれない初期ﾌﾟﾛｼﾞｪｸﾄを含みます。

● Resources : 必要とされる資源(ﾃﾞｰﾀｼｰﾄ、ｿﾌﾄｳｪｱ、ﾂｰﾙなど)を含みます。

特定の位置が指定されない限り、以降の頁でいくつかの資源に対して参照が行われる度に、使用者はこのResources(資源)ﾌﾟ
ﾛｼﾞｪｸﾄ ﾌｫﾙﾀﾞを参照しなければなりません。

2. 課題1 : Arduino IDEへのATmega328P Xplained Mini接続方法

2.1. Arduino IDE

www.arduino.ccからArduino IDEをﾀﾞｳﾝﾛｰﾄﾞしてください。

2.2. ATmega328P Xplained MiniでのmEDBGﾌｧｰﾑｳｪｱ格上げ(更新)

 1. Atmel作業空間(http://spaces.atmel.com/gf/project/avr_xp_mini/frs/)へ行ってください。”medbgdebugger”一括からmedbg_f 
w.zipを選んでﾀﾞｳﾝﾛｰﾄﾞしてください。

 2. Atmel Studioｲﾝｽﾄｰﾙ ﾌﾙﾀﾞ(例えば、C:\Program Files (x86)\Atmel\Atmel Studio 6.2\tools\mEDBG)にmedbg_fw.zipのZIP一括
を上書きしてください。

 3. Atmel Studioを開始してください。

 4. ATmega328P Xplained Miniをｺﾝﾋﾟｭｰﾀに接続してください。

 5. Atmel Studioに於いて、Tools⇒Device programming (alt.:Ctrl+Shift+P)を選んでください。

 6. ﾃﾞﾊﾞｲｽ ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｳｨﾝﾄﾞｳで、ToolにmEDBGを設定して”Apply”をｸﾘｯｸしてさい。

http://gallery.atmel.com/
http://www.arduino.cc/
http://spaces.atmel.com/gf/project/avr_xp_mini/frs/
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情報 次にAtumel Studioがﾌｧｰﾑｳｪｱを格上げ(更新)を望むかを尋ねるでしょう。

 7. Upgradeを選んでください。

Atmel Studioのﾌﾟﾛｸﾞﾗﾐﾝｸﾞ/ﾃﾞﾊﾞｯｸﾞによる認証をできなくする、いくつかのATmega328P Xplained Mini基板での通番
のﾊﾞｸﾞがあります。あなたの基板が通番内に未知の文字を持つ場合、”Releases”ﾌｫﾙﾀﾞ内に修正があります。あなた
の基板の通番を見るには、Atmel Studioを開始してTools⇒Device programmingでﾂｰﾙを選択してください。これは
通番と共にmEDBGを一覧にし、いくつかの文字が黒背景で”?”を持つ場合、通番修正(serial number fix)から一括
をﾀﾞｳﾝﾛｰﾄﾞしてHow_to_change_serial_Number.pdfからの指示に従ってください。

情報

http://spaces.atmel.com/gf/project/avr_xp_mini/frs/?action=FrsReleaseBrowse&frs_package_id=181
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2.3. ATmega328Pでのﾌﾞｰﾄﾛｰﾀﾞ ﾋｭｰｽﾞ設定

 1. 次に’Device Programming’ｳｨﾝﾄﾞｳで、’Fuses’を選択してください。

 2. 下で示されるようにEXTENDED,HIGH,LOWの値を変更してProgramをｸﾘｯｸしてください。
 EXRENDED = $FF
 HIGH =$D8
 LOW = $E0

図2-1. Device Programming : Fuses

2.4. ﾌﾞｰﾄﾛｰﾀﾞ書き込み

ﾌﾞｰﾄﾛｰﾀﾞhexﾌｧｲﾙはC:\Program Files (x86)\Arduino\hardware\arduino\avr\bootloaders\atmega\*.hexのArduino 
IDEﾌｫﾙﾀﾞに置かれます。ﾌﾞｰﾄﾛｰﾀﾞは表2-1.で一覧されるように基板構成設定に従って選択することができます。

情報

表2-1. ﾌﾞｰﾄﾛｰﾀﾞ

Xplained Mini

ATmega328P/5V/16MHz ATmegaBOOT_168_atmega328.hex

ﾌﾞｰﾄﾛｰﾀﾞ

ATmega168P/5V/16MHz ATmegaBOOT_168_ng.hex

ATmega168P/3.3V/8MHz ATmegaBOOT_168_pro_8MHz.hex

 1. ‘Tools⇒Device Programming’でのｳｨﾝﾄﾞｳで、’Memories’ﾀﾌﾞを選んでください。

 2. C:\Program Files (x86)\Arduino\hardware\arduino\avr\bootloaders\atmega\ ATmegaBOOT_168_atmega328.hexを閲覧してく
ださい。

 3. Programをｸﾘｯｸしてください
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図2-2. Device Programming : Memories

2.5. Arduino IDE構成設定

 1. Windows®のｽﾀｰﾄ ﾒﾆｭｰまたはArduino IDEがｲﾝｽﾄｰﾙされたﾌｫﾙﾀﾞからArduino IDEを開始してください。

 2. ﾒﾆｭｰからのTools⇒PortからでmEDBG用の正しいCOMﾎﾟｰﾄを選択してください(mEDBGに使われるCOMﾎﾟｰﾄを確認する方法を
次の助言でご覧ください)。

図2-3. Ardduino IDE : (Serial) Port
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助言 mEDBGのCOMﾎﾟｰﾄはｽﾀｰﾄ⇒ｺﾝﾄﾛｰﾙ ﾊﾟﾈﾙ⇒ﾃﾞﾊﾞｲｽ ﾏﾈｰｼﾞｬ⇒ﾎﾟｰﾄから下のように眺めることができます。

 3. 基板(Board)は表2-2.に従って選択することができます。

表2-2. Arduino IDE : Board

Xplained Mini

ATmega328P Xplained Mini Arduino Nano : ATmega328

Arduino IDEで選択する基板

ATmega168PB Xplained Mini Arduino Nano : ATmega168

ここで、 選択 : Tools⇒Boards⇒Arduino Nano
 選択 : Tools⇒Processor⇒ATmega328

図2-4. Ardduino IDE : BoardとProcessor
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2.6. ﾌﾟﾛｸﾞﾗﾑのｱｯﾌﾟﾛｰﾄﾞ

ATmega328P Xplained Mini基板はArduino IDEへ接続され、LED点滅が始まるでしょう。

 1. Arduino IDEで、Files⇒Examples⇒01.Basics⇒Blinkを選択してください。

結果

図2-5. Ardduino IDE : Examples-Blink

 2. Arduino IDEで“Upload”釦をｸﾘｯｸすることによってｽｹｯﾁをｱｯﾌﾟﾛｰﾄﾞしてください。 図2-6. Ardduino IDE : Upload

ｳｨﾝﾄﾞｳの下部で’Compiling Sketch(ｽｹｯﾁをｺﾝﾊﾟｲﾙ中)’、’Uploading(ｱｯﾌﾟﾛｰﾄﾞ中)’、’Done uploading(ｱｯﾌﾟﾛｰﾄﾞ終
了)’のﾒｯｾｰｼﾞが出現されるでしょう。

 3. File⇒Save As...を選んで’Blink’ｽｹｯﾁを保存してください。ｽｹｯﾁを保存するのにどのﾊﾟｽをも選ぶことができます。

 4. ATmega328P Xplained Mini基板でLED点滅を観察してください。

これで成功裏にArduino IDEへ接続されたATmega328P Xplained Mini基板があります。

結果
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3. 課題2 : Atmel StudioでのArduinoｽｹｯﾁ作成
Atmel StudioのArduino拡張はそれが提供する豊富な使用者ｲﾝﾀｰﾌｪｰｽや専門的な機能を持つAtmel Studio内で書い
てｺﾝﾊﾟｲﾙし、そしてどのArduinoへもｱｯﾌﾟﾛｰﾄﾞすることをArduinoのｽｹｯﾁに許します。

3.1. 拡張のﾀﾞｳﾝﾛｰﾄﾞ

 1. Atmel Studioを開いてください。

 2. Tools⇒Extension Managerを選んでください。拡張管理部(Extension Manager)ｳｨﾝﾄﾞｳが開き、既定によってｲﾝｽﾄｰﾙされている
拡張を示します。

 3. “Available Download”任意選択をｸﾘｯｸしてください。

情報

図3-1. Atmel Studio : Extension Manager

 4. “Arduino IDE for Atmel Studio”を選んで”Download”ｱｲｺﾝをｸﾘｯｸしてください。

 5. “Sign in to Extension Manager Dashboard”ｳｨﾝﾄﾞｳが開き、ｻｲﾝｲﾝ(sign-in)/登録(register)を尋ねます。

既に登録していないなら、どうぞ登録してください。その後に“Sign in to Extension Manager Dashboard”ｳｨﾝﾄﾞｳを閉
じてください。Atmelは提供されるEﾒｰﾙIDのために、あなたへ確認Eﾒｰﾙを送ります。あなたのEﾒｰﾙIDを確認するた
めにﾘﾝｸをｸﾘｯｸしてください。“Sign in to Extension Manager Dashboard”で手順2.～4.を繰り返してください。Eﾒｰﾙ
IDと登録中に提供されるﾊﾟｽﾜｰﾄﾞを使ってｻｲﾝｲﾝしてください。

 6. “Arduino IDE for Atmel Studio”拡張がﾀﾞｳﾝﾛｰﾄﾞされ、その後にそれをｲﾝｽﾄｰﾙしてください。

3.2. ｽｹｯﾁ作成

 1. Atmel Studioを開いてください。

Atmel StudioでArduino 1.6が一覧にされていることを確認し、それを選
んでください。

情報

実施事項
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情報
それが一覧にされてなければ、<Configuration Manager>をｸﾘｯｸしてください。Arduino 1.6を選んでください。下図で
示されるようにArduinoｲﾝｽﾄｰﾙ ﾌｫﾙﾀﾞのﾊﾟｽを追加してください。’OK’を選んでください。

図3-2. Configure Visual Micro

 2. File⇒New⇒Sketch Projectを選んでください。

 3. 下図で示されるようにｽｹｯﾁ ﾌﾟﾛｼﾞｪｸﾄ用の名前を入力して’OK’を選んでください。

情報 led_toggle.inoｽｹｯﾁは図3-2.で示されるように既定位置としてc:Arduinoに作成されるでしょう。

 4. LEDを交互ON/OFFすようにｺｰﾄﾞを編集してください。

int led = 13;

void setup()
{
 /* 準備ｺｰﾄﾞをここに追加してください。 */
 pinMode(led, OUTPUT); 
}

void loop()
{
 /* 主ﾌﾟﾛｸﾞﾗﾑ ｺｰﾄﾞをここに追加してください。 */
 digitalWrite(led,HIGH);
 delay(500);
 digitalWrite(led, LOW);
 delay(500);
} 
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 5. 基板をArduino Nano w/ATmega328として選んでください。

 6. mEDBGのCOMﾎﾟｰﾄ番号を選んでください。

 7.       ｱｲｺﾝをｸﾘｯｸすることによってﾌﾟﾛｸﾞﾗﾑをﾀﾞｳﾝﾛｰﾄﾞしてください。

ATmega328P Xplained Mini基板上のLEDが交互ON/OFFを始めるでしょう。結果
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4. 既存ArduinoｽｹｯﾁのAtmel Studio IDEへの移行

4.1. ﾌﾟﾛｼﾞｪｸﾄ作成

 1. Atmel Studioを開き、”GCC C++ Executable Project”で新規ﾌﾟﾛｼﾞｪｸﾄを作成し、妥当な名前を与え、ﾃﾞﾊﾞｲｽとしてATmega328P
を選んでください。

 2. ﾌﾟﾛｼﾞｪｸﾄが作成されたﾌｫﾙﾀﾞの場所を記録することを確実にしてください。

 3. 結果のSolution Explorerで、下図で示されるように右ｸﾘｯｸしてﾌﾟﾛｼﾞｪｸﾄCPPﾌｧｲﾙ(ここではATmega328P_1.cpp)を削除してくださ
い。
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 4. Windowsのｴｸｽﾌﾟﾛｰﾗで、

a. あなたのｽｹｯﾁ(先に保存したArduino点滅ｽｹｯﾁ/Blink.ino)を複写し、(例えAtmel Sudioのﾌﾟﾛｼﾞｪｸﾄから取り去られたとしても、
未だｴｸｽﾌﾟﾛｰﾗにある)ATmega328P_1.cppのあるAtmel Studioのﾌﾟﾛｼﾞｪｸﾄ副ﾌｫﾙﾀﾞにそれを置いてください。

b. あなたのｽｹｯﾁ拡張を.cppに(Blink.ino⇒Blink.cpp)改名してください。下図をご覧ください。

 5. Atmel StudioでProject⇒Show All Filesを選んでください。

 6. Solution Explorerｳｨﾝﾄﾞｳで、Blink.cppﾌｧｲﾙを右ｸﾘｯｸし右図で示されるよう
に”Include In Project”を選んでください。
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4.2. ｺﾝﾊﾟｲﾗ ｼﾝﾎﾞﾙ構成設定

 1. Solution Explorerでﾌﾟﾛｼﾞｪｸﾄを右ｸﾘｯｸし、Propertiesを選ぶか、またはﾌｧｲﾙ ﾒﾆｭｰ(Alt+F7)でProject⇒ﾌﾟﾛｼﾞｪｸﾄ名 Properties…
へ行ってください。

 2. Toolchain⇒AVR/GNU C Compiler⇒Symbols下に以下を追加してください。

 F_CPU=16000000L
 USB_VID=null
 USB_PID=null
 ARDUINO=160

これらはArduino特有ｼﾝﾎﾞﾙです。

 3. Toolchain⇒AVR/GNU C++ Compiler⇒Symbolsに対して繰り返してください。

情報

4.3. ｺﾝﾊﾟｲﾗ ﾃﾞｨﾚｸﾄﾘ構成設定

 1. Toolchain⇒AVR/GNU C Compiler⇒Directories下に以下を追加してください。

 2. C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino

 3. C:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard

 4. C:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\eightanaloginputs

 5. Toolchain⇒AVR/GNU C++ Compiler⇒Directoriesに対して繰り返してください。

これらのﾊﾟｽ追加中に”Relative Path”の選択解除を確実にしてください。警告
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4.4. Arduino依存ﾌｧｲﾙ追加

 1. ﾌﾟﾛｼﾞｪｸﾄを右ｸﾘｯｸして”Add⇒Existing Item…”に行ってください。

 2. 開いたﾀﾞｲｱﾛｸﾞ枠で閲覧部のﾊﾟｽC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduinoを狙ってください。

a. “File name”枠で*.c*<Enter>を入力してください。

b. 全ﾌｧｲﾙを多選択して”Add as Link”を選んでください。
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4.5. 解決策構築

 1. Blink.cppの先頭に# include “arduino.h”を追加してくださ
い。

情報 今や全てのAtduino依存物が追加され、ﾌﾟﾛｼﾞｪｸﾄをｺﾝﾊﾟｲﾙして目的対象内に読み込むことができます。

 2. ﾌｧｲﾙ ﾒﾆｭｰで、Build⇒Build Solutionを選んでください。この構築は誤りなしで成功裏に終わるべきです。

4.6. ATmega328P Xplained Mini基板差し込み

 1. Solution Explorerでﾌﾟﾛｼﾞｪｸﾄを右ｸﾘｯｸしてﾌｧｲﾙ ﾒﾆｭｰ(Alt+F7)でPropertiesを選ぶか、またはProject⇒ﾌﾟﾛｼﾞｪｸﾄ名 Properties…
へ行ってください。

 2. Tool下で、InterfaceとしてmEDBGとdebugWIREを選んでください。

情報 いくつかの箇所でｼｽﾃﾑはﾃﾞﾊﾞｯｶﾞの更新を望むかもしれません。それを更新しましょう。
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 3. Toolchain⇒AVR/GNU C Compiler⇒Optimization下で最適化ﾚﾍﾞﾙ’Optimize for size(-Os)’を選んでください。

 4. Toolchain⇒AVR/GNU C++ Compiler⇒Optimization下で最適化ﾚﾍﾞﾙ’Optimize for size(-Os)’を選んでください。

4.7. ﾃﾞﾊﾞｯｸﾞ

 1. Debugを選び、’Start Debugging and Break’をｸﾘｯｸしてください。
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警告
DWENﾋｭｰｽﾞが許可されていない場合に異常ﾒｯｾｰｼﾞが表示されます。下で示されるように’Yes’をｸﾘｯｸしてﾋｭｰｽﾞを
設定するのにAtmel StudioはISPを使います。

結果 ﾃﾞﾊﾞｯｶﾞが開始され、mainで中断されます。今やﾃﾞﾊﾞｯｸﾞを開始する準備が整いました。
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情報 Debugﾒﾆｭｰでは種々のﾃﾞﾊﾞｯｸﾞ任意選択が利用可能です。

 2. (‘Solution Explorer’のBlink.cppﾌｧｲﾙで)中断点(ﾌﾞﾚｰｸ ﾎﾟｲﾝﾄ)の挿入を望む場所であるｿｰｽ ｺｰﾄﾞ内の行へ行き、右ｸﾘｯｸしてBr 
eakpoint⇒Insert Breakpointを選んでください。
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結果 中断点(ﾌﾞﾚｰｸ ﾎﾟｲﾝﾄ)が挿入されます。

 3. “Continue”をｸﾘｯｸすることによって中断点へ走行してください。必要な度毎に実行を一時停止と継続をすることができます。

 4. Debug⇒Disable debugWIRE and Closeを選ぶことによってﾃﾞﾊﾞｯｸﾞ動作を抜け出してください。

警告

情報

ﾃﾞﾊﾞｯｸﾞWIREを禁止することが重要です。

ﾃﾞﾊﾞｯｸﾞWIREの禁止は目的対象をﾘｾｯﾄしてDWENﾋｭｰｽﾞをﾘｾｯﾄし、再びISPｲﾝﾀｰﾌｪｰｽを使うことができます。ﾌﾟﾛｸﾞ
ﾗﾑ(0)されたDWENﾋｭｰｽﾞを持つことは、ｸﾛｯｸ系のいくつかの部分に全休止動作形態で動くことを許します。これは
休止動作中にAVRの消費電力を増します。従ってﾃﾞﾊﾞｯｸﾞWIREが使われない時にDWENﾋｭｰｽﾞは常に禁止される
べきです。

 5. 基板をﾘｾｯﾄしてLEDの点滅を観察してください。
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5. ATmega328P応用
我々はA/D変換器(ADC)を使って光感知器を読み、I2Cｲﾝﾀｰﾌｪｰｽを使って温度感知器を読み、そしてSPIｲﾝﾀｰﾌｪｰｽを使ってSD
ｶｰﾄﾞにﾃﾞｰﾀを格納する簡単な応用を作成しつつあります。また、光感知器値と温度感知器値はmEDBG COMﾎﾟｰﾄを通して送信され
ます。

I2CについてはArduinoからの”Wire”ﾗｲﾌﾞﾗﾘが必要とされ、SDｶｰﾄﾞについてはｲﾝｸﾙｰﾄﾞされるべき”SD library”が必要とされます。

5.1. ｺﾝﾊﾟｲﾗ構成設定

 1. ﾌﾟﾛｼﾞｪｸﾄ(ここではATmega328P_1)を右ｸﾘｯｸしてPropertiesを選んでください。

 2. Toolchain⇒AVR/GNU C Compiler⇒Directories下に以下を追加してください(前もって追加したﾃﾞｨﾚｸﾄﾘが未だ一覧にあるべき
です)。

C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\Wire
C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\Wire\utility
C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\SPI
C:\Program Files (x86)\Arduino\libraries\SD\src
C:\Program Files (x86)\Arduino\libraries\SD\src\utility

 3. Toolchain⇒AVR/GNU C++ Compiler⇒Directoriesに対して繰り返してください。

これらのﾊﾟｽ追加中に”Relative Path”のﾁｪｯｸ外しを確実にしてください。警告

図5-1. Atmel Studio : Compiler Setup
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5.2. 依存ﾌｧｲﾙ追加

ﾗｲﾌﾞﾗﾘから実際のAtmel Studio　ﾌﾟﾛｼﾞｪｸﾄへ.ccpｿｰｽ ﾌｧｲﾙを追加してください。

5.2.1. Wireﾗｲﾌﾞﾗﾘに対して

 1. ﾌﾟﾛｼﾞｪｸﾄを右ｸﾘｯｸし、“Add⇒Existing Item…”へ行ってください。

 2. 開いたﾀﾞｲｱﾛｸﾞ枠に於いて、閲覧部でC:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\Wireを狙ってください。

 3. Wire.ccpﾌｧｲﾙを選択して‘As a link(ﾘﾝｸとして)’追加してください。

 4. “wire\utility”副ﾃﾞｨﾚｸﾄﾘに対して同様に繰り返し、twi.cﾌｧｲﾙを選択して‘As a link(ﾘﾝｸとして)’追加してください。

実施事項

5.2.2. SDﾗｲﾌﾞﾗﾘに対して

 1. ﾌﾟﾛｼﾞｪｸﾄを右ｸﾘｯｸし、“Add⇒Existing Item…”へ行ってください。

 2. 開いたﾀﾞｲｱﾛｸﾞ枠に於いて、閲覧部でC:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\SPIを狙ってください。

 3. SPI.ccpﾌｧｲﾙを選択して‘As a link(ﾘﾝｸとして)’追加してください。

 4. C:\Program Files (x86)\Arduino\libraries\SD\srcに対して同様に繰り返してください。

a. SD.cppとFile.cppのﾌｧｲﾙを複数選択してください。

b. “SD\utility”副ﾃﾞｨﾚｸﾄﾘに対して同様に繰り返し、SdVolume.cpp, Sd2Card.cpp, SdFile.cppを選択して‘As a link(ﾘﾝｸとして)’追
加してください。
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5.3. 応用開発

現在のBlink.cppﾌｧｲﾙをsensors.cppﾌｧｲﾙに改名し、LED点滅ｺｰﾄﾞ(即ち、setup()とloop())を削除してください。

sensors.cppﾌｧｲﾙの先頭でSDとWireのﾗｲﾌﾞﾗﾘ用のﾍｯﾀﾞ ﾌｧｲﾙをｲﾝｸﾙｰﾄﾞください。

#include <Wire.h>
#include <SD.h>

温度感知器に関する定義を追加してください。

#define AT30TSE_TEMPERATURE_TWI_ADDR 0x4F
#define AT30TSE_TEMPERATURE_REG 0x00
#define AT30TSE_TEMPERATURE_REG_SIZE 2
#define AT30TSE_NON_VOLATILE_REG 0x00

#define AT30TSE_CONFIG_RES_9_bit 0
#define AT30TSE_CONFIG_RES_10_bit 1
#define AT30TSE_CONFIG_RES_11_bit 2
#define AT30TSE_CONFIG_RES_12_bit 3
uint16_t resolution = AT30TSE_CONFIG_RES_12_bit;

使用ﾋﾟﾝに対する定数を定義してください。 

const int analogInPin = A0; // ｱﾅﾛｸﾞ入力ﾋﾟﾝ
const int chipSelect = 10; // SPI従装置選択ﾋﾟﾝ

SDﾗｲﾌﾞﾗﾘを使う変数を定義してください。 

File myFile;

A/D変換結果と温度を格納する変数を定義してください。 

double temp_result;
int sensorValue = 0; // A/D変換器A0からの読み込み値

実行

実行

実行

実行

実行

実行
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温度感知器を読む関数を追加してください。

uint16_t at30tse_read_register(uint8_t reg, uint8_t reg_type, uint8_t reg_size)
{
 uint8_t buffer[2],i=0;
 buffer[0] = reg | reg_type;
 buffer[1] = 0;

 /* AT30TSEの内部ﾚｼﾞｽﾀ ﾎﾟｲﾝﾀ */
 Wire.beginTransmission(AT30TSE_TEMPERATURE_TWI_ADDR);
 Wire.write(buffer[0]);
 Wire.endTransmission();

 Wire.requestFrom(AT30TSE_TEMPERATURE_TWI_ADDR, reg_size);

 while(Wire.available())
 {
  buffer[i] = Wire.read(); // 文字としてﾊﾞｲﾄ受信
  i++;
 }

 return (buffer[0] << 8) | buffer[1];
}

double at30tse_read_temperature()
{
 /* 16ﾋﾞｯﾄ温度ﾚｼﾞｽﾀ読み込み */
 uint16_t data = at30tse_read_register(AT30TSE_TEMPERATURE_REG, AT30TSE_NON_VOLATILE_REG,
    AT30TSE_TEMPERATURE_REG_SIZE);

 double temperature = 0;
 int8_t sign = 1;

 /* 負検査と符号ﾋﾞｯﾄ解除 */
 if (data & (1 << 15)){
  sign *= -1;
  data &= ~(1 << 15);
 }

 /* 温度へ変換  */
 switch (resolution){
  case AT30TSE_CONFIG_RES_9_bit:
   data = (data >> 7);
   temperature = data * sign * 0.5;
   break;
  case AT30TSE_CONFIG_RES_10_bit:
   data = (data >> 6);
   temperature = data * sign * 0.25;
   break;
  case AT30TSE_CONFIG_RES_11_bit:
   data = (data >> 5);
   temperature = data * sign * 0.125;
   break;
  case AT30TSE_CONFIG_RES_12_bit:
   data = (data >> 4);
   temperature = data * sign * 0.0625;
   break;
  default:
   break;
 }
 return temperature;
}

実行
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実行

情報

setup()初期化関数を追加してください。

Atumel Studioで関数名を書き始めると直ぐに下で示されるように可能な関数名が一覧にされます。

void setup()
{
 Serial.begin(9600); // 直列通信を開く

 if (!SD.begin(chipSelect)) {
  Serial.println("SD Card initialization failed!");
  return;
 }
 Serial.println("SD Card initialization done.");

 SD.remove("data.txt");

 Wire.begin();
} 
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変数とloop()関数追加してください。

bool sensor_flg=0;

void loop() {

 sensorValue = analogRead(analogInPin); // A/D変換器(ADC)読み込み
 temp_result = at30tse_read_temperature(); // 温度読み込み

 if (sensorValue>=500)
 {
  sensor_flg=1;
 }

 if (sensor_flg==1) // 特殊な感知器値でﾌｧｲﾙ内にﾃﾞｰﾀ書き込み
 {
  sensor_flg=0;

  myFile = SD.open("data.txt", FILE_WRITE);

  if (myFile) // ﾌｧｲﾙが開いていればそれに書き込み
  {
   myFile.print("sensor = " );
   myFile.print(sensorValue);

   myFile.print("    temp = ");
   myFile.print(temp_result);
   myFile.print("\n");

   myFile.close(); // ﾌｧｲﾙを閉じる
  }
  else
  {
   // ﾌｧｲﾙが開かなかった場合は異常表示
   Serial.println("error opening data.txt");
  }

  // 読むために改めてﾌｧｲﾙを開く
  myFile = SD.open("data.txt");
  if (myFile)
  {
   // 何も無くなるまでﾌｧｲﾙから読み込み
   while (myFile.available()) {
    Serial.write(myFile.read());
   }
   // ﾌｧｲﾙを閉じる
   myFile.close();
  } else {
   // ﾌｧｲﾙが開かなかった場合は異常表示
   Serial.println("error opening data.txt");
  }
 }
 delay(500);
}

実行
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ﾌｧｲﾙを保存し、’Build’ﾀﾌﾞを選択するか、またはｷｰﾎﾞｰﾄﾞでF7ｷｰを押すことによって解決策を構築してください。実行

結果　この構築は異常なしで成功裏に終了すべきです。

5.4. ﾊｰﾄﾞｳｪｱ接続

光感知器と温度感知器はIO1 Xplained Pro基板上に存在します。

IO1 Xplained ProはAtmel Xplained Pro評価基盤に対する拡張基板です。それはﾏｲｸﾛSD、温度感知器、光感知器、その他色々を
含むXplained Pro MCU基板に対して広く多様な機能を与えるように設計されます。IO1拡張基板は図5-2.で示されます。

図5-2. IO1 Xplained Pro

Xplained Pro
IDﾁｯﾌﾟATSHA204 低域通過濾波器

LED UARTﾍｯﾀﾞ

光感知器

GPIOﾍｯﾀﾞ 電源ﾍｯﾀﾞ ﾏｲｸﾛSDｶｰﾄﾞ ｺﾈｸﾀ

ATmega328P Xplained MiniへのIO1 Xplained Pro基板の実際の接続は表5-1.で示されます。

http://www.atmel.com/tools/ATIO1-XPRO.aspx
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表5-1. 接続 : IO1 Xplained Pro - ATmega328P Xpalined Mini

IO1 Xplained Pro ATmega328P Xplained Mini

ﾋﾟﾝ番号 ﾋﾟﾝ名名前 MCUﾋﾟﾝ

3 ADC PC0 A0

11 TWI_SDA PC4 SDA

12 TWI_SCL PC5 SCL

2 GND GND -

20 VCC 3V3 -

15 SPI_SS_A PB2 SPI_SS (D10)

16 SPI_MOSI PB3 SPI_MOSI

17 SPI_MISO PB4 SPI_MISO

18 SPI_SCK PB5 SPI_SCK

5.4.1. 接続 : IO1 Xplained Pro - Arduino Xplained Pro

下図で示されるようにIO1 Xplained ProをArduino Xplained Proへ接続してください。
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5.4.2. 接続 : ATmega328P Xplained Mini - Arduino Xplained Pro

次にATmega328P Xplained MiniをArduino Xplained Pro基板に接続することが必要です。Xplained Mini基板の列1からのPC5を
Arduino Xplained ProのA5に(赤色接続)とXplained Mini基板の列11からのPC5をArduino Xplained ProのSCLに(緑色接続)行くように
接続してください。

右のように接続してください。
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5.4.3. 接続 : USBｹｰﾌﾞﾙ

ATmega328P Xplained Mini基板にUSBｹｰﾌﾞﾙを接続し、基板を図5-3.のように接続してください。

ｿｹｯﾄにSDｶｰﾄﾞが正しく挿入されているのを確実にしてください。

基板は光感知器が暗がりにないこの方法で置かれます。

代替接続法 : 使用者は右下の図で示されるようにArduino Xplained Pro基板を使わずに9Pのｵｽｰﾒｽ ｺﾈｸﾀを使って
IO1 Xplained Pro基板を接続することもできます。

警告

図5-3. 課題4に対するﾊｰﾄﾞｳｪｱ接続の視覚的表現

情報

情報
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5.5. 応用のﾃﾞﾊﾞｯｸﾞ

次に応用をﾃﾞﾊﾞｯｸﾞします。ｺｰﾄﾞは特定条件(感知器値>500時)で
光感知器値と温度感知器値がSDｶｰﾄﾞに格納されるように書かれ
ています。この条件に中断点(ﾌﾞﾚｰｸﾎﾟｲﾝﾄ)を配置して中断点に
当たることを調べてください。

Debugを選んで’Start debugging and Break’
をｸﾘｯｸしてください。

実施事項

警告
DWENﾋｭｰｽﾞが許可されていない場合に異常ﾒｯｾｰ
ｼﾞが表示されます。下で示されるように’Yes’をｸﾘｯ
ｸしてﾋｭｰｽﾞを設定するのにAtmel StudioはISPを使
います。

結果 ﾃﾞﾊﾞｯｶﾞが開始され、mainで中断されます。今やﾃﾞﾊﾞｯｸﾞを開始する準備が整いました。
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Atmel StudioでView⇒Terminal Windowを選んでください。mEDBG COMﾎﾟｰﾄ、Baud:9600を選び、”Connect”を
選んでください。

実施事項

結果

情報

実施事項

感知器ﾃﾞｰﾀはmEDBG COMﾎﾟｰﾄを通して受信されます。

Solution Explorerからsensors.cppを開き、下図で示されるように中断点を配置してください。

実施事項

情報

次に      印の選択、またはｷｰﾎﾞｰﾄﾞでのF5ｷｰ押下によってﾃﾞﾊﾞｯｸﾞを始めてください。

端末(Terminal)ｳｨﾝﾄﾞｳに’SD Card initialization done’ﾒｯｾｰｼﾞが現れるでしょう。

光感知器はIO1 Xplained Pro上に存在し、感知器値は暗い時に増加し、明るい時に減少します。

感知器値が増すように指で感知器を覆ってください。感知器値が増加されたために条件(sensorValue≧500)が真
なら、下で示されるようにﾌﾟﾛｸﾞﾗﾑ実行が中断点(ﾌﾞﾚｰｸﾎﾟｲﾝﾄ)に行き当たるでしょう。

実施事項
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ﾃﾞﾊﾞｯｸﾞ中に感知器値を見るために、Debug⇒QuickWatch…を選んでください。式’sensorValue’を入力して’Add 
Watch’釦を選んでください。

監視1(Watch1)ｳｨﾝﾄﾞｳに’sensorValue’変数の値が表示されるでしょう。

実施事項

実施事項

実施事項

結果

結果

‘Watch1’ｳｨﾝﾄﾞｳと’QuickWatch’ｳｨﾝﾄﾞｳを閉じてください。

ｷｰﾎﾞｰﾄﾞでF5を押すことによって実行を続けてください。

感知器の値はSDｶｰﾄﾞに格納されmEDBG COMﾎﾟｰﾄを通して送信もされます。端末(Terminal)ｳｨﾝﾄﾞｳは光感知器値と
温度値を示すでしょう。

図5-4. Atmel Studio : 端末(Terminal)ｳｨﾝﾄﾞｳ
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実施事項

警告

Debug⇒Disable debugWIREを選ぶことによってﾃﾞﾊﾞｯｸﾞ動作を向けだしてください。

ﾃﾞﾊﾞｯｸﾞWIREを禁止することが重要です。

Atmel StudioでATmega328P Xplained MiniでのArduinoﾌﾟﾛｼﾞｪｸﾄを成功裏に追加しました。
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追補A. 課題4に対する完全な解決策
sensors.cppﾌｧｲﾙ

#include "arduino.h"
#include <Wire.h>
#include <SD.h>

#define AT30TSE_TEMPERATURE_TWI_ADDR 0x4F
#define AT30TSE_TEMPERATURE_REG 0x00
#define AT30TSE_TEMPERATURE_REG_SIZE 2
#define AT30TSE_NON_VOLATILE_REG 0x00

#define AT30TSE_CONFIG_RES_9_bit 0
#define AT30TSE_CONFIG_RES_10_bit 1
#define AT30TSE_CONFIG_RES_11_bit 2
#define AT30TSE_CONFIG_RES_12_bit 3

uint16_t resolution = AT30TSE_CONFIG_RES_10_bit;
double temp_result;
int sensorValue = 0; // A/D変換器(ADC) A0から読んだ値

const int analogInPin = A0; // ｱﾅﾛｸﾞ入力ﾋﾟﾝ
const int chipSelect = 10;

// SDﾕｰﾃｨﾘﾃｨ ﾗｲﾌﾞﾗﾘ関数を使うための変数を準備
File myFile;

void setup()
{
 Serial.begin(9600); // 直列通信を開く

 if (!SD.begin(chipSelect)) {
  Serial.println("SD Card initialization failed!");
  return;
 }
 Serial.println("SD Card initialization done.");

 SD.remove("data.txt");

 Wire.begin();
}

uint16_t at30tse_read_register(uint8_t reg, uint8_t reg_type, uint8_t reg_size)
{
 uint8_t buffer[2],i=0;
 buffer[0] = reg | reg_type;
 buffer[1] = 0;

 /* AT30TSEでの内部ﾚｼﾞｽﾀ ﾎﾟｲﾝﾀ */
 Wire.beginTransmission(AT30TSE_TEMPERATURE_TWI_ADDR);
 Wire.write(buffer[0]);
 Wire.endTransmission();

 Wire.requestFrom(AT30TSE_TEMPERATURE_TWI_ADDR, reg_size);

 while(Wire.available())
 {
  buffer[i] = Wire.read();
  i++;
 }

 return (buffer[0] << 8) | buffer[1];
}
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#include <Wire.h>
double at30tse_read_temperature()
{
 /* 16ﾋﾞｯﾄ温度ﾚｼﾞｽﾀ読み込み */
 uint16_t data = at30tse_read_register(AT30TSE_TEMPERATURE_REG,  AT30TSE_NON_VOLATILE_REG,
      AT30TSE_TEMPERATURE_REG_SIZE);

 double temperature = 0;
 int8_t sign = 1;

 /* 負検査と符号ﾋﾞｯﾄ解除 */
 if (data & (1 << 15)){
  sign *= -1;
  data &= ~(1 << 15);
 }

 /* 温度に変換 */
 switch (resolution){
  case AT30TSE_CONFIG_RES_9_bit:
   data = (data >> 7);
   temperature = data * sign * 0.5;
   break;
  case AT30TSE_CONFIG_RES_10_bit:
   data = (data >> 6);
   temperature = data * sign * 0.25;
   break;
  case AT30TSE_CONFIG_RES_11_bit:
   data = (data >> 5);
   temperature = data * sign * 0.125;
   break;
  case AT30TSE_CONFIG_RES_12_bit:
   data = (data >> 4);
   temperature = data * sign * 0.0625;
   break;
  default:
   break;
 }
 return temperature;
}
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bool sensor_flg=0;

void loop() {
 sensorValue = analogRead(analogInPin); // A/D変換器(ADC)読み込み
 temp_result = at30tse_read_temperature(); // 温度読み込み

 if (sensorValue>=500)
 {
  sensor_flg=1;
 }

 if (sensor_flg==1) // 特定感知器値をﾌｧｲﾙに書き込み
 {
  sensor_flg=0;

  myFile = SD.open("data.txt", FILE_WRITE);

  if (myFile) // ﾌｧｲﾙが開いていれば、それに書き込み
  {
   myFile.print("sensor = " );
   myFile.print(sensorValue);

   myFile.print("    temp = ");
   myFile.print(temp_result);
   myFile.print("\n");

   myFile.close(); // ﾌｧｲﾙを閉じる
  }
  else
  {
   // ﾌｧｲﾙが開かなければ異常を表示
   Serial.println("error opening data.txt");
  }

  // 読むために再びﾌｧｲﾙを開く
  myFile = SD.open("data.txt");
  if (myFile)
  {
   // 何も無くなるまでﾌｧｲﾙから読み込み
   while (myFile.available()) {
    Serial.write(myFile.read());
   }
   // ﾌｧｲﾙを閉じる
   myFile.close();
  } else {
   // ﾌｧｲﾙが開かなければ異常を表示
   Serial.println("error opening data.txt");
  }
 }
 delay(500);
}
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6. 結び
この実施訓練で以下の作業が達成されました。

● Atmel StudioへのArduino風ｺｰﾄﾞ書き形式支援を追加

● Arduinoﾌﾟﾛｼﾞｪｸﾄへﾃﾞﾊﾞｯｸﾞ能力を追加

● どんなｺｰﾄﾞ変更もなしにAtmel Xplained MiniとAtmel StudioでのArduinoﾌﾟﾛｼﾞｪｸﾄを置く

● もっと込み入った複雑なﾌﾟﾛｸﾞﾗﾑを書くことができる能力を追加

7. 改訂履歴

文書改訂 日付 注釈

42439A 2015年8月 初版文書公開
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