AVR 選択表

AVR 選択表 改訂4.51

このﾍﾙﾌﾟは一般の方々の便宜のため有志により作成されたもので、ATMEL社とは無関係であることを御承知ください。

注意
  • 本内容は各種資料から収集したものを再構成したものです。利用にあっては、対象ﾃﾞﾊﾞｲｽの資料で確認してください。
  • 本資料では分別の必要がない限り、動作範囲を示すｻﾌｨｯｸｽ(L,U,Vなど)を省略しています。 このため表記上実在しないﾃﾞﾊﾞｲｽ名(例えばATtiny28)となる場合があります。
  • xmegaを除くﾃﾞﾊﾞｲｽに於いて電源電圧と動作周波数は時期により定義法が異なるため一様ではありません。 基本的に旧定義法では最高周波数を可能とする電圧を、現定義法では動作保証電圧を電源電圧としています。 従って現定義法に於いて最高周波数で動作可能な電圧範囲は表記電圧ではなく、一般的に4.5～5.5Vです。 これ以下の電圧では動作可能周波数が電圧に応じて低減します。

[AVR系統図] [参考情報]					AVR 8-Bit RISC Micro-controller
ﾃﾞﾊﾞｲｽ名形状動作電圧低電圧
ﾘｾｯﾄ 		ｸﾛｯｸ元ﾒﾓﾘ(ﾊﾞｲﾄ)ｳｫｯﾁ
ﾄﾞｯｸﾞ 		割り込み最大
I/O数 		ﾀｲﾏ/ｶｳﾝﾀ直列I/Oｱﾅﾛｸﾞ入力命令 書き
込み		内蔵
ﾃﾞ
ﾊﾞ
ｯ
ｸﾞ
機能		備考
周波数内蔵RC
発振器		FlashRAMEEP
ROM		外部 数外部8/16
ﾋﾞｯﾄ		特殊
機能 		10ﾋﾞｯﾄ
A/D		比較器 数乗算
ATtiny46SOT1.8～5.5V1.4V
1.6V
2.4V
3.6V 		0～12MHz8MHz
/3V 		51232-- 〇 91(4)4,0,0 -/1PWM×2 - -1112- TPI-
ATtiny5 | 10 | 4(注)
ATtiny9 1K 9 -
ATtiny10 | 10 | 4(注)
ATtiny2014SOIC,14TSSOP
15UFBGA,20MLF
12WLCSP		1.8～5.5V1.8V
2.7V
4.3V 		0～12MHz8MHz
/3V 		2K128-- 〇 161(12)12,0,0 1/1PWM×4 SPI
TWI 		81112- TPI-
ATtiny4020SOIC,20TSSOP
20MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～12MHz8MHz
/3V 		4K256-- 〇 171(18)18,0,0 8×1
8/16×1		PWM×2 SPI
TWI 		121112- TPI-
旧ATtiny10L8DIP
8SOIC		2.7～5.5V- 0～2MHz1MHz
/5V 		1K
(OTP)		--- 〇 41(5)5,1,0 1/-- - -190- HS- ATtiny11のOTP版
新規入手困難
旧ATtiny10 | 4.0～5.5V | 0～6MHz
ATtiny11L8DIP
8SOIC		2.7～5.5V- 0～2MHz1MHz
/5V 		1K--- 〇 41(5)5,1,0 1/-- - -190- HS-
ATtiny11 | 4.0～5.5V | 0～6MHz
ATtiny12V8DIP
8SOIC		1.8～5.5V1.8V
2.7V 		0～1MHz1.2MHz
/5V 		1K-64- 〇 51(5)6,0,0 1/-- - -190- LS
HS		- ATtiny11の
EEPROM追加
機能増強版
ATtiny12L | 2.7～5.5V | 0～4MHz
ATtiny12 | 4.0～5.5V | 0～8MHz
ATtiny13V8DIP
8SOIC
10MLF
20MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz4.8MHz
9.6MHz
/3V 		1K6464- 〇 91(6)6,0,0 1/-PWM×2 - 41123- LS
HS
自己		dW ATtiny12の
機能増強版
ATtiny13 | 2.7～5.5V | 0～20MHz
ATtiny13A8DIP
8SOIC
10MLF
20MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz4.8MHz
9.6MHz
/3V 		1K6464- 〇 91(6)6,0,0 1/-PWM×2 - 41123- LS
HS
自己		dW ATtiny13の
後継版
ATtiny15L8DIP
8SOIC		2.7～5.5V2.7V
4.0V 		1.6MHz1.6MHz
/5V 		1K-64- 〇 81(5)6,0,0 2/-PWM×1 - 4190- LS
HS		-
ATtiny15 | 4.0～5.5V
ATtiny25V8DIP
8SOIC
20MLF		1.8～5.5V1.8V
2.3V
2.7V
4.3V 		0～10MHz6.4MHz
8.0MHz
/3V 		2K128128- 〇 141(5)6,0,0 2/-PWM×4 USI 41123- LS
HS
自己		dW ATtiny13,15の
ﾒﾓﾘ,機能増強版
ATtiny25 | 2.7～5.5V | 0～20MHz
ATtiny45V | 1.8～5.5V | 0～10MHz | 4K | 256 | 256
ATtiny45 | 2.7～5.5V | 0～20MHz
ATtiny85V | 1.8～5.5V | 0～10MHz | 8K | 512 | 512
ATtiny85 | 2.7～5.5V | 0～20MHz
ATtiny22L8DIP
8SOIC		2.7～6.0V- 約1MHz1MHz
/5V 		2K128128- 〇 215,0,0 1/-- - --118- LS
HS		- 新規入手困難
ATtiny24V14DIP
14SOIC
15UFBGA
20MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		2K128128- 〇 161(12)12,0,0 1/1PWM×4 USI 81123- LS
HS
自己		dW
ATtiny24 | 2.7～5.5V | 0～20MHz
ATtiny24A | 1.8～5.5V | 0～20MHz | 統合後継版
ATtiny44V | 1.8～5.5V | 0～10MHz | 4K | 256 | 256
ATtiny44 | 2.7～5.5V | 0～20MHz
ATtiny44A | 1.8～5.5V | 0～20MHz | 統合後継版
ATtiny84V | 1.8～5.5V | 0～10MHz | 8K | 512 | 512
ATtiny84 | 2.7～5.5V | 0～20MHz
ATtiny84A | 1.8～5.5V | 0～20MHz | 統合後継版
ATtiny44114SOIC
20MLF
20VQFN		1.7～5.5V1.8V
2.7V
4.3V 		0～16MHz8MHz
/3V 		4K256256- 〇 291(12)12,0,0 1/2PWM×6 USART×2
SPI
TWI 		122123- LS
HS
自己		dW
ATtiny841 | 8K | 512 | 512 | ATtiny441のﾒﾓﾘ増量版
ATtiny43U20SOIC
20MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		4K25664- 〇 151(16)16,0,0 2/-PWM×4 USI 41123- LS
HP
自己		dW 単ｾﾙ電池用
昇圧器内蔵
ATtiny2313V20DIP
20SOIC
20MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz4MHz
8MHz
/3V 		2K128128- 〇 182(8)18,0,0 1/1PWM×4 USART
USI 		-1123- LS
HP
自己		dW AT90S2313の
機能増強版
ATtiny2313 | 2.7～5.5V | 0～20MHz
ATtiny2313A20DIP
20SOIC
20MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz4MHz
8MHz
/3V 		2K128128- 〇 202(18)18,0,0 1/1PWM×4 USART
USI 		-1123- LS
HP
自己		dW ATtiny2313の
後継版
ATtiny43134K256256ATtiny2313Aの
ﾒﾓﾘ増量版
ATtiny26L20DIP
20SOIC
32MLF		2.7～5.5V2.7V
4.0V 		0～8MHz1,2,4,8
MHz
/5V 		2K128128- 〇 111(11)16,0,0 2/-PWM×2 USI 111119- LS
HP		-
ATtiny26 | 4.5～5.5V | 0～16MHz
ATtiny261V20DIP,20SOIC
32MLF		1.8～5.5V1.8V
2.3V
2.7V
4.3V 		0～10MHz8MHz
/3V 		2K128128- 〇 182(16)16,0,0 10×1
8/16×1		PWM×3 USI 111123- LS
HP
自己		dW ATtiny26の
機能増強版
ATtiny261 | 2.7～5.5V | 0～20MHz
ATtiny261A20DIP,20SOIC
32MLF,20TSSOP		1.8～5.5V0～20MHz統合後継版
ATtiny461V20DIP,20SOIC
32MLF		1.8～5.5V0～10MHz 4K256256ATtiny261の
ﾒﾓﾘ増量版
ATtiny461 | 2.7～5.5V | 0～20MHz
ATtiny461A20DIP,20SOIC
32MLF,20TSSOP		1.8～5.5V0～20MHz統合後継版
ATtiny861V20DIP,20SOIC
32MLF		1.8～5.5V0～10MHz 8K512512ATtiny461の
ﾒﾓﾘ増量版
ATtiny861 | 2.7～5.5V | 0～20MHz
ATtiny861A20DIP,20SOIC
32MLF,20TSSOP		1.8～5.5V0～20MHz統合後継版
ATtiny28V28DIP,32TQFP
32MLF		1.8～5.5V- 0～1MHz1.2MHz
/3V 		2K--- 〇 52(8)11,8,1 1/-- - -190- HP-
ATtiny28L | 2.7～5.5V | 0～4MHz
ATtiny4828DIP,28MLF
32TQFP,32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～12MHz8MHz
/3V 		4K25664- 〇 192(28)24/28,0,0 1/1PWM×2 SPI
TWI 		6,81123- LS
HP
自己		dW ATmega48の
簡略版
ATtiny88 8K512 ATmega88の
簡略版
ATtiny8720SOIC,20TSSOP
32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～16MHz8MHz
/3V 		8K512512- 〇 192(16)16,0,0 1/1PWM×3 SPI
USI
LIN/UART 		11
別途電流源		1123- LS
HP
自己		dW LIN制御器
ATtiny167 | 16K | 125
ATtiny82832TQFP
32MLF		1.7～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		8K512256- 〇 242(28)28,0,0 1/1PWM×4 USART
SPI
TWI 		281123- LS
HP
自己		dW
ATtiny163420SOIC,20MLF
20WLCSP		1.8～5.5V1.8V
2.7V
4.3V 		0～12MHz8MHz
/3V 		16K1K256- 〇 272(18)18,0,0 1/1PWM×4 USART×2
USI
TWI 		121125- LS
HP
自己		dW
AT90S120020DIP, 20SOIC
20SSOP		2.7～6.0V- 0～12MHz1MHz
/5V 		1K-64- 〇 3115,0,0 1/-- - -189- LS
HP		-
AT90S231320DIP
20SOIC		2.7～6.0V- 0～10MHz- 2K128128- 〇 10215,0,0 1/1PWM×1 UART -1118- LS
HP		- AT90S1200の
ﾒﾓﾘ,機能増強版
AT90LS23238DIP
8SOIC		2.7～6.0V- 0～4MHz- 2K128128- 〇 213,0,0 1/-- - --118- LS
HS		-
AT90S2323 | 4.0～6.0V | 0～10MHz
AT90LS23438DIP
8SOIC		2.7～6.0V- 0～4MHz1MHz
/5V 		2K128128- 〇 215,0,0 1/-- - --118- LS
HS		- AT90S2323の
RC発振器内蔵版
AT90S2343 | 4.0～6.0V | 0～10MHz
AT90LS233328DIP
32TQFP		2.7～6.0V2.7V
4.0V 		0～4MHz- 2K128128- 〇 13220,0,0 1/1PWM×1 UART
SPI 		61118- LS
HP		- 新規入手困難
AT90S2333 | 4.0～6.0V | 0～8MHz
AT90LS443328DIP
32TQFP		2.7～6.0V2.7V
4.0V 		0～4MHz- 4K128256- 〇 13220,0,0 1/1PWM×1 UART
SPI 		61118- LS
HP		- AT90S2333の
ﾒﾓﾘ増量版
AT90S4433 | 4.0～6.0V | 0～8MHz
AT90S4414-440DIP,44PLCC
44TQFP		2.7～6.0V- 0～4MHz- 4K256256〇 〇 12232,0,0 1/1PWM×2 UART
SPI 		-1118- LS
HP		- 新規入手困難
AT90S4414-8 | 4.0～6.0V | 0～8MHz
AT90S8515-440DIP,44PLCC
44TQFP		2.7～6.0V- 0～4MHz- 8K512512〇 〇 12232,0,0 1/1PWM×2 UART
SPI 		-1118- LS
HP		- AT90S4414の
ﾒﾓﾘ増量版
AT90S8515-8 | 4.0～6.0V | 0～8MHz
AT90LS443440DIP,44PLCC
44TQFP		2.7～6.0V- 0～4MHz- 4K256256- 〇 16232,0,0 2/1PWM×3
RTC 		UART
SPI 		81118- LS
HP		- 新規入手困難
AT90S4434 | 4.0～6.0V | 0～8MHz
AT90LS853540DIP,44PLCC
44TQFP,44MLF		2.7～6.0V- 0～4MHz- 8K512512- 〇 16232,0,0 2/1PWM×3
RTC 		UART
SPI 		81118- LS
HP		- AT90S4434の
ﾒﾓﾘ増量版
AT90S8535 | 4.0～6.0V | 0～8MHz
AT90C853448TQFP3.3～6.0V- 0～1.5MHz- 8K256512- - 620,2,7 1/1- - 6-118- LP- 変調器内蔵
AT90CAN3264TQFP
64MLF		2.7～5.5V2.5V
2.6V
2.7V
3.8V
3.9V
4.0V
4.1V 		0～16MHz8MHz
/3V 		32K2K1K〇 〇 37853,0,0 2/2PWM×8
RTC 		USART×2
SPI
TWI
CAN 		81134〇 LS
HP
自己		JTAG CAN制御器
AT90CAN64 | 64K | 4K | 2K
AT90CAN128 | 128K | 4K | 4K
ATmega16M132TQFP,32MLF2.7～5.5V2.6V
2.7V
4.3V
4.5V 		16MHz8MHz 16K1K512- 〇 304(27)27,0,0 1/1PWM×4
別途専用PWM×3 		SPI
LIN/UART
CAN 		11(+8)
別途D/A
別途電流源		-131〇 LS
HS
自己		dW 車載制御
応用特化
ATmega32M1 | 32K | 2K | 1K
ATmega32M1 | 64K | 4K | 2K
AT90PWM8120SO2.7～5.5V1.8V
1.9V
2.0V
2.2V
2.3V
2.7V
4.3V 		0～16MHz8MHz
/3V 		8K256512- 〇 19315,0,0 -/1別途専用PWM×2 SPI 83129〇 LS
HP
自己		dW 電力段制御用PWM
32QFN | 19,0,0 | 11
AT90PWM161 | 20SO | 16K | 1K | 15,0,0 | 8
32QFN | 19,0,0 | 11
AT90PWM124SO2.7～5.5V2.6V
2.7V
2.8V
4.2V
4.3V
4.4V
4.5V 		0～16MHz8MHz
/3V 		8K512512- 〇 21319,0,0 1/1別途専用PWM×2 SPI 82129〇 LS
HP
自己		dW 電力段制御用PWM
AT90PWM2
AT90PWM2B 		24 USART
(DALI)
SPI 		8
別途D/A
AT90PWM216 | 16K | 1K | 131 | AT90PWM2Bのﾒﾓﾘ増量版
AT90PWM3
AT90PWM3B		32SO,32QFN 8K512 28427,0,0 別途専用PWM×3 11
別途D/A		3 129 電力段制御用PWM
AT90PWM316 | 16K | 1K | 131 | AT90PWM3Bのﾒﾓﾘ増量版
AT90USB8232TQFP
32MLF		2.7～5.5V2.7V
2.9V
3.0V
3.5V
3.6V
4.0V
4.3V 		0～16MHz8MHz
/3V 		8K512512- 〇 288(13)23,0,0 1/1PWM×8 USART
SPI
USB
PS/2 		-1125- LS
HP
自己		dW USB装置
制御器
AT90USB162 | 16K
ATmega8U232TQFP
32MLF		2.7～5.5V2.7V
3.0V
3.5V
4.0V
4.3V 		0～16MHz8MHz
/3V 		8K512512- 〇 288(13)23,0,0 1/1PWM×8 USART
SPI
USB 		-1125- LS
HP
自己		dW USB装置
制御器
ATmega16U2 | 16K
ATmega32U2 | 32K | 1K | 1K
ATmega16U444TQFP
44QFN		2.7～5.5V2.0V
2.2V
2.4V
2.6V
3.4V
3.5V
4.3V 		0～16MHz8MHz
/3V 		16K1.25K512- 〇 365(8)26,0,0 1/2
10×1		PWM×12 USART
SPI
TWI
USB 		121131〇 LS
HP
自己		JTAG USB装置
制御器
ATmega32U4 | 32K | 2.5K | 1K
ATmega32U664TQFP
64MLF		2.7～5.5V2.6V
3.4V
3.5V
4.3V 		0～16MHz8MHz
/3V 		32K2.5K1K〇 〇 378(8)48,0,0 2/2PWM×10
RTC 		USART
SPI
TWI
USB 		81131〇 LS
HP
自己		JTAG AT90USB646の
ﾒﾓﾘ減少版
AT90USB64664TQFP
64MLF		2.7～5.5V2.6V
3.4V
3.5V
4.3V 		0～16MHz8MHz
/3V 		64K4K2K〇 〇 378(8)48,0,0 2/2PWM×10
RTC 		USART
SPI
TWI
USB 		81131〇 LS
HP
自己		JTAG USB装置
制御器
AT90USB647USBﾎｽﾄ/装置
制御器
AT90USB128664TQFP
64MLF		2.7～5.5V2.6V
3.4V
3.5V
4.3V 		0～16MHz8MHz
/3V 		128K8K4K〇 〇 378(8)48,0,0 2/2PWM×10
RTC 		USART
SPI
TWI
USB 		81134〇 LS
HP
自己		JTAG USB装置
制御器
AT90USB1287USBﾎｽﾄ/装置
制御器
ATmega8L28DIP,32TQFP
32MLF		2.7～5.5V2.7V
4.0V 		0～8MHz1,2,4,8
MHz
/5V 		8K1K512- 〇 18223,0,0 2/1PWM×3
RTC 		USART
SPI
TWI 		6,81128〇 LS
HP
自己		- AT90S4433の
ﾒﾓﾘ,機能増強版
ATmega8 | 4.5～5.5V | 0～16MHz
ATmega8A28DIP,32TQFP
32MLF		2.7～5.5V2.7V
4.0V 		0～16MHz1,2,4,8
MHz
/5V 		8K1K512- 〇 18223,0,0 2/1PWM×3
RTC 		USART
SPI
TWI 		6,81128〇 LS
HP
自己		- ATmega8の
後継版
ATmega48V28DIP,28MLF
32TQFP,32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		4K512256- 〇 252(23)23,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		6,81129〇 LS
HP
自己		dW ATmega88の
ﾒﾓﾘ減少版
ATmega48 | 2.7～5.5V | 0～20MHz
ATmega48PV28DIP,28MLF
32TQFP,32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		4K512256- 〇 252(23)23,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		6,81129〇 LS
HP
自己		dW ATmega48の
低消費電力版
ATmega48P | 2.7～5.5V | 0～20MHz
ATmega48A28DIP,28MLF
32TQFP,32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		4K512256- 〇 252(23)23,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		6,81129〇 LS
HP
自己		dW ATmega48(V)の
統合後継版
ATmega48PAATmega48Aの
低消費電力版
ATmega48PB32TQFP
32VFQFN		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		4K512256- 〇 262(23)27,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		81129〇 LS
HP
自己		dW ATmega48PAの
機能強化版
ATmega88V28DIP,32TQFP
32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		8K1K512- 〇 252(23)23,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		6,81129〇 LS
HP
自己		dW ATmega8の
ﾒﾓﾘ,機能強化版
ATmega88 | 2.7～5.5V | 0～20MHz
ATmega88PV28DIP,32TQFP
32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		8K1K512- 〇 252(23)23,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		6,81129〇 LS
HP
自己		dW ATmega88の
低消費電力版
ATmega88P | 2.7～5.5V | 0～20MHz
ATmega88A28DIP,28MLF
32TQFP,32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		8K1K512- 〇 252(23)23,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		6,81129〇 LS
HP
自己		dW ATmega88(V)の
統合後継版
ATmega88PAATmega88Aの
低消費電力版
ATmega88PB32TQFP
32VFQFN		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		8K1K512- 〇 262(23)27,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		81129〇 LS
HP
自己		dW ATmega88PAの
機能強化版
ATmega168V28DIP,32TQFP
32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		16K1K512- 〇 252(23)23,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		6,81131〇 LS
HP
自己		dW ATmega88の
ﾒﾓﾘ増加版
ATmega168 | 2.7～5.5V | 0～20MHz
ATmega168PV28DIP,32TQFP
32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		16K1K512- 〇 252(23)23,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		6,81131〇 LS
HP
自己		dW ATmega168の
低消費電力版
ATmega168P | 2.7～5.5V | 0～20MHz
ATmega168A28DIP,28MLF
32TQFP,32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		16K1K512- 〇 252(23)23,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		6,81131〇 LS
HP
自己		dW ATmega168(V)の
統合後継版
ATmega168PAATmega168Aの
低消費電力版
ATmega168PB32TQFP
32VFQFN		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		16K1K512- 〇 262(23)27,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		81129〇 LS
HP
自己		dW ATmega168PAの
機能強化版
ATmega32828DIP,32TQFP
32MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		32K2K1K- 〇 252(23)23,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		6,81131〇 LS
HP
自己		dW ATmega168Aの
ﾒﾓﾘ増加版
ATmega328PATmega328の
低消費電力版
ATmega8515L40DIP,44PLCC
44TQFP,44MLF		2.7～5.5V2.7V
4.0V 		0～8MHz1,2,4,8
MHz
/5V 		8K512512〇 〇 16335,0,0 1/1PWM×3 USART
SPI 		-1128〇 LS
HP
自己		- AT90S8515の
機能増強版
ATmega8515 | 4.5～5.5V | 0～16MHz
ATmega161L40DIP
44TQFP		2.7～5.5V- 0～4MHz- 16K1K512〇 〇 20335,0,0 2/1PWM×4
RTC 		UART×2
SPI 		-1130〇 LS
HP
自己		- AT90S8515の
ﾒﾓﾘ,機能増強版
ATmega161 | 4.0～5.5V | 0～8MHz
ATmega162V40DIP
44TQFP
44MLF		1.8～5.5V1.8V
(2.3V)
2.7V
4.3V 		0～8MHz8MHz
/3V 		16K1K512〇 〇 273(16)35,0,0 2/2PWM×6
RTC 		USART×2
SPI 		-1131〇 LS
HP
自己		JTAG ATmega161の
機能増強版
ATmega162 | 2.7～5.5V | 0～16MHz
ATmega83L40DIP
44TQFP		2.7～5.5V2.7V
4.0V 		0～4MHz1MHz
/5V 		8K512512- 〇 17232,0,0 2/1PWM×3
RTC 		UART
SPI
TWI 		81128〇 LS
HP
自己		- AT90S8535の
機能増強版(廃)
ATmega83 | 4.0～5.5V | 0～8MHz
ATmega163L40DIP
44TQFP		2.7～5.5V2.7V
4.0V 		0～4MHz1MHz
/5V 		16K1K512- 〇 17232,0,0 2/1PWM×3
RTC 		UART
SPI
TWI 		81130〇 LS
HP
自己		- ATmega83の
ﾒﾓﾘ増量版
ATmega163 | 4.0～5.5V | 0～8MHz
ATmega323L40DIP
44TQFP		2.7～5.5V2.7V
4.0V 		0～4MHz1MHz
/5V 		32K2K1K- 〇19332,0,0 2/1PWM×4
RTC 		USART
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega163の
ﾒﾓﾘ,機能増強版
ATmega323 | 4.0～5.5V | 0～8MHz
ATmega8535L40DIP,44PLCC
44TQFP,44MLF		2.7～5.5V2.7V
4.0V 		0～8MHz1,2,4,8
MHz
/5V 		8K512512- 〇 20332,0,0 2/1PWM×4 USART
SPI
TWI 		81128〇 LS
HP
自己		- AT90S8535の
機能増強版
ATmega8535 | 4.5～5.5V | 0～16MHz
ATmega16L40DIP,44TQFP
44MLF		2.7～5.5V2.7V
4.0V 		0～8MHz1,2,4,8
MHz
/5V 		16K1K512- 〇 20332,0,0 2/1PWM×4
RTC 		USART
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega163の
機能増強版
ATmega16 | 4.5～5.5V | 0～16MHz
ATmega16A44TQFP
44MLF		2.7～5.5V2.7V
4.0V 		0～16MHz1,2,4,8
MHz
/5V 		16K1K512- 〇 20332,0,0 2/1PWM×4
RTC 		USART
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega16の
後継版
ATmega32L40DIP,44TQFP
44MLF		2.7～5.5V2.7V
4.0V 		0～8MHz1,2,4,8
MHz
/5V 		32K2K1K- 〇 20332,0,0 2/1PWM×4
RTC 		USART
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega323の
機能強化版
ATmega32 | 4.5～5.5V | 0～16MHz
ATmega32A44TQFP
44MLF		2.7～5.5V2.7V
4.0V 		0～16MHz1,2,4,8
MHz
/5V 		32K2K1K- 〇 20332,0,0 2/1PWM×4
RTC 		USART
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega32の
後継版
ATmega164PV40DIP,44TQFP
44MLF,44DRQFN		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		16K1K512- 〇 303(32)32,0,0 2/1PWM×6
RTC 		USART×2
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega16の
機能増強版
ATmega164P | 2.7～5.5V | 0～20MHz
ATmega164A40DIP,44TQFP
44MLF,44DRQFN
49CGBA		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		16K1K512- 〇 303(32)32,0,0 2/1PWM×6
RTC 		USART×2
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega164PAの
非picoPower版
ATmega164PAATmega164P/PVの
統合後継版
ATmega324PV40DIP,44TQFP
44MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		32K2K1K- 〇 303(32)32,0,0 2/1PWM×6
RTC 		USART×2
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega32の
機能増強版
ATmega324P | 2.7～5.5V | 0～20MHz
ATmega324A40DIP,44TQFP
44MLF,44DRQFN
49CGBA		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		32K2K1K- 〇 303(32)32,0,0 2/1PWM×6
RTC 		USART×2
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega324PAの
非picoPower版
ATmega324PAATmega324P/PVの
統合後継版
ATmega644V40DIP,44TQFP
44MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		64K4K2K- 〇 273(32)32,0,0 2/1PWM×6
RTC 		USART
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega644Pへ移行
ATmega644 | 2.7～5.5V | 0～20MHz
ATmega644PV40DIP,44TQFP
44MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		64K4K2K- 〇 303(32)32,0,0 2/1PWM×6
RTC 		USART×2
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega324Pの
ﾒﾓﾘ増量版
ATmega644P | 2.7～5.5V | 0～20MHz
ATmega644A40DIP,44TQFP
44MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		64K4K2K- 〇 303(32)32,0,0 2/1PWM×6
RTC 		USART×2
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega644PAの
非picoPower版
ATmega644PAATmega644P/PVの
統合後継版
ATmega128440DIP,44TQFP
44MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		128K16K4K- 〇 303(32)32,0,0 2/1PWM×6
RTC 		USART×2
SPI
TWI 		81134〇 LS
HP
自己		JTAG ATmega1284Pの
非picoPower版
ATmega1284PATmega644PAの
ﾒﾓﾘ増量版
ATmega4HVD18DRDFN2.0～6.0V1.8V 4MHz4(8)MHz 4K512256- 〇 1525,0,0 8/16×2- - 1(+1+1)-129〇 LS
HS
自己		dW 単ｾﾙ
電池応用特化
ATmega8HVD | 8K
ATmega8HVA28TSOP,36LGA1.8～9V2.9V 4MHz4(8)MHz 8K512256- 〇 2037,0,0 2- SPI 2(+2+1)-129〇 LS
HS
自己		dW 1,2ｾﾙ
電池応用特化
ATmega16HVA | 16K | 131
ATmega16HVB44TSSOP4～25V2.9V 8MHz8MHz 16K1K512- 〇 284(12)17,0,1 8/16×2- SPI
TWI 		2(+4+1)-131〇 LS
HS
自己		dW 2,3,4ｾﾙ
電池応用特化
ATmega32HVB | 32K | 2K | 1K
ATmega40648LQFP4～25V2.7V 1MHz1(4)MHz 40K2K512- 〇 224(16)18,0,1 1/1PWM×2 TWI 5(+4+1)-131〇 HP
自己		JTAG 2,3,4ｾﾙ
電池応用特化
ATmega165V64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		16K1K512- 〇 211(16)53,0,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega169の
LCD制御器なし版
ATmega165 | 2.7～5.5V | 0～16MHz
ATmega165PV64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		16K1K512- 〇 211(16)53,0,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega165の
低消費電力版
ATmega165P | 2.7～5.5V | 0～16MHz
ATmega165A64TQFP
64MLF
64DRQFN		1.8～5.5V1.8V
2.7V
4.3V 		0～16MHz8MHz
/3V 		16K1K512- 〇 211(16)53,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega165/Vの
統合後継版
ATmega165PA ATmega165P/PVの
統合後継版
ATmega325V64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		32K2K1K- 〇 211(16)53,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega165の
ﾒﾓﾘ増量版
ATmega325 | 2.7～5.5V | 0～16MHz
ATmega325PV64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		32K2K1K- 〇 211(16)53,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega325の
低消費電力版
ATmega325P | 2.7～5.5V | 0～20MHz
ATmega325A64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		32K2K1K- 〇 211(16)53,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega325/Vの
統合後継版
ATmega325PA ATmega325P/PVの
統合後継版
ATmega645V64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		64K4K2K- 〇 211(16)53,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega325の
ﾒﾓﾘ増量版
ATmega645 | 2.7～5.5V | 0～16MHz
ATmega645A64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～16MHz8MHz
/3V 		16K1K512- 〇 211(16)53,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega645/Vの
統合後継版
ATmega645P ATmega645Aの
低電力版
ATmega169V64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		16K1K512- 〇 221(16)53,0,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega165の
25seg×4
LCD I/F付き
ATmega169 | 2.7～5.5V | 0～16MHz
ATmega169PV64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		16K1K512- 〇 221(16)53,0,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega169の
低消費電力版
ATmega169P | 2.7～5.5V | 0～16MHz
ATmega169A64TQFP
64MLF
64DRQFN		1.8～5.5V1.8V
2.7V
4.3V 		0～16MHz8MHz
/3V 		16K1K512- 〇 221(16)53,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega169/Vの
統合後継版
ATmega169PA ATmega169P/PVの
統合後継版
ATmega329V64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		32K2K1K- 〇 221(16)53,0,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega325の
25seg×4
LCD I/F付き
ATmega329 | 2.7～5.5V | 0～16MHz
ATmega329PV64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		32K2K1K- 〇 221(16)53,0,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega329の
低消費電力版
ATmega329P | 2.7～5.5V | 0～20MHz
ATmega329A64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		32K2K1K- 〇 221(16)53,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega329/Vの
統合後継版
ATmega329PA ATmega329P/PVの
統合後継版
ATmega649V64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		64K4K2K- 〇 221(16)53,0,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega325の
25seg×4
LCD I/F付き
ATmega649 | 2.7～5.5V | 0～16MHz
ATmega649A64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～16MHz8MHz
/3V 		16K1K512- 〇 221(16)53,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega649/Vの
統合後継版
ATmega649P ATmega649Aの
低電力版
ATmega3250V100TQFP1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		32K2K1K- 〇 241(31)68,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega325の
機能拡張版
ATmega3250 | 2.7～5.5V | 0～16MHz
ATmega3250PV100TQFP1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		32K2K1K- 〇 241(31)68,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega3250の
低消費電力版
ATmega3250P | 2.7～5.5V | 0～20MHz
ATmega3250A100TQFP1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		32K2K1K- 〇 241(31)68,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega3250/Vの
統合後継版
ATmega3250PA ATmega3250P/Vの
統合後継版
ATmega6450V100TQFP1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		64K4K2K- 〇 241(31)68,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega645の
機能拡張版
ATmega6450 | 2.7～5.5V | 0～16MHz
ATmega6450A100TQFP1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		64K4K2K- 〇 241(31)68,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega6450/Vの
統合後継版
ATmega6450P ATmega6450/Vの
低電力版
ATmega3290V100TQFP1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		32K2K1K- 〇 251(31)68,0,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega3250の
40seg×4
LCD I/F付き
ATmega3290 | 2.7～5.5V | 0～16MHz
ATmega3290PV100TQFP1.8～5.5V1.8V
2.7V
4.3V 		0～10MHz8MHz
/3V 		32K2K1K- 〇 251(31)68,0,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega3290の
低消費電力版
ATmega3290P | 2.7～5.5V | 0～20MHz
ATmega3290A100TQFP1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		32K2K1K- 〇 251(31)68,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega3290/Vの
統合後継版
ATmega3290PA ATmega3290P/Vの
統合後継版
ATmega6490V100TQFP1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		64K4K2K- 〇 251(31)68,0,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega6450の
40seg×4
LCD I/F付き
ATmega6490 | 2.7～5.5V | 0～16MHz
ATmega6490A100TQFP1.8～5.5V1.8V
2.7V
4.3V 		0～20MHz8MHz
/3V 		64K4K2K- 〇 251(31)68,1,0 2/1PWM×4
RTC 		USART
SPI
USI 		81131〇 LS
HP
自己		JTAG ATmega6490/Vの
統合後継版
ATmega6490P ATmega6490/Vの
低電力版
ATmega64L64TQFP
64MLF		2.7～5.5V2.7V
4.0V 		0～8MHz1,2,4,8
MHz
/5V 		64K4K2K〇 〇 34853,0,0 2/2PWM×6
RTC 		USART×2
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega603の
機能増強版
ATmega64 | 4.5～5.5V | 0～16MHz
ATmega64A64TQFP
64MLF		2.7～5.5V2.7V
4.0V 		0～16MHz1,2,4,8
MHz
/5V 		64K4K2K〇 〇 34853,0,0 2/2PWM×6
RTC 		USART×2
SPI
TWI 		81131〇 LS
HP
自己		JTAG ATmega64の
後継版
ATmega128L64TQFP
64MLF		2.7～5.5V2.7V
4.0V 		0～8MHz1,2,4,8
MHz
/5V 		128K4K4K〇 〇 34853,0,0 2/2PWM×6
RTC 		USART×2
SPI
TWI 		81134〇 LS
HP
自己		JTAG ATmega64の
ﾒﾓﾘ増量版
ATmega128 | 4.5～5.5V | 0～16MHz
ATmega128A64TQFP
64MLF		2.7～5.5V2.7V
4.0V 		0～16MHz1,2,4,8
MHz
/5V 		128K4K4K〇 〇 34853,0,0 2/2PWM×6
RTC 		USART×2
SPI
TWI 		81134〇 LS
HP
自己		JTAG ATmega128の
後継版
ATmega603L64TQFP2.7～3.6V- 0～4MHz- 64K4K2K〇 〇 23832,8,8 2/1PWM×4
RTC 		UART
SPI 		81121- LS
HP		- ATmega161,163
の合体増量版(廃)
ATmega603 | 4.0～5.5V | 0～6MHz
ATmega103L64TQFP2.7～3.6V- 0～4MHz- 128K40004K〇 〇 23832,8,8 2/1PWM×4
RTC 		UART
SPI 		81121- LS
HP		- ATmega603の
ﾒﾓﾘ増量版
ATmega103 | 4.0～5.5V | 0～6MHz
ATmega1281V64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		128K8K4K〇 〇 498(9)51,0,0 2/4PWM×9
RTC 		USART×2
SPI
TWI 		81134〇 LS
HP
自己		JTAG ATmega2561の
ﾒﾓﾘ減少版
ATmega1281 | 2.7～5.5V | 0～16MHz
ATmega2561V64TQFP
64MLF		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		256K8K4K〇 〇 498(9)51,0,0 2/4PWM×9
RTC 		USART×2
SPI
TWI 		81136〇 LS
HP
自己		JTAG ATmega2560の
機能縮小版
ATmega2561 | 2.7～5.5V | 0～16MHz
ATmega640V100TQFP
100CBGA		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		64K8K4K〇 〇 568(24)86,0,0 2/4PWM×16
RTC 		USART×4
SPI
TWI 		161131〇 LS
HP
自己		JTAG ATmega1280の
ﾒﾓﾘ減少版
ATmega640 | 2.7～5.5V | 0～16MHz
ATmega1280V100TQFP
100CBGA		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		128K8K4K〇 〇 568(24)86,0,0 2/4PWM×16
RTC 		USART×4
SPI
TWI 		161134〇 LS
HP
自己		JTAG ATmega2560の
ﾒﾓﾘ減少版
ATmega1280 | 2.7～5.5V | 0～16MHz
ATmega2560V100TQFP
100CBGA		1.8～5.5V1.8V
2.7V
4.3V 		0～8MHz8MHz
/3V 		256K8K4K〇 〇 568(24)86,0,0 2/4PWM×16
RTC 		USART×4
SPI
TWI 		161136〇 LS
HP
自己		JTAG ATmega128の
増量改良版
ATmega2560 | 2.7～5.5V | 0～16MHz
ﾃﾞﾊﾞｲｽ名形状動作電圧低電圧
ﾘｾｯﾄ 		ｸﾛｯｸ元ﾒﾓﾘ(ﾊﾞｲﾄ)ｳｫｯﾁ
ﾄﾞｯｸﾞ 		割り込み最大
I/O数 		16ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀ直列I/Oｱﾅﾛｸﾞ入出力命令 書き
込み		内蔵
ﾃﾞ
ﾊﾞ
ｯ
ｸﾞ
機能		DMA事象ｼｽﾃﾑ暗号ｴﾝｼﾞﾝ備考
周波数内蔵RC
発振器		FlashRAMEEP
ROM		外部 数外部4ch/2ch特殊
機能 		12ﾋﾞｯﾄ
A/D,
D/A		比較器 数乗算
ATxmega8E532TQFP
32QFN		1.6～3.6V1.6V
1.8V
2.0V
2.2V
2.4V
2.6V
2.8V
3.0V 		0～32MHz2,32MHz
/3V 		8K+2K1K512- 〇 422626 1/2PWM×8
RTC16 		USART×2
SPI×1
TWI×1 		12×1,
-		2141〇 PDI
自己		PDI 4
(EDMA)		8-XCL(注文論理回路)付き

各々は↑のﾒﾓﾘ増量版
ATxmega16E5 | 16K+4K | 2K | 512
ATxmega32E5 | 32K+4K | 4K | 1K
ATxmega16A444TQFP
44QFN
44BGA		1.6～3.6V1.63V
1.9V
2.17V
2.43V
2.68V
2.96V
3.22V
3.49V 		0～32MHz2,32MHz
/3V 		16K+4K2K1K- 〇 803434 3/2PWM×16
RTC16 		USART×5
SPI×2
TWI×2 		12×1,
2×1		2138〇 PDI
自己		PDI 48〇D4系の機能増強版

各々は↑のﾒﾓﾘ増量版
ATxmega32A4 | 32K+4K | 4K | 1K
ATxmega64A4 | 64K+4K | 4K | 2K
ATxmega128A4 | 128K+8K | 8K | 2K
ATxmega16A4U44TQFP
44QFN
44BGA		1.6～3.6V1.62V
1.81V
2.01V
2.21V
2.41V
2.61V
2.81V
3.00V 		0～32MHz2,32MHz
/3V 		16K+4K2K1K- 〇 823434 3/2PWM×16
RTC16 		USART×5
SPI×2
TWI×2
 USB×1 		12×1,
2×1		2142〇 PDI
自己		PDI 48〇各々A4系のUSB追加版

各々は↑のﾒﾓﾘ増量版
ATxmega32A4U | 32K+4K | 4K | 1K
ATxmega64A4U | 64K+4K | 4K | 2K
ATxmega128A4U | 128K+8K | 8K | 2K
ATxmega16C444TQFP
44QFN
44BGA		1.6～3.6V1.62V
1.8V
2.0V
2.2V
2.4V
2.6V
2.8V
3.0V 		0～32MHz2,32MHz
/3V 		16K+4K2K1K- 〇 603434 3/1PWM×14
RTC16 		USART×3
SPI×2
TWI×2
 USB×1 		12×1,
-		2141〇 PDI
自己		PDI -4-各々A4U系の機能縮小版

32C4は16C4のﾒﾓﾘ増量版
ATxmega32C4 | 32K+4K | 4K | 1K
ATxmega16D444TQFP
44QFN
44BGA		1.6～3.6V1.63V
1.9V
2.17V
2.43V
2.68V
2.96V
3.22V
3.49V 		0～32MHz2,32MHz
/3V 		16K+4K2K1K- 〇 543434 3/1PWM×14
RTC16 		USART×2
SPI×2
TWI×2 		12×1,
-		2137〇 PDI
自己		PDI -4-A4系の機能減少版

各々は↑のﾒﾓﾘ増量版
ATxmega32D4 | 32K+4K | 4K | 1K
ATxmega64D4 | 64K+4K | 4K | 2K
ATxmega128D4 | 128K+8K | 8K | 2K
ATxmega64A364TQFP
64QFN		1.6～3.6V1.63V
1.9V
2.17V
2.43V
2.68V
2.96V
3.22V
3.49V 		0～32MHz2,32MHz
/3V 		64K+4K4K2K- 〇 1025050 4/3PWM×22
RTC16 		USART×7
SPI×3
TWI×2 		8×2,
2×1		4138〇 PDI
JTAG
自己		PDI
JTAG 		48〇D3系の機能増強版

各々は↑のﾒﾓﾘ増量版
ATxmega128A3 | 128K+8K | 8K | 2K
ATxmega192A3 | 192K+8K | 16K | 2K
ATxmega256A3 | 256K+8K | 16K | 4K
ATxmega256A3B 256K+8K16K4K 984747 PWM×22
RTC32 		USART×6
SPI×2
TWI×2 		ATxmega256A3の電池代替支援対応版
ATxmega64A3U64TQFP
64QFN		1.6～3.6V1.62V
1.81V
2.01V
2.21V
2.41V
2.61V
2.81V
3.01V 		0～32MHz2,32MHz
/3V 		64K+4K4K2K- 〇 1045050 4/3PWM×22
RTC16 		USART×7
SPI×3
TWI×2
 USB×1 		8×2,
2×1		4142〇 PDI
JTAG
自己		PDI
JTAG 		48〇各々A3(B)系のUSB追加版

各々は↑のﾒﾓﾘ増量版
ATxmega128A3U | 128K+8K | 8K | 2K
ATxmega192A3U | 192K+8K | 16K | 2K
ATxmega256A3U | 256K+8K | 16K | 4K
ATxmega256A3BU 256K+8K16K4K 984747 PWM×22
RTC32 		USART×6
SPI×2
TWI×2
USB×1
ATxmega32C364TQFP
64QFN		1.6～3.6V1.62V
1.8V
2.0V
2.2V
2.4V
2.6V
2.8V
3.0V 		0～32MHz2,32MHz
/3V 		32K+4K4K1K- 〇 685050 4/1PWM×18
RTC16 		USART×3
SPI×2
TWI×2
 USB×1 		16×1,
-		4141〇 PDI
自己		PDI -4-各々A3U系の機能縮小版

各々は↑のﾒﾓﾘ増量版
ATxmega64C3 | 64K+4K | 4K | 2K
ATxmega128C3 | 128K+8K | 8K | 2K
ATxmega192C3 | 192K+8K | 16K | 2K
ATxmega256C3 | 256K+8K | 16K | 4K
ATxmega384C3 384K+8K32K4K 24○
ATxmega64B364TQFP
64QFN		1.6～3.6V1.6V
1.8V
2.0V
2.2V
2.4V
2.6V
2.8V
3.0V 		0～32MHz2,32MHz
/3V 		64K+4K4K2K- 〇 423636 1/1PWM×6
RTC16 		USART×1
SPI×1
TWI×1
 USB×1 		8×1,
-		4142〇 PDI
JTAG
自己		PDI
JTAG 		24〇各々A3U系の4×25seg LCD追加、他機能縮小版

128B3は64B3のﾒﾓﾘ増量版
ATxmega128B3 | 128K+8K | 8K | 2K
ATxmega32D364TQFP
64QFN		1.6～3.6V1.63V
1.9V
2.17V
2.43V
2.68V
2.96V
3.22V
3.49V 		0～32MHz2,32MHz
/3V 		32K+4K4K1K- 〇 645050 4/1PWM×18
RTC16 		USART×3
SPI×2
TWI×2 		16×1,
-		4137〇 PDI
自己		PDI -4-A3系の機能減少版

各々は↑のﾒﾓﾘ増量版
ATxmega64D3 | 64K+4K | 4K | 2K
ATxmega128D3 | 128K+8K | 8K | 2K
ATxmega192D3 | 192K+8K | 16K | 2K
ATxmega256D3 | 256K+8K | 16K | 4K
ATxmega384D3 | 384K+8K | 32K | 4K
ATxmega64A1100TQFP
100BGA		1.6～3.6V1.6V
1.9V
2.1V
2.4V
2.6V
2.9V
3.2V
3.4V 		0～32MHz2,32MHz
/3V 		64K+4K4K2K〇 〇 1227878 4/4PWM×24
RTC16 		USART×8
SPI×4
TWI×4 		8×2,
2×2		4138〇 PDI
JTAG
自己		PDI
JTAG 		48〇A3系の機能強化版

各々は↑のﾒﾓﾘ増量版
ATxmega128A1 | 128K+8K | 8K | 2K
ATxmega192A1 | 192K+8K | 16K | 2K
ATxmega256A1 | 256K+8K | 16K | 4K
ATxmega384A1 | 384K+8K | 32K | 4K
ATxmega64A1U100TQFP
100BGA		1.6～3.6V1.6V
1.9V
2.1V
2.4V
2.6V
2.9V
3.2V
3.4V 		0～32MHz2,32MHz
/3V 		64K+4K4K2K〇 〇 1247878 4/4PWM×24
RTC16 		USART×8
SPI×4
TWI×4
USB×1 		8×2,
2×2		4142〇 PDI
JTAG
自己		PDI
JTAG 		48〇各々A1系のUSB追加版

128A1Uは64A1Uのﾒﾓﾘ増量版
ATxmega128A1U | 128K+8K | 8K | 2K
ATxmega64B1100TQFP
100BGA		1.6～3.6V1.6V
1.8V
2.0V
2.2V
2.4V
2.6V
2.8V
3.0V 		0～32MHz2,32MHz
/3V 		64K+4K4K2K- 〇 605353 2/1PWM×10
RTC16 		USART×2
SPI×1
TWI×1
 USB×1 		8×2,
-		4142〇 PDI
JTAG
自己		PDI
JTAG 		24〇各々A3U系の4×40seg LCD追加、他機能縮小版

128B1は64B1のﾒﾓﾘ増量版
ATxmega128B1 | 128K+8K | 8K | 2K

© HERO 2014.


AVR選択: 系統図

系統図

AVRの系統図を以下に示します。 確実に確認できなかったﾃﾞﾊﾞｲｽについては一部推測を含めて分類しています。 基本的に同系統(互換関係)群間と系統群内はそれぞれ下から上へ向かってﾌﾗｯｼｭ ﾒﾓﾘ搭載量順、左から右へ向かって機能量順となっています。 互換関係内は基本的にﾋﾟﾝ互換ですが、厳密には機能上位ﾋﾟﾝ互換です。 互換枠内( )内数値はﾋﾟﾝ数で、記述が2つある場合は基本的に左側がPDIP, SOIC、右側がTQFP, PLCC, QFN/MLFです。 赤文字のﾃﾞﾊﾞｲｽは新規入手困難と思われるものです。


AVR選択: ﾃﾞﾊﾞｲｽ名

ﾃﾞﾊﾞｲｽ名

正式な型番(製品番号)は次の形式です。
AT | xxx | nnn | e | v | - | ss | p | t

上記 - (ﾊｲﾌﾝ)の左側が一般的に呼称されるﾃﾞﾊﾞｲｽ名です。 各部は右表の項目を表します。

一部のﾃﾞﾊﾞｲｽは速度種別に応じて xxx 部の一部が変更されることに注意してください。

部分 |  | 項目の意味 | 取り得る文字
 | AT | 製造業者名 | (AT固定)
 | xxx | 系統名 | ｱﾙﾌｧﾍﾞｯﾄと数字
 | nnn | 系統内の個別名 | 数字
 | e | 構造種別識別名 | ｱﾙﾌｧﾍﾞｯﾄ
 | v | 動作電圧範囲識別名 | ｱﾙﾌｧﾍﾞｯﾄ
 | ss | 最高動作速度 | 数字
 | p | 外囲器識別名 | ｱﾙﾌｧﾍﾞｯﾄ
 | t | 動作温度範囲識別名 | ｱﾙﾌｧﾍﾞｯﾄ

各項目の概要は以下で示されます。 これらの具体的な組み合わせや、外囲器の詳細については個別ﾃﾞｰﾀｼｰﾄを参照してください。

■ 製造業者名

先頭の AT は製造業者ATMELを表します。

■ 系統名

製造業者名 AT に続く xxx はAVR系統の大別を表します。 これらには基本群の3種類とそれらから派生した特定目的用名称があります。

系統名 | 意味
90S, 90LS | ｸﾗｯｼｯｸ系統とも呼ばれていた初期の製品名です。 系統名自体は 90S ですが、一部のﾃﾞﾊﾞｲｽは本来の動作電圧範囲識別位置を使用せず、これを 90 と S 間に挿入し、90LS になります。
tiny | 小規模現行製品名です。
mega | 大規模現行製品名です。
90C | 90S 派生の特定目的製品名です。 (初期製品)
90CAN | mega派生のCAN(Controller Area Network)特定目的製品名です。 後続製品はmegaCn(nは数字)になります。
90PWM | mega派生のPWM電力制御の特定目的製品名です。 後続製品はmegaMn(nは数字)になります。
90USB | mega派生のUSB制御器付きのUSB応用目的製品名です。 後続製品はmegaUn(nは数字)になります。

■ 系統内個別名

系統名 xxx に続く nnn は系統内の個別識別名を数字で表します。 特別な場合に於いて、それに続く e で nnn の違いを表します。 これらの命名規則は系統によって異なります。

90S,90LS

4桁の数字 nnnn で示され、各桁の意味は次の通りです。
桁位置 | 意味
1 | ﾌﾗｯｼｭ ﾒﾓﾘ容量(数値×1Kﾊﾞｲﾄ)。
2 | EEPROM容量(2の(数値+4)乗ﾊﾞｲﾄ、右表参照)。
3 | 系統番号。
4 | SRAM容量(2の(数値+4)乗ﾊﾞｲﾄ、右表参照)。

系統番号の意味は次の通りです。

系統番号 | 意味
0 | 最初の製品。
1 | 上記の改良版。 8051ﾋﾟﾝ互換を意識した製品。
2 | 外部ｸﾛｯｸ用の基本8ﾋﾟﾝの製品。
3 | A/D変換器付きの製品。
4 | 内部ｸﾛｯｸ用の基本8ﾋﾟﾝの製品。
5 | -
6 | -
7 | -
8 | -
9 | -

数値 | 容量(ﾊﾞｲﾄ)
0 | 0
1 | 32
2 | 64
3 | 128
4 | 256
5 | 512

tiny

基本的に2桁の数字 nn で示されますが、改良品の場合は1桁追加され、3桁の数字 nnn で示されます。 各桁の意味は以下の通りですが、2313だけは[90S]系統の後継品の位置付けのため、本規則ではなく、[90S]系統の規則に従います。
桁位置 | 意味
1 | ﾌﾗｯｼｭ ﾒﾓﾘ容量(数値×1Kﾊﾞｲﾄ)。
2 | 系統番号。
3 | 改良品番号(現状は1のみ)。

系統番号の意味は右表の通りです。

系統番号 | 意味
0 | OTP(書き換え不可)の基本8ﾋﾟﾝの製品。
1 | 基本8ﾋﾟﾝの製品。
2 | 上記の改良版。
3 | 上記の更なる改良版。
4 | 基本14ﾋﾟﾝの製品。
5 | 高速PWM用途の基本8ﾋﾟﾝ製品。
6 | 高速PWM用途の基本20ﾋﾟﾝ製品。
7 | -
8 | 赤外ﾘﾓｺﾝ用途の製品。
9 | -

mega

基本的に1～4桁の数字 n ～ nnnn で示されますが、一部の製品でそれに続く e も使用され、一様の規則ではありません。 また、8515と8535は[90S]系統の後継品の位置付けのため、本規則ではなく、[90S]系統の規則に従います。 基本的な構成は次の順です。

  1. ﾌﾗｯｼｭ ﾒﾓﾘ容量
  2. 系統番号
  3. 重複回避識別番号
  4. 構造種別文字 ( e )

  • ﾌﾗｯｼｭ ﾒﾓﾘ容量

    1～3桁で表されます。 一部の例外(60,10)を除いて、この数値は1Kﾊﾞｲﾄ単位のﾌﾗｯｼｭ ﾒﾓﾘ容量を表します。 現状は次の通りです。

    数字 | 4 | 8 | 16 | 32 | 40 | 60 | 64 | 10 | 128 | 256
    容量(Kﾊﾞｲﾄ) | 4 | 8 | 16 | 32 | 40 | 64 | 128 | 256

  • 系統番号・系統種別

    ﾌﾗｯｼｭ ﾒﾓﾘ容量桁の後ろに付加された1桁の数字は系統を表します。

    系統番号・系統種別 | 意味
    0-
    1 | 8051ﾋﾟﾝ互換を意識した基本40ﾋﾟﾝの製品。
    2 | 上記の改良版。
    3 | 基本40ﾋﾟﾝの製品。
    4 | 上記の改良版。
    5 | 基本64ﾋﾟﾝが基本の製品
    6 | 電池充電器用途の製品。
    7-
    8 | 基本28ﾋﾟﾝの製品。
    9 | LCDｲﾝﾀｰﾌｪｰｽ付きの製品
    C | CANｲﾝﾀｰﾌｪｰｽ付きの製品
    M | ﾓｰﾀ等の電力制御用にPWMを増強した製品
    U | USBｲﾝﾀｰﾌｪｰｽ付きの製品

    一部のﾃﾞﾊﾞｲｽで系統番号・系統種別がないことに注意してください。

  • 系統種別内識別番号

    これは上記で系統種別文字を持つﾃﾞﾊﾞｲｽに於いて、系統種別文字の次の番号です。 この番号は基本的にそのﾃﾞﾊﾞｲｽの規模を表し、より大きな番号がより大きな規模です。

  • 重複回避識別番号

    これは個別番号の重複を避ける結果的になっています。 本来、末尾1桁の 0 付加は元となる64ﾋﾟﾝ ﾃﾞﾊﾞｲｽの100ﾋﾟﾝ拡張版を表します。 例えば 329 と 3290 などが該当します。 ところが 1280 の64ﾋﾟﾝ版は 128 となり、既存名と重複してしまいます。 このため、このような状態の場合、末尾に1桁の 1 を付加し、重複名を避けています。 2560 の場合は既存名との重複がないのですが、 1280 と同一系統のため、これに従って 2561 になっています。

  • 構造種別文字

    これは元となる製品に対する拡張/別種指示に用いられます。 従って元となる製品には、この構造種別文字はありません。 資料作成時点での構造種別文字は以下のみです。

    構造種別文字 | 意味
    A | 既存ﾃﾞﾊﾞｲｽの直接の後継製品
    P | picoPower技術(超低消費電力)製品

上記の2つが同時に記される場合は、P,Aの順です。

■ 動作電圧範囲識別名

系統内の個別識別名 nnn に続く1桁の文字 v と、本文字の未存在は、動作電圧範囲を表します。 [90S]系統の一部のﾃﾞﾊﾞｲｽの L 版が本位置を使用せず、系統名に合成されて 90LS となることに注意してください。 また、一部特定目的ﾃﾞﾊﾞｲｽが固有の動作電圧範囲のため、本規則に従わないことにも注意してください。
文字 | 動作電圧範囲(V)
 | 旧定義 | 現定義
なし | 4.0～5.5/6.0 | [xmega]系 : 1.6～3.6 [xmega]系以外の最近のﾃﾞﾊﾞｲｽ : 1.8～5.5 上記以外 : 2.7～5.5
L | 2.7～5.5/6.0 | -
U | 2.4～4.0/5.5 | -
V | 1.8～3.6/5.5 | 1.8～5.5

動作電圧範囲識別文字 なし を除いて、基本的に旧ｺｱは L 、最近は V の製品が殆どです。 過去の一時期、特に[mega]系統に於いて全ての動作電圧範囲の製品が出されていましたが、現在は なし と V に統合されています。 U は現状製品に存在しません。 また現在、全ての製品に於いて動作電圧範囲は単一の なし で統合中です。

旧定義内の上限電圧は概ね旧ｺｱが6.0V、新ｺｱが5.5Vで、他の電圧は特定用途向け製品の場合です。

■ 最高動作速度

最高動作速度識別数字は[xmega]系以外のﾃﾞﾊﾞｲｽに存在し、- の後ろの ss が最高動作速度(MHz)を表します。 この最高動作速度が必ずしも動作電圧範囲全域での動作を保証するものでないことに注意してください。 最近の製品に対しては、動作電圧範囲識別文字 なし の製品が4.5～5.5V、V の製品が2.7～5.5Vでの最高動作速度を示します。

■ 外囲器識別名

最高動作速度 ss に続く1または2桁の文字 pp は外囲器種別を表します。
文字 | 外囲器種別
A | TQFP, LQFP
C | CBGA
J | PLCC
M | QFN/MLF
P | PDIP
S | SOIC (EIAJ)
SS | SOIC (JEDEC)
Y | SSOP

AVRで使用される具体的な外囲器は次の通りです。
選択一覧表 識別名 | 外囲器種別
8DIP | 8ﾋﾟﾝ 300mil幅 | ﾌﾟﾗｽﾃｨｯｸ2重直線外囲器 (PDIP)
20DIP | 20ﾋﾟﾝ 300mil幅
28DIP | 28ﾋﾟﾝ 300mil幅
40DIP | 40ﾋﾟﾝ 600mil幅
8SOIC | 8ﾋﾟﾝ 200/209mil幅 | ﾌﾟﾗｽﾃｨｯｸ小外形外囲器 (EIAJ SOIC)
 | 8ﾋﾟﾝ 150mil幅 | ﾌﾟﾗｽﾃｨｯｸ小外形外囲器 (JEDEC SOIC)
14SOIC | 14ﾋﾟﾝ 150mil幅 | ﾌﾟﾗｽﾃｨｯｸ小外形外囲器 (SOIC)
20SOIC | 20ﾋﾟﾝ 300mil幅
20SO | 20ﾋﾟﾝ | 小外形外囲器 (SOIC)
24SO | 24ﾋﾟﾝ
32SO | 32ﾋﾟﾝ
6SOT | 6ﾘｰﾄﾞ 2.90×1.60mm | ﾌﾟﾗｽﾃｨｯｸ小型外形外囲器 (SOT23)
12WLCSP | 12球 1.54×1.338mm | ｳｪﾊｰ水準ﾁｯﾌﾟ尺度外囲器 (WLCSP)
20WLCSP | 20球 2.38×2.02mm | ｳｪﾊｰ水準ﾁｯﾌﾟ尺度外囲器 (WLCSP)
20SSOP | 20ﾋﾟﾝ 5.3mm幅 | ﾌﾟﾗｽﾃｨｯｸ 縮小外形外囲器 (SSOP)
28TSOP | 28ﾋﾟﾝ 8×13.4×1mm 0.55mmﾋﾟｯﾁ | ﾌﾟﾗｽﾃｨｯｸ薄型小外形外囲器 (SSOP)
14TSSOP | 14ﾘｰﾄﾞ | ﾌﾟﾗｽﾃｨｯｸ縮小薄型小外形外囲器(TSSOP)
20TSSOP | 20ﾘｰﾄﾞ
44TSSOP | 44ﾘｰﾄﾞ
44PLCC | 44ﾘｰﾄﾞ | ﾌﾟﾗｽﾃｨｯｸ Jﾘｰﾄﾞ ﾁｯﾌﾟ ｷｬﾘｱ (PLCC)
32TQFP | 32ﾋﾟﾝ 7×7×1mm 0.8mmﾋﾟｯﾁ | ﾌﾟﾗｽﾃｨｯｸ4方向平板外囲器 (TQFP)
44TQFP | 44ﾋﾟﾝ 10×10×1mm 0.8mmﾋﾟｯﾁ
48TQFP | 48ﾋﾟﾝ 7×7×1mm 0.5mmﾋﾟｯﾁ
48LQFP | 48ﾋﾟﾝ 7×7×1.44mm 0.5mmﾋﾟｯﾁ | ﾌﾟﾗｽﾃｨｯｸ4方向平板外囲器 (LQFP)
64TQFP | 64ﾋﾟﾝ 14×14×1.0mm 0.8mmﾋﾟｯﾁ | ﾌﾟﾗｽﾃｨｯｸ4方向平板外囲器 (TQFP)
100TQFP | 100ﾋﾟﾝ 14×14×1mm 0.5mmﾋﾟｯﾁ
10MLF | 10ﾋﾟﾝ 3×3×1mm 0.5mmﾋﾟｯﾁ | 4方向平板ﾘｰﾄﾞなし/小ﾘｰﾄﾞ枠外囲器 (QFN/MLF)
20VQFN | 20ﾋﾟﾝ 3×3×0.8mm 0.45mmﾋﾟｯﾁ
20MLF | 20ﾋﾟﾝ 4×4×0.75mm 0.5mmﾋﾟｯﾁ
28MLF | 28ﾋﾟﾝ 4×4×1mm 0.45mmﾋﾟｯﾁ
32MLF | 32ﾋﾟﾝ 5×5×1mm 0.5mmﾋﾟｯﾁ
32QFN | 32ﾋﾟﾝ 7×7×1mm 0.65mmﾋﾟｯﾁ
44MLF | 44ﾋﾟﾝ 7×7×1mm 0.5mmﾋﾟｯﾁ
64MLF | 64ﾋﾟﾝ 9×9×1mm 0.5mmﾋﾟｯﾁ
44DRQFN | 44ﾋﾟﾝ(2列千鳥) 5×5×1mm 0.4mmﾋﾟｯﾁ | 2列千鳥4方向平板ﾘｰﾄﾞなし外囲器 (DRQFN)
64DRQFN | 64ﾋﾟﾝ(2列千鳥) 5×5×0.9mm 0.65mmﾋﾟｯﾁ
36LGA | 36ﾊﾟｯﾄﾞ 6.5×3.5×0.85mm 0.6mmﾋﾟｯﾁ | 格子配列着点外囲器 (LGA)
15UFBGA | 15球 3×3×0.6mm 0.65mmﾋﾟｯﾁ | 極薄細密間隔球格子配列外囲器 (UFBGA)
49CGBA | 49球 5×5×1.0mm 0.65mmﾋﾟｯﾁ | 球辺格子配列外囲器 (CBGA)
100CGBA | 100球 9×9×1.2mm 0.8mmﾋﾟｯﾁ | 球辺格子配列外囲器 (CBGA)

■ 動作温度範囲識別名

末尾1桁の文字 t は動作温度範囲を表します。
文字 | 動作温度範囲
A | -30～85℃(RoHS適合)
C | 0～70℃
I | -40～85℃
Q | -40～105℃(RoHS適合)
U | -40～85℃(RoHS適合)

旧製品の温度範囲は C と I です。 RoHS適合化のため、現状の主な製品は全て U に統合され、従って動作温度範囲は基本的に-40～85℃です。 他の温度範囲は特定用途向け製品です。


AVR選択: 動作電圧

動作電圧

動作電圧と動作周波数は時期によって定義法が異なるため一様ではありません。 基本的に旧定義法では最高動作周波数で動作可能な電圧範囲を動作電圧として表します。 現定義法は動作保証電圧範囲を表し、この範囲内での最高動作周波数は動作電圧に依存して変化します。 従ってこの場合の最高動作周波数での動作可能電圧範囲は表記電圧ではなく、一般的に4.5～5.5Vです。 これ以下の電圧では基本的に動作可能周波数が電圧に応じて直線的に低減します。 これらの関係の詳細については対象ﾃﾞﾊﾞｲｽのﾃﾞｰﾀｼｰﾄをご覧ください。
  • [mega] 4HVD, 8HVD, 8HVA, 16HVA, 16HVB, 32HVB, 406は安定化電源部を内蔵しており、外部からの非安定電源で動作できます。 この入力電圧範囲は4HVD, 8HVDが2.1～6.0V、8HVA, 16HVAが1.8～9.0V、16HVB, 32HVB, 406が4～25Vです。 安定化電源部の出力電圧は各々、2.2V、3.3V、3.3Vです。 従って安定化電源部を除く一般的な部分は、基本的に2.2V、3.3V、3.3V動作と考えられます。
  • [tiny] 43Uは昇圧ｽｨｯﾁﾝｸﾞ電源部を内蔵しており、0.7Vまでの低い電圧入力で動作できます。 この場合の入力電圧範囲は0.7～1.8Vで、昇圧電源部を除く他の部分は3.3Vで動作します。
  • [90USB] 82, 162, 646, 647, 1286, 1287と[mega] 8U2, 16U2, 16U4, 32U2, 32U4, 32U6はUSB信号線(D-,D+)用の安定化電源部を内蔵しており、VCCが4.0～5.5Vの場合に利用できます。これは一般的にUSBのVBUSをVCCとする場合を想定しています。 3.0～3.6Vの場合は安定化電源部なしで直接駆動できます。 [90USB] 646, 647, 1286, 1287と[mega] 32U6はその場合の外部/内部の切り替え機能も内蔵しています。
  • [xmega]系の電源電圧は1.6～3.6Vです。
  • [xmega] 256A3B, 256A3BU は電池での実時間計数器の継続動作を容易にする、電池代替支援ｼｽﾃﾑを持っています。


AVR選択: 低電圧検出ﾘｾｯﾄ

低電圧検出(BOD)ﾘｾｯﾄ

旧製品を除いて、殆どのAVRには低電圧検出(BOD)ﾘｾｯﾄがあります。 これは俗に言うﾘｾｯﾄIC相当機能で、特に電源ON/OFF時に於ける安定な動作を保証します。 けれども次の点を考慮しなければなりません。
  • 外部にﾘｾｯﾄ信号を出力できませんので、他のﾃﾞﾊﾞｲｽがﾘｾｯﾄ信号を必要とする場合は利用できないでしょう。
  • 一般的に低消費型専用ﾘｾｯﾄICより多目の電力を消費します。 但し、picoPower技術導入(主に末尾P付き)製品では、特定の休止形態時にBOD機能をOFFにできます(該当製品は下表赤文字、但しATtiny24/44/84の初期版を除く)。 これを利用することによって、待機(動作停止)時の消費電力を一般の低消費型専用ﾘｾｯﾄICより少なくできます。
  • [tiny] 441, 828, 841, 1634と[xmega]は継続許可動作/間隔採取動作/禁止動作が選択でき、更に活動動作と休止動作で個別に設定できます。
  • 休止形態からの再起動を含む全ﾘｾｯﾄに於いて、起動安定時間が必要です。 特に旧製品の場合、条件によって10秒以上になる場合があります。
  • [tiny] 4, 5, 9, 10には類似機能のVCCﾚﾍﾞﾙ監視器があります。これは1.4Vまたは1.6V以下でﾘｾｯﾄ、2.4Vまたは3.6V以下で割り込みを生成できます。

本機能を持つﾃﾞﾊﾞｲｽとその検出電圧は次の通りです。 但し、[xmega]の検出電圧は基準公称値で、実ﾃﾞﾊﾞｲｽでは若干異なります(各ﾃﾞｰﾀｼｰﾄ参照)。

ﾃﾞﾊﾞｲｽ名 | 公称検出電圧(V)
[mega] 4HVD, 8HVD |  | 1.8 |
[mega] 8HVA, 16HVA, 16HVB, 32HVB |  |  |  |  |  |  |  |  |  |  |  |  | 2.9 |
[mega] 406 |  |  |  |  |  |  |  |  |  |  | 2.7 |
[tiny] 12 |  | 1.8 |  |  |  |  |  |  |  |  | 2.7 |
[90S] 2333, 4433 [tiny] 15, 26 [mega] 8, 8A, 8515, 8535, 16, 16A, 163, 32, 32A, 323, 64, 64A, 128, 128A |  |  |  |  |  |  |  |  |  |  | 2.7 |  |  |  |  |  |  |  |  |  | 4.0 |
[tiny] 13, 13A, 20, 2313, 2313A, 24, 24A, 25, 261, 261A, 40, 43U, 4313, 44, 44A, 441, 45, 461, 461A, 48, 828, 84, 84A, 841, 85, 861, 861A, 87, 88, 167, 1634 [mega] 48, 48A, 48P, 48PA, 48PB, 88, 88A, 88P, 88PA, 88PB, 164A, 164P, 164PA, 165, 165A, 165P, 165PA, 168, 168A, 168P, 168PA, 168PB, 169, 169A, 169P, 169PA, 324A, 324P, 324PA, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 328, 328P, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA, 640, 644, 644A, 644P, 644PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P, 1280, 1281, 1284, 1284P, 2560, 2561 |  | 1.8 |  |  |  |  |  |  |  |  | 2.7 |  |  |  |  |  |  |  |  |  |  |  |  | 4.3 |
[mega] 162 |  | 1.8 |  |  |  |  | 2.3 |  |  |  | 2.7 |  |  |  |  |  |  |  |  |  |  |  |  | 4.3 |
[90PWM] 81, 161 |  | 1.8 | 1.9 | 2.0 |  | 2.2 | 2.3 |  |  |  | 2.7 |  |  |  |  |  |  |  |  |  |  |  |  | 4.3 |
[90CAN] 32, 64, 128 |  |  |  |  |  |  |  |  | 2.5 | 2.6 | 2.7 |  |  |  |  |  |  |  | 3.8 | 3.9 | 4.0 | 4.1 |
[mega] 16M1, 32M1, 64M1 |  |  |  |  |  |  |  |  |  | 2.6 | 2.7 |  |  |  |  |  |  |  |  |  |  |  |  | 4.3 |  | 4.5
[90PWM] 1, 2, 2B, 216, 3, 3B, 316 |  |  |  |  |  |  |  |  |  | 2.6 | 2.7 | 2.8 |  |  |  |  |  |  |  |  |  |  | 4.2 | 4.3 | 4.4 | 4.5
[mega] 8U2, 16U2, 32U2 |  |  |  |  |  |  |  |  |  |  | 2.7 |  | 2.9 |  |  |  | 3.5 |  |  |  | 4.0 |  |  | 4.3 |
[90USB] 82, 162 |  |  |  |  |  |  |  |  |  |  | 2.7 |  | 2.9 | 3.0 |  |  | 3.5 | 3.6 |  |  | 4.0 |  |  | 4.3 |
[90USB] 646, 647, 1286, 1287 [mega] 32U6 |  |  |  |  |  |  |  |  |  | 2.6 |  |  |  |  |  | 3.4 | 3.5 |  |  |  |  |  |  | 4.3 |
[mega] 16U4, 32U4 |  |  |  | 2.0 |  | 2.2 |  | 2.4 |  | 2.6 |  |  |  |  |  | 3.4 | 3.5 |  |  |  |  |  |  | 4.3 |
[xmega] 64A1U, 128A1U, 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU, 16A4U, 32A4U, 64A4U, 128A4U, 64B1, 128B1, 64B3, 128B3, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | 1.6 | 1.8 |  | 2.0 |  | 2.2 |  | 2.4 |  | 2.6 |  | 2.8 |  | 3.0 |
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A3, 128A3, 192A3, 256A3, 256A3B, 16A4, 32A4, 64A4, 128A4 | 1.6 |  | 1.9 |  | 2.1 |  |  | 2.4 |  | 2.6 |  |  | 2.9 |  | 3.2 | 3.4 |

上記のﾃﾞﾊﾞｲｽは表内の何れかの電圧以下でﾘｾｯﾄでき、この機能を禁止することもできます。 この機能を使用すると消費電流が増加します。 この増加電流は殆どが内部基準電圧となるﾊﾞﾝﾄﾞｷﾞｬｯﾌﾟ電圧作成に使用されます。 ﾊﾞﾝﾄﾞｷﾞｬｯﾌﾟ電圧は低電圧検出器(BOD)だけが利用する訳ではありません。 A/D変換器やｱﾅﾛｸﾞ比較器が内部基準電圧を使用する場合にも使われます。 従って消費電力削減を考慮する場合、可能ならば全ての周辺機能が内部基準電圧を使用しないようにします。


AVR選択: ｸﾛｯｸ元

ｸﾛｯｸ元

殆どのAVRはｼｽﾃﾑ ｸﾛｯｸとして複数のｸﾛｯｸ元を選択できます。 多くのﾃﾞﾊﾞｲｽは内蔵RC発振器により、外部ｸﾛｯｸや外部部品なしで動作できます。 各ﾃﾞﾊﾞｲｽに於ける選択可能なｸﾛｯｸ元を以下に示します。

ﾃﾞﾊﾞｲｽ名 | 内蔵RC 発振器 | Xtal | 外部 信号 | 外部 RC発振 | PLL
[90C] 8534 [90S] 2313, 2323, 2333, 4414, 4433, 4434, 8515, 8535 [mega] 161, 603, 103 | - | ○ | ○ | - | -
[tiny] 22 | ○ | - | - | - | -
[tiny] 15 | ○ | - | - | - | △
[90S] 2343 [tiny] 4, 5, 9, 10, 13, 13A, 20, 40, 43U, 48, 88 | ○ | - | ○ | - | -
[mega] 4HVD, 8HVD, 8HVA, 16HVA, 16HVB, 32HVB | ○ | - | - | - | -
[mega] 406 | ○ | ○ | - | - | -
[90S] 1200 [90CAN] 32, 64, 128 [tiny] 2313, 2313A, 24, 24A, 25, 4313, 44, 44A, 441, 45, 828, 84, 84A, 841, 85, 87, 167, 1634 [mega] 48, 48A, 48P, 48PA, 48PB, 88, 88A, 88P, 88PA, 88PB, 16U4, 162, 164A, 164P, 164PA, 165, 165A, 165P, 165PA, 168, 168A, 168P, 168PA, 168PB, 169, 169A, 169P, 169PA, 32U4, 324A, 324P, 324PA, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 328, 328P, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA, 640, 644, 644A, 644P, 644PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P, 1280, 1281, 1284, 1284P, 2560, 2561 | ○ | ○ | ○ | - | -
[tiny] 261, 261A, 461, 461A, 861, 861A | ○ | ○ | ○ | - | ○
[tiny] (旧10), 11, 12, 28 [mega] 8, 8A, 8515, 8535, 16, 16A, 163, 32, 32A, 323, 64, 64A, 128, 128A | ○ | ○ | ○ | ○ | -
[tiny] 26 | ○ | ○ | ○ | ○ | ○
[90USB] 82, 162, 646, 647, 1286, 1287 [mega] 8U2, 16U2, 32U2, 32U6 | ○ | ○ | ○ | - | △
[90PWM] 81, 161, 1, 2, 2B, 216, 3, 3B, 316 [mega] 16M1, 32M1, 64M1 | ○ | ○ | ○ | - | ○
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A1U, 128A1U, 64A3, 128A3, 192A3, 256A3, 256A3B, 256A3BU, 64A3U, 128A3U, 192A3U, 256A3U, 16A4, 32A4, 64A4, 128A4, 16A4U, 32A4U, 64A4U, 128A4U, 64B1, 128B1, 64B3, 128B3, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | ○ | ○ | ○ | - | ○

  • [tiny] 441, 828, 841, 1634 は8MHz内蔵RC発振器の温度校正機能を持ちます。
  • [90USB] 82, 162と[mega] 8U2, 16U2, 32U2は動作中に外部系発振器と内蔵RC発振器間をｿﾌﾄｳｪｱによって切り替えられます。
  • [90PWM] 81, 161と[tiny] 4, 5, 9, 10, 20, 441, 841, 87, 167, 1634は動作中に全てのｸﾛｯｸ元間をｿﾌﾄｳｪｱによって切り替えられます。

■ 内蔵RC発振器

ｳｫｯﾁﾄﾞｯｸﾞ ﾀｲﾏ(WDT)機能があるﾃﾞﾊﾞｲｽは最低限ｳｫｯﾁﾄﾞｯｸﾞ用にRC発振器を内蔵しています。 一部のﾃﾞﾊﾞｲｽは、このRC発振器出力をｼｽﾃﾑ ｸﾛｯｸとして使用できます。 これとは別に多くのﾃﾞﾊﾞｲｽがｼｽﾃﾑ ｸﾛｯｸ用に校正付きRC発振器を内蔵しています。 この内の一部のﾃﾞﾊﾞｲｽはPLLによって、より高速なｸﾛｯｸを作成し、それをｼｽﾃﾑ ｸﾛｯｸとしたり、一部のﾀｲﾏ/ｶｳﾝﾀ専用ｸﾛｯｸとして利用できます。

ﾃﾞﾊﾞｲｽ名 | ｼｽﾃﾑ ｸﾛｯｸに選択可能な内蔵RC発振器形態と備考
[90S] 1200, 2343 [tiny] (旧10), 11, 22 | 1MHz内部(WDT)発振器
[mega] 163, 323 | 1MHz校正付き内蔵発振器
[tiny] 12, 28 | 1.2MHz校正付き内蔵発振器
[tiny] 15 | 1.6MHz校正付き内蔵発振器 [T/C1に25.6MHz供給]
[90CAN] 32, 64, 128 [90USB] 82, 162 [mega] 8U2, 16HVB, 16U2, 162, 165A, 165P, 165PA, 169, 169A, 169P, 169PA, 32HVB, 32U2, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P | 8MHz校正付き内蔵発振器
[mega] 16U4, 32U4 | 8MHz校正付き内蔵発振器 [T/C4に16～96MHz供給]
[mega] 8, 8A, 8515, 8535, 16, 16A, 32, 32A, 64, 64A, 128, 128A | 1/2/4/8MHz校正付き内蔵発振器
[tiny] 828, 1634 | 8MHz校正付き内蔵発振器、32kHz超低電力(ULP)発振器
[tiny] 441, 841 | 8MHz校正付き内蔵発振器、32/64/128/256/512kHz超低電力(ULP)発振器
[90USB] 646, 647, 1286, 1287 [mega] 48, 48A, 48P, 48PA, 48PB, 88, 88A, 88P, 88PA, 88PB, 164A, 164P, 164PA, 168, 168A, 168P, 168PA, 168PB, 32U6, 324A, 324P, 324PA, 328, 328P, 640, 644, 644A, 644P, 644PA, 1280, 1281, 1284, 1284P, 2560, 2561 [tiny] 4, 5, 9, 10, 20, 24, 24A, 40, 43U, 44, 44A, 48, 84, 84A, 87, 88, 167 | 8MHz校正付き内蔵発振器、128kHz内部(WDT)発振器
[tiny] 2313, 2313A, 4313 | 4/8MHz校正付き内蔵発振器、128kHz内部(WDT)発振器
[tiny] 13, 13A | 4.8/9.6MHz校正付き内蔵発振器、128kHz内部(WDT)発振器
[90PWM] 81, 161, 1, 2, 2B, 216, 3, 3B, 316 [mega] 16M1, 32M1, 64M1 | 8MHz校正付き内蔵発振器、16MHz/任意周波数内蔵PLL、128kHz内部(WDT)発振器
[tiny] 26 | 1/2/4/8MHz校正付き内蔵発振、16MHz内蔵PLL [T/C1に64MHz供給]
[tiny] 261, 261A, 461, 461A, 861, 861A | 8MHz校正付き内蔵発振、16MHz内蔵PLL、128kHz内部(WDT)発振器 [T/C1に32/64MHz供給]
[tiny] 25, 45, 85 | 6.4/8MHz校正付き内蔵発振、8/16MHz内蔵PLL、128kHz内部(WDT)発振器 [T/C1に25.6/32/64MHz供給]
[mega] 4HVD, 8HVD, 8HVA, 16HVA | 8MHz校正付き内蔵発振器(ｼｽﾃﾑ ｸﾛｯｸは1/2)
[mega] 406 | 4MHz校正付き内蔵発振器(ｼｽﾃﾑ ｸﾛｯｸは1/4)、131kHz内部発振器、128kHz内部(WDT)発振器
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A1U, 128A1U, 64A3, 128A3, 192A3, 256A3, 256A3B, 256A3BU, 64A3U, 128A3U, 192A3U, 256A3U, 16A4, 32A4, 64A4, 128A4, 16A4U, 32A4U, 64A4U, 128A4U, 64B1, 128B1, 64B3, 128B3, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | 2/32MHz校正付き内蔵発振器、2～31逓倍内蔵PLL

ｳｫｯﾁﾄﾞｯｸﾞ ﾀｲﾏ(WDT)用内部RC発振器の発振周波数は動作電圧に大きく依存します。 また温度にも依存しますので、特に電源投入直後の変動が大きくなります。

校正付き内蔵RC発振器はﾃﾞﾊﾞｲｽよって若干異なりますが、概ね数%～1%以下程度の精度で校正できます。 初期のﾃﾞﾊﾞｲｽは使用者が応用ﾌﾟﾛｸﾞﾗﾑで校正値を設定しなければなりません。 後期のﾃﾞﾊﾞｲｽはﾘｾｯﾄ時に校正値が自動的に設定されます。

次のﾃﾞﾊﾞｲｽはｼｽﾃﾑ ｸﾛｯｸ用分周器を内蔵しており、基本的に動作中の変更が可能です。

ﾃﾞﾊﾞｲｽ名 | 分周数と種別
 | ﾋｭｰｽﾞ | ﾚｼﾞｽﾀ
[tiny] 13, 13A, 2313, 2313A, 24, 24A, 25, 261, 261A, 43U, 4313, 44, 44A, 441, 45, 461, 461A, 48, 828, 84, 84A, 841, 85, 861, 861A, 87, 88, 167, 1634 [mega] 48, 48A, 48P, 48PA, 48PB, 8U2, 88, 88A, 88P, 88PA, 88PB, 16HVB, 16U2, 16U4, 162, 164A, 164P, 164PA, 165, 165A, 165P, 165PA, 168, 168A, 168P, 168PA, 168PB, 169, 169A, 169P, 169PA, 32HVB, 32U2, 32U4, 32U6, 324A, 324P, 324PA, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 328, 328P, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA, 640, 644, 644A, 644P, 644PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P, 1280, 1281, 1284, 1284P, 2560, 2561 [90CAN] 32, 64, 128 [90PWM] 81, 161, 1, 2, 2B, 216, 3, 3B, 316 [90USB] 82, 162, 646, 647, 1286, 1287 | 8 | 1, 2, 4, 8, 16, 32, 64, 128, 256
[tiny] 4, 5, 9, 10, 20, 40 | - | 1, 2, 4, 8, 16, 32, 64, 128, 256
[mega] 603, 64, 64A, 103, 128, 128A | - | 2～129
[mega] 4HVD, 8HVD, 8HVA, 16HVA, 16HVB, 32HVB | - | 2, 4, 8
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A1U, 128A1U, 64A3, 128A3, 192A3, 256A3, 256A3B, 256A3BU, 64A3U, 128A3U, 192A3U, 256A3U, 16A4, 32A4, 64A4, 128A4, 16A4U, 32A4U, 64A4U, 128A4U, 64B1, 128B1, 64B3, 128B3, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | - | 1, 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048

  • [xmega]系の前置分周器は1～512、1,2,4、1,2の直列3種に分けられます。 これによって基本的にｼｽﾃﾑ ｸﾛｯｸとその2倍及び4倍の周辺ｸﾛｯｸを生成します。

■ Xtal/ｾﾗﾐｯｸ用発振器

Xtal/ｾﾗﾐｯｸ用発振器を持つﾃﾞﾊﾞｲｽは基本的にXtal発振子またはｾﾗﾐｯｸ振動子を外部接続し、その出力をｼｽﾃﾑ ｸﾛｯｸにできます。 一部のﾃﾞﾊﾞｲｽは発振容量(ｺﾝﾃﾞﾝｻ)も内蔵しており、任意で選択できます。

この発振器の発振周波数範囲が概ね400kHz～最高動作周波数までであることに注意してください。 ﾃﾞﾊﾞｲｽによっては、より低速(例えば32.768kHz)用の発振器選択も可能です。

旧製品の場合、本発振器出力で1つのHC入力を駆動し、他へのｸﾛｯｸ供給が行なえます。 或る時点以降の製品は低消費化のため、これが行なえないことに注意してください。 代わりにｼｽﾃﾑ ｸﾛｯｸ出力許可(CKOUT)ﾋｭｰｽﾞ)によってｼｽﾃﾑ ｸﾛｯｸを特定ﾋﾟﾝに出力できます。

■ 外部ｸﾛｯｸ信号

外部からのｸﾛｯｸ信号をｼｽﾃﾑ ｸﾛｯｸとして使用します。 このｸﾛｯｸ信号は一般的なﾛｼﾞｯｸ出力で駆動できますが、入力条件(High/Lowﾚﾍﾞﾙ)が一般ﾎﾟｰﾄより厳しく、遷移時間、ﾃﾞｭｰﾃｨ比、変動などにも制限があることに注意してください。

■ 外部RC発振器

一部のﾃﾞﾊﾞｲｽに於いて、外部にRCを接続することでRC発振器を形成できます。 このRC発振器は安定性や温度特性が他のｸﾛｯｸ元より大きく劣るため、動作周波数が安定していなければならない応用では利用できません。

■ PLL

■ xmega以外

一部のﾃﾞﾊﾞｲｽは内蔵RC発振器とPLLによって、より高速なｸﾛｯｸが利用できます。

  • [90USB] 82, 162, 646, 647, 1286, 1287と[mega] 8U2, 16U2, 32U2, 32U6の内蔵PLLはUSBのｸﾛｯｸ再生専用で、他の目的に利用できません。
  • [mega] 16U4, 32U4の内蔵PLLは基本的に上記同様ですが、USB以外に高速ﾀｲﾏ/ｶｳﾝﾀ用ｸﾛｯｸにも使用できます。
  • 上記以外について、[90PWM] 1, 2, 2B, 216, 3, 3B, 316を除き、内蔵PLLへの供給元は校正付き内蔵RC発振器だけです。
  • [90PWM] 81, 161, 1, 2, 2B, 216, 3, 3B, 316 [mega] 16M1, 32M1, 64M1の内蔵PLLは基本的に64/32MHz高速周辺ｸﾛｯｸと16MHzｼｽﾃﾑ ｸﾛｯｸ生成専用です。

■ xmega

[xmega]は低速系ｸﾛｯｸ以外の全てのｸﾛｯｸ元に対して内蔵PLLが動作し、2～31の範囲で逓倍することができます。 PLL出力はその後に接続される前置分周器によって高速周辺ｸﾛｯｸとｼｽﾃﾑ ｸﾛｯｸを個別に設定でき、これによって高速周辺ｸﾛｯｸはｼｽﾃﾑ ｸﾛｯｸの2または4倍にすることができます。


AVR選択: ﾒﾓﾘ

ﾒﾓﾘ

AVRは一般的な広義の意味で次のﾒﾓﾘを内蔵しています。
  • ﾌﾟﾛｸﾞﾗﾑ用ﾌﾗｯｼｭ ﾒﾓﾘ
  • ﾃﾞｰﾀ用SRAM
  • ﾃﾞｰﾀ用EEPROM
  • 作業用のﾚｼﾞｽﾀ ﾌｧｲﾙ
  • I/O操作用のI/Oﾚｼﾞｽﾀ
  • ﾒﾓﾘ保護用の施錠ﾋﾞｯﾄ
  • 動作任意選択用のﾋｭｰｽﾞ ﾋﾞｯﾄ
これらの内、一般的に狭義の意味でﾒﾓﾘと言われているのが、ﾌﾟﾛｸﾞﾗﾑ用ﾌﾗｯｼｭ ﾒﾓﾘ、ﾃﾞｰﾀ用SRAM、ﾃﾞｰﾀ用EEPROMです。 極一部のAVRを除いて、AVRはこれら全てを内蔵していますが、容量以外にも各々の操作や動作が異なりますので注意が必要です。

一部のAVRにはｱﾄﾞﾚｽ ﾊﾞｽとﾃﾞｰﾀ ﾊﾞｽによって外部ﾒﾓﾘや周辺ﾃﾞﾊﾞｲｽを接続できるﾃﾞｰﾀ用SRAM空間として外部ﾒﾓﾘ ｲﾝﾀｰﾌｪｰｽがあります。

■ ﾌﾟﾛｸﾞﾗﾑ用ﾌﾗｯｼｭ ﾒﾓﾘ

全てのAVRにﾌﾟﾛｸﾞﾗﾑ用ﾌﾗｯｼｭ ﾒﾓﾘが内蔵されていますが、旧ATtiny10のﾌﾗｯｼｭ ﾒﾓﾘはOTP(ﾜﾝ ﾀｲﾑ ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)ですので書き換えができません。 旧ATtiny10を除いて、ﾌﾗｯｼｭ ﾒﾓﾘは書き換えができ、その耐久性は基本的に第1世代ｺｱが1000回、第2世代ｺｱが10000回です。

或る時期以降のAVRは自己ﾌﾟﾛｸﾞﾗﾐﾝｸﾞにより、自身によるﾌﾟﾛｸﾞﾗﾑ書き換えが可能です。 このﾌﾟﾛｸﾞﾗﾑ変更(更新)を行なうﾌﾟﾛｸﾞﾗﾑをﾌﾞｰﾄ ﾛｰﾀﾞと呼び、このﾌﾞｰﾄ ﾛｰﾀﾞを支援する機能を持つﾃﾞﾊﾞｲｽもあります。

[xmega]以外でﾌﾞｰﾄ ﾛｰﾀﾞ支援があるﾃﾞﾊﾞｲｽでは、ﾌﾗｯｼｭ ﾒﾓﾘを応用ﾌﾟﾛｸﾞﾗﾑ用とﾌﾞｰﾄ ﾛｰﾀﾞ用に分割でき、施錠ﾋﾞｯﾄによって各々の領域を保護する機能もあります。

[xmega]では全てのﾃﾞﾊﾞｲｽがﾌﾞｰﾄ ﾛｰﾀﾞ領域を持ち、ﾌﾗｯｼｭ ﾒﾓﾘの公称容量は応用領域だけを示し、ﾌﾞｰﾄ ﾛｰﾀﾞ領域用のﾌﾗｯｼｭ ﾒﾓﾘは別容量で、それ以前のように容量を選択することができず、固定です。 また、応用領域は応用ﾌﾟﾛｸﾞﾗﾑ用と応用表用に分割されおり、ﾌﾞｰﾄ ﾛｰﾀﾞ領域と併せて、これらの領域を施錠ﾋﾞｯﾄによって保護する機能もあります。

  • AVR8Lﾃﾞﾊﾞｲｽのﾌﾗｯｼｭ ﾒﾓﾘはﾃﾞｰﾀ空間内の特定領域に読み込み専用として投影されます。従ってﾌﾗｯｼｭ ﾒﾓﾘからの定数取得はLD系命令を用いて行います。

■ ﾃﾞｰﾀ用SRAM

[tiny] (旧10), 11, 12, 15, 28 [90S] 1200 には内蔵SRAMがありません。 これらを除く他の全てのAVRはSRAMを内蔵しています。 多くのAVRはﾌﾗｯｼｭ ﾒﾓﾘ容量に比例したSRAM容量ですが、一部のﾃﾞﾊﾞｲｽは異なります。

■ 外部ﾒﾓﾘ ｲﾝﾀｰﾌｪｰｽ

本機能を使用すると、ﾎﾟｰﾄをｱﾄﾞﾚｽ/ﾃﾞｰﾀ ﾊﾞｽ用に使用するため、標準I/Oﾎﾟｰﾄして利用できるﾎﾟｰﾄ数が大きく減少します。

■ xmega以外

[90S] 4414, 8515 [90USB] 646, 647, 1286, 1287 [mega] 8515, 161, 162, 32U6, 603, 64, 64A, 640, 103, 128, 128A, 1280, 1281, 2560, 2561 には外部ﾃﾞｰﾀ空間ｱｸｾｽ用に外部ﾒﾓﾘ ｲﾝﾀｰﾌｪｰｽがあります。 これらは最大64Kﾊﾞｲﾄ空間ですが、ﾃﾞﾊﾞｲｽによってはこの容量を選択できます。

ﾃﾞﾊﾞｲｽ名 | 容量
[90S] 4414, 8515 [mega] 161, 603, 103 | 64K固定
[90CAN] 32, 64, 128 [90USB] 646, 647, 1286, 1287 [mega] 8515, 162, 32U6, 64, 64A, 640, 128, 128A, 1280, 1281, 2560, 2561 | 256/1K/2K/4K/8K/16K/32K/64K

■ xmega

[xmega A] 64A1, 128A1, 192A1, 256A1, 384A1, 64A1U, 128A1U には外部ﾃﾞｰﾀ空間ｱｸｾｽ用に外部ﾒﾓﾘ ｲﾝﾀｰﾌｪｰｽがあります。 これらは最大16Mﾊﾞｲﾄ空間で、下限付きで基本的に任意の容量を選択できます。 また、少ﾋﾟﾝ数SRAM、SRAM(標準)、SDRAMに対応するﾊﾞｽ形式に形態設定することができ、SDRAM形態の場合は最大256Mﾊﾞｲﾄまでを扱えます。 現状の上記ﾃﾞﾊﾞｲｽはﾎﾟｰﾄ数の制約から最大構成ではないので、SDRAMの場合の最大容量が128Mﾊﾞｲﾄに制限されます。

■ ﾃﾞｰﾀ用EEPROM

[tiny] 4, 5, 9, 10, (旧10), 11, 20, 28 には内蔵EEPROMがありません。 これらを除く他の全てのAVRはEEPROMを内蔵しています。 その耐久性は100000回です。 多くのAVRはﾌﾗｯｼｭ ﾒﾓﾘ容量に比例したEEPROM容量ですが、一部のﾃﾞﾊﾞｲｽは異なります。

ﾃﾞｰﾀ用EEPROM空間はﾃﾞｰﾀ用SRAM空間と別空間で、且つその構造が異なります。 ﾃﾞｰﾀ用SRAM空間は空間内の任意ﾊﾞｲﾄに直接ｱｸｾｽできますが、EEPROM空間はSRAM空間に属するI/O空間に配置されたEEPROM用I/Oﾚｼﾞｽﾀを経由して間接的にｱｸｾｽします。

[xmega]系は読み込みに関してEEPROMを通常のﾃﾞｰﾀ空間に割り当てることができ、これによってSRAMと同様の方法で読むことができます。

■ 汎用ﾚｼﾞｽﾀ ﾌｧｲﾙ

AVR8Lﾃﾞﾊﾞｲｽを除く全てのAVRには1ﾊﾞｲﾄ長の汎用ﾚｼﾞｽﾀが32個あります。 AVR8Lﾃﾞﾊﾞｲｽには上位の16個(R16～R31)だけがあります。 多くの操作が各ﾚｼﾞｽﾀに対して同じように行なえますが、一部の機能や命令は特定ﾚｼﾞｽﾀだけで動作します。

ﾚｼﾞｽﾀ名 | ﾊﾞｲﾄ系特定操作 | ﾜｰﾄﾞ系特定操作
R31 | 即値系/MULS | MOVW/ADIW/SBIW/Zﾚｼﾞｽﾀ
R30 | 即値系/MULS
R29 | 即値系/MULS | MOVW/ADIW/SBIW/Yﾚｼﾞｽﾀ
R28 | 即値系/MULS
R27 | 即値系/MULS | MOVW/ADIW/SBIW/Xﾚｼﾞｽﾀ
R26 | 即値系/MULS
R25 | 即値系/MULS | MOVW/ADIW/SBIW
R24 | 即値系/MULS
R23 | 即値系/MULS/MULSU/FMUL系 | MOVW
R22 | 即値系/MULS/MULSU/FMUL系
R21 | 即値系/MULS/MULSU/FMUL系 | MOVW
R20 | 即値系/MULS/MULSU/FMUL系
R19 | 即値系/MULS/MULSU/FMUL系 | MOVW
R18 | 即値系/MULS/MULSU/FMUL系
R17 | 即値系/MULS/MULSU/FMUL系 | MOVW
R16 | 即値系/MULS/MULSU/FMUL系
R15 |  | MOVW
R14 |
R13 |  | MOVW
R12 |
R11 |  | MOVW
R10 |
R9 |  | MOVW
R8 |
R7 |  | MOVW
R6 |
R5 |  | MOVW
R4 |
R3 |  | MOVW
R2 |
R1 |  | MOVW/乗算結果/SPM操作
R0 | LPM/ELPM/SPMの暗黙ｵﾍﾟﾗﾝﾄﾞ


AVR選択: ｳｫｯﾁﾄﾞｯｸﾞ ﾀｲﾏ

ｳｫｯﾁﾄﾞｯｸﾞ ﾀｲﾏ

[90C] 8534を除く全てのAVRにはｳｫｯﾁﾄﾞｯｸﾞ ﾀｲﾏがあります。 ｳｫｯﾁﾄﾞｯｸﾞ ﾀｲﾏは専用の内蔵RC発振器によって動作します。 この発振器の周波数はﾃﾞﾊﾞｲｽによって異なります。 またﾃﾞﾊﾞｲｽによっては次の機能が提供されます。
  • ｳｫｯﾁﾄﾞｯｸﾞ常時ON(WDTON)ﾋｭｰｽﾞによるｳｫｯﾁﾄﾞｯｸﾞ停止操作の禁止機能。
  • ｳｫｯﾁﾄﾞｯｸﾞ ﾀｲﾏ割り込み機能。

ﾃﾞﾊﾞｲｽ名 | 公称発振 周波数 | WDTON ﾋｭｰｽﾞ | 割り込み | 窓動作
[90S] 1200, 2313, 2323, 2333, 2343, 4414, 4433, 4434, 8515, 8535 [tiny] (旧10), 11, 12, 15, 22, 26, 28 [mega] 16, 16A, 161, 163, 32, 32A, 323, 603, 103 | 1MHz | - | - | -
[mega] 8, 8A, 8515, 8535, 162, 165, 165A, 165P, 165PA, 169, 169A, 169P, 169PA, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA, 64, 64A, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P, 128, 128A [90CAN] 32, 64, 128 | 1MHz | ○ | - | -
[tiny] 4, 5, 9, 10, 13, 13A, 20, 2313, 2313A, 24, 24A, 25, 261, 261A, 40, 43U, 4313, 44, 44A, 45, 461, 461A, 48, 84, 84A, 85, 861, 861A, 87, 88, 167 [mega] 4HVD, 48, 48A, 48P, 48PA, 48PB, 8HVA, 8HVD, 8U2, 88, 88A, 88P, 88PA, 88PB, 16HVA, 16HVB, 16M1, 16U2, 16U4, 164A, 164P, 164PA, 168, 168A, 168P, 168PA, 168PB, 32HVB, 32M1, 32U2, 32U4, 32U6, 324A, 324P, 324PA, 328, 328P, 406, 64M1, 640, 644, 644A, 644P, 644PA, 1280, 1281, 1284, 1284P, 2560, 2561 [90PWM] 81, 161, 1, 2, 2B, 216, 3, 3B, 316 [90USB] 82, 162, 646, 647, 1286, 1287 | 128kHz | ○ | ○ | -
[tiny] 441, 828, 841, 1634 | 32kHz | ○ | ○ | -
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A1U, 128A1U, 64A3, 128A3, 192A3, 256A3, 256A3B, 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU, 16A4, 32A4, 64A4, 128A4, 16A4U, 32A4U, 64A4U, 128A4U, 64B1, 128B1, 64B3, 128B3, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | 1kHz | △ | ○ | ○

  • [90USB] 82, 162は本来の監視時間値に加えて、それらの3,5,7倍の時間も設定できます。 [mega] 8U2, 16U2はそれに加えて9,1,13,15倍の時間も設定できます。
  • [tiny] 4, 5, 9, 10, 20, 40, 441, 828, 841, 1634には変更時の安全性を高める形態設定施錠機能があります。
  • [tiny] 1634には低消費動作用の間欠動作などもあります。
  • [xmega]系には既存のWDTONﾋｭｰｽﾞの機能を含む、より安全性を高める形態設定施錠機能があります。 また低消費動作用の間欠動作や、安全性向上用のWDR命令有効窓機能もあります。


AVR選択: 割り込み

割り込み

ﾃﾞﾊﾞｲｽ選択一覧表の割り込み数は内部と外部の割り込みﾍﾞｸﾀ総数ですが、ﾘｾｯﾄ ﾍﾞｸﾀは除かれています。 このためﾃﾞﾊﾞｲｽの合計ﾍﾞｸﾀ数は記載数+1になります。 外部割り込みは一般的に汎用入出力と兼用されていますので、割り込みとして使用すると、使用可能な汎用入出力数が減ります。

■ xmega以外

  • 一般的にINTnとして定義される外部割り込みは、Lowﾚﾍﾞﾙ、上昇端、下降端、両端(上昇端と下降端)で割り込みを発生できますが、[90S] 1200, 2313, 2323, 2343, 4414, 4434, 8515, 8535, [tiny] 22 は両端(上昇端と下降端)ができず、[90C] 8534は上昇端、下降端のどちらかだけです。
  • [tiny] 261, 261A, 461, 461A, 861, 861A のINT0とINT1の条件選択は共用されており、個別に設定できません。
  • [tiny] 48, 88 のﾋﾟﾝ数は外囲器に依存し、(+4)は32TQFPと32MLFの場合だけです。
以下のﾃﾞﾊﾞｲｽには特別な割り込み機能があります。

ﾃﾞﾊﾞｲｽ名 | 合計ﾋﾟﾝ数 | 内訳 | 種別
[tiny] 4, 5, 9, 10 | 4 | 4 | ﾚﾍﾞﾙ変化
[tiny] (旧10), 11, 12, 15, 25, 45, 85 | 5 | 5 | ﾚﾍﾞﾙ変化
[tiny] 13, 13A | 6 | 6 | ﾚﾍﾞﾙ変化
[tiny] 28 | 8 | 8 | Lowﾚﾍﾞﾙ
[90USB] 646, 647, 1286, 1287 [tiny] 2313 [mega] 16U4, 32U4, 32U6 | 8 | 8 | ﾚﾍﾞﾙ変化
[mega] 1281, 2561 | 9 | 8+1 | ﾚﾍﾞﾙ変化
[tiny] 26 | 11 | 7+4 | ﾚﾍﾞﾙ変化
[tiny] 20, 24, 24A, 44, 44A, 441, 84, 84A, 841 [mega] 16HVB, 32HVB | 12 | 8+4 | ﾚﾍﾞﾙ変化
[90USB] 82, 162 [mega] 8U2, 16U2, 32U2 | 13 | 8+5 | ﾚﾍﾞﾙ変化
[tiny] 261, 261A, 43U, 461, 461A, 861, 861A, 87, 167 [mega] 162, 165, 165A, 165P, 165PA, 169, 169A, 169P, 169PA, 325, 325A, 325P, 325PA, 329, 329A, 329P, 329PA, 406, 645, 645A, 645P, 649, 649A, 649P | 16 | 8+8 | ﾚﾍﾞﾙ変化
[tiny] 2313A, 4313 | 18 | 8+3+7 | ﾚﾍﾞﾙ変化
[tiny] 40, 1634 | 18 | 8+4+6 | ﾚﾍﾞﾙ変化
[mega] 48, 48A, 48P, 48PA, 48PB, 88, 88A, 88P, 88PA, 88PB, 168, 168A, 168P, 168PA, 168PB, 328, 328P | 23 | 8+8+7 | ﾚﾍﾞﾙ変化
[mega] 640, 1280, 2560 | 24 | 8+8+8 | ﾚﾍﾞﾙ変化
[mega] 16M1, 32M1, 64M1 | 27 | 8+8+8+3 | ﾚﾍﾞﾙ変化
[tiny] 48, 88 | 24(+4) | 8+8+8(+4) | ﾚﾍﾞﾙ変化
[tiny] 828 | 28 | 8+8+8+4 | ﾚﾍﾞﾙ変化
[mega] 3250, 3250A, 3250P, 3250PA, 3290, 3290A, 3290P, 3290PA, 6450, 6450A, 6450P, 6490, 6490A, 6490P | 31 | 8+8+8+7 | ﾚﾍﾞﾙ変化
[mega] 164A, 164P, 164PA, 324A, 324P, 324PA, 644, 644A, 644P, 644PA, 1284, 1284P | 32 | 8+8+8+8 | ﾚﾍﾞﾙ変化

ﾚﾍﾞﾙ変化割り込みは内訳で記述された群毎に許可/禁止ができ、1ﾋﾟﾝ単位で個別にも許可/禁止ができます。 基本的に割り込みﾍﾞｸﾀは、この群毎に割り当てられますが、一部に纏めて1つだけの機種があります。

■ xmega

[xmega]にはそれ以前に存在していた外部割り込み専用機能がなく、代わりにそれ以前でのﾋﾟﾝ変化割り込みが強化された形で実装されています。 これは各ﾎﾟｰﾄに対して2系統の割り込み元を持ち、各ﾋﾟﾝの割り込み条件はLowﾚﾍﾞﾙ、Highﾚﾍﾞﾙ、上昇端、下降端、両端(上昇端と下降端)が選択可能になっています。 従って、全ての汎用入出力ﾋﾟﾝが外部割り込み元として利用することができます。 また、[xmega]以前のﾃﾞﾊﾞｲｽに於いてﾃﾞﾊﾞｲｽ毎に異なっていた非同期感知割り込みは、統一されて各ﾎﾟｰﾄのPx2に割り当てられています。


AVR選択: 汎用入出力ﾎﾟｰﾄ

汎用入出力ﾎﾟｰﾄ

ﾃﾞﾊﾞｲｽ選択一覧表の記述は使用可能な汎用入出力, 汎用入力, 汎用出力数の最大値です。 多くの汎用入出力は他の機能と兼用されています。 他の機能を使用すればするほど使用可能な汎用入出力数は減少します。 一部のﾃﾞﾊﾞｲｽで入力専用、出力専用ﾋﾟﾝが存在します。 次にﾃﾞﾊﾞｲｽ固有の特記事項を示します。
  • [tiny] 48, 88の汎用入出力数は外囲器に依存し、32TQFPと32MLFの場合に4ﾋﾟﾝが追加されます。
  • [tiny] 12, 15の汎用入出力の1つはｵｰﾌﾟﾝ ﾄﾞﾚｲﾝ出力です。
  • [mega] 16HVB, 32HVB, 406の1つの出力専用ﾎﾟｰﾄは高電圧ｵｰﾌﾟﾝ ﾄﾞﾚｲﾝ出力です。
  • [mega] 4HVD, 8HVDの2つ、8HVA, 16HVAの1つ、16HVB, 32HVBの5つのﾎﾟｰﾄはﾃﾞｼﾞﾀﾙ入力可能な高電圧ｵｰﾌﾟﾝ ﾄﾞﾚｲﾝ出力です。
  • [90C] 8534の汎用出力の1つは高電流出力が可能で、専用の変調器が内蔵されています。
  • RESETと共用可能なI/Oﾋﾟﾝ機能を持つﾃﾞﾊﾞｲｽでは、一般的にそのﾋﾟﾝの特性が標準I/Oﾋﾟﾝと異なります。

出力ﾎﾟｰﾄの駆動能力は特定時期のﾃﾞﾊﾞｲｽを除いて、基本的に吸い込み能力が吐き出し能力より勝ります。 また、一般的に全てのﾎﾟｰﾄは同一駆動能力ですが、一部のﾃﾞﾊﾞｲｽはﾎﾟｰﾄによって駆動能力が異なります。

  • [tiny] 441, 841には2本(PA7,PA5)の追加高(吸い込み)駆動可能なﾎﾟｰﾄがあります。
  • [tiny] 828には8本(PC7～0)の追加高(吸い込み)駆動可能なﾎﾟｰﾄがあります。

以下のﾃﾞﾊﾞｲｽには標準的な使用法に影響する他と異なるﾎﾟｰﾄ構造(機能)があります。

  • [tiny] 4, 5, 9, 10, 20, 40, 441, 48, 841, 87, 88, 167, 1634には安全な入出力間切り替えを保証する接続前切断動作機能があり、その許可/禁止設定ﾋﾞｯﾄがあります。
  • [tiny] 48, 87, 88, 167にはﾋﾞｯﾄ個別と全体のﾌﾟﾙｱｯﾌﾟ以外にﾎﾟｰﾄ単位での許可/禁止を行う設定ﾋﾞｯﾄがあります。
  • [tiny] 4, 5, 9, 10, 20, 40, 441, 828, 841, 1634 にはﾋﾞｯﾄ個別と全体のﾌﾟﾙｱｯﾌﾟの制御ﾋﾞｯﾄがなく、代わりに各ﾋﾞｯﾄ毎専用の許可/禁止設定ﾋﾞｯﾄがあります。


AVR選択: ﾀｲﾏ/ｶｳﾝﾀ

ﾀｲﾏ/ｶｳﾝﾀ

ﾀｲﾏ/ｶｳﾝﾀには大別して次の種類があります。
  • 8ﾋﾞｯﾄ同期ﾀｲﾏ/ｶｳﾝﾀ
  • 比較機能付き8ﾋﾞｯﾄ同期ﾀｲﾏ/ｶｳﾝﾀ
  • 比較機能付き8ﾋﾞｯﾄ非同期ﾀｲﾏ/ｶｳﾝﾀ
  • 高速PLLｸﾛｯｸ、比較機能付き8ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀ
  • 高速PLLｸﾛｯｸ、比較機能付き10ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀ
  • 16ﾋﾞｯﾄ同期ﾀｲﾏ/ｶｳﾝﾀ
  • 比較、捕獲機能付き8/16ﾋﾞｯﾄ兼用同期ﾀｲﾏ/ｶｳﾝﾀ
  • 比較、捕獲機能付き16ﾋﾞｯﾄ同期ﾀｲﾏ/ｶｳﾝﾀ
  • 高速ｸﾛｯｸ、複合波形生成、比較、捕獲機能付き16ﾋﾞｯﾄ同期ﾀｲﾏ/ｶｳﾝﾀ (xmega)
  • 起動ﾀｲﾏ

■ xmega以外

更にﾃﾞﾊﾞｲｽによって比較機能は比較部の数とその機能が異なります。

以下の表では基本的なﾀｲﾏ/ｶｳﾝﾀの種別を次の略号で表します。

種別 | 略号
8ﾋﾞｯﾄ同期ﾀｲﾏ/ｶｳﾝﾀ | 8Sn
8ﾋﾞｯﾄ非同期ﾀｲﾏ/ｶｳﾝﾀ | 8An
高速PLLｸﾛｯｸ付き8ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀ | 8Pn
高速PLLｸﾛｯｸ付き10ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀ | 10Pn
8/16ﾋﾞｯﾄ兼用同期ﾀｲﾏ/ｶｳﾝﾀ | 8/16Snn
16ﾋﾞｯﾄ同期ﾀｲﾏ/ｶｳﾝﾀ | 16Snn

略号末尾のnは比較部の数を表します。 16ﾋﾞｯﾄ同期ﾀｲﾏ/ｶｳﾝﾀの略号末尾のnnは順に捕獲部と比較部の数を表します。 -は、無いことを表します。

ﾃﾞﾊﾞｲｽ名 | T/C0 | T/C1 | T/C2 | T/C3 | T/C4 | T/C5 | 起動ﾀｲﾏ
[90S] 1200, 2323, 2343 [tiny] (旧10), 11, 12, 22, 28 | 8S- | - | - | - | - | - | -
[tiny] 13, 13A | 8S2 | - | - | - | - | - | -
[tiny] 4, 5, 9, 10 | 16S12 | - | - | - | - | - | -
[90PWM] 81, 161 | - | 16S10 | - | - | - | - | -
[tiny] 43U | 8S2 | 8S2 | - | - | - | - | -
[tiny] 15 | 8S- | 8P2 | - | - | - | - | -
[tiny] 26 | 8S- | 8P3 | - | - | - | - | -
[tiny] 25, 45, 85 | 8S2 | 8P3 | - | - | - | - | -
[tiny] 40 | 8S2 | 8/16S12 | - | - | - | - | -
[tiny] 261, 261A, 461, 461A, 861, 861A | 8/16S12 | 10P4 | - | - | - | - | -
[mega] 4HVD, 8HVD, 8HVA, 16HV, 16HVB, 32HVB | 8/16S12 | 8/16S12 | - | - | - | - | -
[90C] 8534 | 8S- | 16S-- | - | - | - | - | -
[90S] 2313, 2333, 4433 | 8S- | 16S11 | - | - | - | - | -
[90S] 4414, 8515 | 8S- | 16S12 | - | - | - | - | -
[mega] 406 | 8S2 | 16S-1 | - | - | - | - | ○
[tiny] 87, 167 | 8A1 | 16S12 | - | - | - | - | -
[mega] 8515 | 8S1 | 16S12 | - | - | - | - | -
[tiny] 20, 2313, 2313A, 24, 24A, 4313, 44, 44A, 48, 828, 84, 84A, 88, 1634 [90PWM] 1, 2, 2B, 216, 3, 3B, 316 [mega] 16M1, 32M1, 64M1 | 8S2 | 16S12 | - | - | - | - | -
[tiny] 441, 841 | 8S2 | 16S12 | 16S12 | - | - | - | -
[90USB] 82, 162 [mega] 8U2, 16U2, 32U2 | 8S2 | 16S13 | - | - | - | - | -
[90S] 4434, 8535 [mega] 8, 8A, 163 | 8S- | 16S12 | 8A1 | - | - | - | -
[mega] 603, 103 | 8A1 | 16S12 | 8S1 | - | - | - | -
[mega] 8535, 16, 16A, 161, 165, 165A, 165P, 165PA, 169, 169A, 169P, 169PA, 32, 32A, 323, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P | 8S1 | 16S12 | 8A1 | - | - | - | -
[mega] 48, 48A, 48P, 48PA, 48PB, 88, 88A, 88P, 88PA, 88PB, 164A, 164P, 164PA, 168, 168A, 168P, 168PA, 168PB, 324A, 324P, 324PA, 328, 328P, 644, 644A, 644P, 644PA, 1284, 1284P | 8S2 | 16S12 | 8A2 | - | - | - | -
[mega] 162 | 8S1 | 16S12 | 8A1 | 16S12 | - | - | -
[mega] 64, 64A, 128, 128A | 8A1 | 16S13 | 8S1 | 16S13 | - | - | -
[90CAN] 32, 64, 128 | 8S1 | 16S13 | 8A1 | 16S13 | - | - | -
[mega] 16U4, 32U4 | 8S2 | 16S13 | - | 16S13 | 10P4 | - | -
[90USB] 646, 647, 1286, 1287 [mega] 32U6 | 8S2 | 16S13 | 8A2 | 16S13 | - | - | -
[mega] 640, 1280, 1281, 2560, 2561 | 8S2 | 16S13 | 8A2 | 16S13 | 16S13 | 16S13 | -

  • [mega] 16U4, 32U4のT/C4は11ﾋﾞｯﾄ増強分解能でも使用できます。
  • 8ﾋﾞｯﾄ非同期ﾀｲﾏ/ｶｳﾝﾀ(上表の8Ax)、高速PLLｸﾛｯｸ付き8ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀ(上表の8Px)と高速PLLｸﾛｯｸ付き10ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀ(上表の10Px)には元々外部ｸﾛｯｸ駆動機能がありません。 他のﾀｲﾏ/ｶｳﾝﾀには基本的に外部ｸﾛｯｸ入力ﾋﾟﾝがありますが、次のﾀｲﾏ/ｶｳﾝﾀには外部ｸﾛｯｸ入力ﾋﾟﾝがありません。

    ﾃﾞﾊﾞｲｽ名 | ﾀｲﾏ/ｶｳﾝﾀ名 | 備考
    [mega] 406 | T/C1 | 機能なし
    [90C] 8534 | T/C0, T/C1 | 機能なし
    [mega] 162 | T/C3 | 機能なし
    [90PWM] 1, 2, 2B, 216 | T/C0, T/C1 | 機能あり、外部ﾋﾟﾝなし
    [mega] 1281, 2561 | T/C4, T/C5 | 機能あり、外部ﾋﾟﾝなし

  • 高速PLLｸﾛｯｸ付き8ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀ(上表の8Px)と高速PLLｸﾛｯｸ付き10ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀ(上表の10Px)を持つﾃﾞﾊﾞｲｽは内部PLLによる高速周辺ｸﾛｯｸを利用できます。

    ﾃﾞﾊﾞｲｽ名 | 25.6MHz | 32MHz | 64MHz
    [tiny] 15○××
    [tiny] 26××○
    [tiny] 25, 261, 261A, 45, 461, 461A, 85, 861, 861A○○○
    [mega] 16U4, 32U4 | 16～96MHz

  • [tiny] 261, 261A, 461, 461A, 861, 861A と[mega] 4HVD, 8HVD, 8HVA, 16HVA を除いて、ﾀｲﾏ/ｶｳﾝﾀ1(T/C1)に配置された16ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀは捕獲起動入力としてｱﾅﾛｸﾞ比較器出力も利用できます。 [tiny] 441, 841 を除き、他の位置に配置された16ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀに、この機能はありません。 [tiny] 441, 841 はﾀｲﾏ/ｶｳﾝﾀ2(T/C2)に配置された16ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀも独立した捕獲起動入力をとｱﾅﾛｸﾞ比較器出力が利用可能です。 [tiny] 261, 261A, 461, 461A, 861, 861A では、この機能をﾀｲﾏ/ｶｳﾝﾀ0(T/C0)で利用できます。 [mega] 4HVD, 8HVD, 8HVA, 16HVA は代わりに内部機能からの事象を捕獲起動入力として切り換え使用できます。
  • 次の16ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀには捕獲起動入力ﾋﾟﾝがありません。

    ﾃﾞﾊﾞｲｽ名 | ﾀｲﾏ/ｶｳﾝﾀ名
    [90C] 8534 | T/C1
    [mega] 406 | T/C1
    [mega] 1281, 2561 | T/C4, T/C5

■ xmega

これもﾎﾟｰﾄ毎に割り当てられ、1つのﾎﾟｰﾄに対して、基本的に4つの比較/捕獲ﾁｬﾈﾙを持つ0型ﾀｲﾏ/ｶｳﾝﾀと2つの比較/捕獲ﾁｬﾈﾙを持つ1型ﾀｲﾏ/ｶｳﾝﾀを各々1つずつ持ちます。 改良ｺｱで、0型ﾀｲﾏ/ｶｳﾝﾀは8ﾋﾞｯﾄ×2の計数部と8ﾋﾞｯﾄ×8の比較部に分割使用可能で、この形態を2型ﾀｲﾏ/ｶｳﾝﾀとして分類します。 同一ﾎﾟｰﾄの0型と1型ﾀｲﾏ/ｶｳﾝﾀは連結して32ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀとして使用することもできます。 ﾃﾞﾊﾞｲｽによっては1型ﾀｲﾏ/ｶｳﾝﾀが省略されているﾎﾟｰﾄもあります。 また、ﾎﾟｰﾄCとﾎﾟｰﾄEのﾀｲﾏ/ｶｳﾝﾀは新波形拡張(AWeX)または波形拡張(WeX)を持ち、切り換え時に沈黙時間挿入(DTI)ができる反転補完出力も生成でき、その他の様々な付加機能を持ちます。 AWeXやWeXもﾃﾞﾊﾞｲｽによっては実装されていないﾎﾟｰﾄがある場合があります。 更に、多くのﾀｲﾏ/ｶｳﾝﾀが高分解能拡張(Hi-Res)を利用でき、これはｼｽﾃﾑ ｸﾛｯｸの4倍の高速周辺ｸﾛｯｸを用いることで、分解能を2ﾋﾞｯﾄ分拡張(結果として4倍速動作が)できます。 改良ｺｱ(2型ﾀｲﾏ/ｶｳﾝﾀ動作が可能なﾃﾞﾊﾞｲｽまたは4型/5型を持つﾃﾞﾊﾞｲｽ)では高速周辺ｸﾛｯｸの両端を利用することで8倍速動作もできます。

ﾃﾞﾊﾞｲｽ名 | ﾎﾟｰﾄC | ﾎﾟｰﾄD | ﾎﾟｰﾄE | ﾎﾟｰﾄF
[xmega] 64B3, 128B3 | 0(2)型,1型,Hi-Res,AWeX | - | - | -
[xmega] 8E5, 16E5, 32E5 | 4型,5型,Hi-Res,WeX | 5型 | - | -
[xmega] 64B1, 128B1 | 0(2)型,1型,Hi-Res,AWeX | - | 0(2)型 | -
[xmega] 16D4, 32D4, 64D4, 128D4 | 0(2)型,1型,Hi-Res,AWeX | 0(2)型 | 0(2)型 | -
[xmega] 16C4, 32C4 | 0(2)型,1型,Hi-Res,AWeX | 0(2)型 | 0型 | -
[xmega] 16A4, 32A4, 64A4, 128A4 | 0型,1型,Hi-Res,AWeX | 0型,Hi-Res | 0型,Hi-Res | -
[xmega] 16A4U, 32A4U, 64A4U, 128A4U | 0(2)型,1型,Hi-Res,AWeX | 0(2)型,Hi-Res | 0(2)型,Hi-Res | -
[xmega] 32C3, 64C3, 128C3, 192C3, 256C3, 384C3 | 0(2)型,1型,Hi-Res,AWeX | 0(2)型 | 0(2)型 | 0(2)型
[xmega] 32D3, 64D3, 128D3, 192D3, 256D3, 384D3 | 0(2)型,1型,Hi-Res,AWeX | 0(2)型,1型 | 0(2)型,1型 | 0(2)型
[xmega] 64A3, 128A3, 192A3, 256A3, 256A3B | 0型,1型,Hi-Res,AWeX | 0型,1型,Hi-Res | 0型,1型,Hi-Res | 0型,Hi-Res
[xmega] 64A3U, 128A3U, 192A3U, 256A3U, , 256A3BU | 0(2)型,1型,Hi-Res,AWeX | 0(2)型,1型,Hi-Res | 0(2)型,1型,Hi-Res | 0(2)型,Hi-Res
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1 | 0型,1型,Hi-Res,AWeX | 0型,1型,Hi-Res | 0型,1型,Hi-Res,AWeX | 0型,1型,Hi-Res
[xmega] 64A1U, 128A1U | 0(2)型,1型,Hi-Res,AWeX | 0(2)型,1型,Hi-Res | 0(2)型,1型,Hi-Res,AWeX | 0(2)型,1型,Hi-Res

■ RTC

■ xmega以外

比較機能付き8ﾋﾞｯﾄ非同期ﾀｲﾏ/ｶｳﾝﾀ(上表の8Ax)を持つﾃﾞﾊﾞｲｽは時計用の32.768kHzｸﾘｽﾀﾙ専用の発振回路を内蔵し、これによってRTC(実時間ｶｳﾝﾀ)を実現できます。 このﾀｲﾏ/ｶｳﾝﾀに対して外部ｸﾛｯｸ信号でも駆動できるﾃﾞﾊﾞｲｽもあります。

ﾃﾞﾊﾞｲｽ名 | 8Ax外部ｸﾛｯｸ信号 | 備考
[90S] 4434, 8535 [mega] 8, 8A, 8535, 16, 16A, 162, 163, 32, 32A, 323, 64, 64A, 128, 128A | × |
[mega] 161, 603, 103 | ○ | 256kHz以下、且つｼｽﾃﾑ ｸﾛｯｸの1/4未満
[90CAN] 32, 64, 128 [90USB] 646, 647, 1286, 1287 [mega] 48, 48A, 48P, 48PA, 48PB, 88, 88A, 88P, 88PA, 88PB, 164A, 164P, 164PA, 165, 165A, 165P, 165PA, 168, 168A, 168P, 168PA, 168PB, 169, 169A, 169P, 169PA, 32U6, 324A, 324P, 324PA, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 328, 328P, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA, 640, 644, 644A, 644P, 644PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P, 1280, 1281, 1284, 1284P, 2560, 2561 [tiny] 87, 167 | ○ | ｼｽﾃﾑ ｸﾛｯｸの1/4未満

■ xmega

比較機能付き16ﾋﾞｯﾄまたは32ﾋﾞｯﾄの実時間計数器(RTCまたはRTC32)を持っています。 16ﾋﾞｯﾄRTCは様々なｸﾛｯｸ元と前置分周でｸﾛｯｸ駆動することができます。 32ﾋﾞｯﾄRTCは時計用32.768kHz外部ｸﾘｽﾀﾙ用発振器からの1.024kHzまたは1Hzからしかｸﾛｯｸ駆動できませんが、電池での代替給電切り換えを含む電池代替支援ｼｽﾃﾑによって容易に電池での計時が行えます。

ﾃﾞﾊﾞｲｽ名 | RTC種別 | 備考
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A1U, 128A1U, 64A3, 128A3, 192A3, 256A3, 64A3U, 128A3U, 192A3U, 256A3U, 16A4, 32A4, 64A4, 128A4, 16A4U, 32A4U, 64A4U, 128A4U, 64B1, 128B1, 64B3, 128B3, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | 16ﾋﾞｯﾄ |
[xmega] 256A3B, 256A3BU | 32ﾋﾞｯﾄ | 代替電池給電支援付き

■ PWM

■ xmega以外

基本的なPWMは自由走行のﾀｲﾏ/ｶｳﾝﾀに於ける計数値=0点と比較一致点での出力論理反転によって行います。 この場合、多くのﾃﾞﾊﾞｲｽでは比較部の数と一致したPWM出力数になりますが、一部ﾃﾞﾊﾞｲｽの特定比較部が計数上限値として使用されるため、その場合はPWM出力数が比較部の数より少なくなります。 また、ﾃﾞﾊﾞｲｽによっては比較部を出力論理反転位置指定か、または前記の計数上限値目的にも使用できますので、計数上限値として使用した場合は、やはりPWM出力数が比較部の数より少なくなります。

下表の比較部数はPWM出力論理反転位置指定に使用される数で、基本的に上限値指定専用を含みません。 従って、これらの比較部数は該当するPWM出力数と一致します。

ﾃﾞﾊﾞｲｽ名ﾀｲﾏ/ｶｳﾝﾀ分解能非重複
反転出力
ﾋﾞｯﾄ,数 比較数
[tiny] 13, 13A [mega] 4068×128ﾋﾞｯﾄ固定または可変×
[tiny] 158×118ﾋﾞｯﾄ可変○
[tiny] 268×128ﾋﾞｯﾄ可変○
[tiny] 25, 40, 43U, 45, 858×228ﾋﾞｯﾄ固定または可変×
[tiny] 261, 261A, 461, 461A, 861, 861A10×3310ﾋﾞｯﾄ可変○
[90S] 2313, 2333, 443316×118,9,10ﾋﾞｯﾄ固定×
[90S] 4414, 851516×128,9,10ﾋﾞｯﾄ固定×
[tiny] 4, 5, 9, 10, 48, 8816×128,9,10ﾋﾞｯﾄ固定または可変×
[90S] 4434, 8535 [mega] 83, 1638×118ﾋﾞｯﾄ固定×
16×128,9,10ﾋﾞｯﾄ固定×
[mega] 8, 8A, 8515 [tiny] 87, 1678×118ﾋﾞｯﾄ固定×
16×128,9,10ﾋﾞｯﾄ固定×
[90PWM] 1, 2, 2B, 216 (注2,注3)8×128ﾋﾞｯﾄ固定または可変×
16×118,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[tiny] 20, 2313, 2313A, 24, 24A, 4313, 44, 44A, 828, 84, 84A, 1634 [90PWM] 3, 3B, 316 (注2) [mega] 16M1, 32M1, 64M1 (注1)8×128ﾋﾞｯﾄ固定または可変×
16×128,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[90USB] 82, 162 [mega] 8U2, 16U2, 32U28×128ﾋﾞｯﾄ固定または可変×
16×138,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[mega] 161, 323, 603, 1038×218ﾋﾞｯﾄ固定×
16×128,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[mega] 8535, 16, 16A, 165, 165A, 165P, 165PA, 169, 169A, 169P, 169PA, 32, 32A, 325, 325A, 325P, 325PA, 329, 329A, 329P, 329PA, 3250, 3250A, 3250P, 3250PA, 3290, 3290A, 3290P, 3290PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P8×218ﾋﾞｯﾄ固定×
16×128,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[mega] 48, 48A, 48P, 48PA, 48PB, 88, 88A, 88P, 88PA, 88PB, 164A, 164P, 164PA, 168, 168A, 168P, 168PA, 168PB, 324A, 324P, 324PA, 328, 328P, 644, 644A, 644P, 644PA, 1284, 1284P8×228ﾋﾞｯﾄ固定または可変×
16×128,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[tiny] 441, 8418×128ﾋﾞｯﾄ固定または可変×
16×228,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[mega] 162, 64, 64A, 128, 128A8×218ﾋﾞｯﾄ固定×
16×228,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[90CAN] 32, 64, 1288×218ﾋﾞｯﾄ固定または可変×
16×238,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[mega] 1281, 2561 (注4)8×118ﾋﾞｯﾄ固定または可変×
8×128ﾋﾞｯﾄ固定または可変×
16×238,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[mega] 16U4, 32U48×128ﾋﾞｯﾄ固定または可変×
10(+1)×1310(+1)ﾋﾞｯﾄ可変×
16×238,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[90USB] 646, 647, 1286, 1287 [mega] 32U68×228ﾋﾞｯﾄ固定または可変×
16×238,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
[mega] 640, 1280, 25608×228ﾋﾞｯﾄ固定または可変×
16×438,9,10ﾋﾞｯﾄ固定または16ﾋﾞｯﾄ可変×
注1 | この他に、mega16M1, 32M1, 64M1には3つの電力段制御器(PSC)としての専用PWMがあります。これらのPWM出力は非重複反転出力にもできます。
注2 | この他に、90PWM1, 2, 2B, 216には2つ、90PWM3, 3B, 316には3つの電力段制御器(PSC)としての専用PWMがあります。 これらのPWMの基本分解能は12ﾋﾞｯﾄで小数分周器による16ﾋﾞｯﾄ拡張動作ができます。また、これらのPWM出力は非重複反転出力にもできます。
注3 | 16ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀは内部的に比較部×2動作ができますが、その内の1つは対応する出力ﾋﾟﾝが1つ分存在しないため、外部PWMとして利用できるのは1つの比較分だけです。
注4 | 8ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀは内部的に比較部×2動作ができますが、その内の1つは対応する出力ﾋﾟﾝが1つ分存在しないため、外部PWMとして利用できるのは1つの比較分だけです。

■ xmega

比較と捕獲の基本動作はそれ以前の比較、捕獲付き16ﾋﾞｯﾄ同期ﾀｲﾏ/ｶｳﾝﾀと同様で、4つの比較/捕獲ﾁｬﾈﾙを持つ0型ﾀｲﾏ/ｶｳﾝﾀは4つのPWM、2つの比較/捕獲ﾁｬﾈﾙを持つ1型ﾀｲﾏ/ｶｳﾝﾀは2つのPWMを出力することができます。 従って2型/4型/5型ﾀｲﾏ/ｶｳﾝﾀ動作を持たないﾃﾞﾊﾞｲｽでは、全てが16ﾋﾞｯﾄ長で、単純なPWMの出力数は0型ﾀｲﾏ/ｶｳﾝﾀ×4+1型ﾀｲﾏ/ｶｳﾝﾀ×2になります。 2型/4型/5型ﾀｲﾏ/ｶｳﾝﾀ動作を持つﾃﾞﾊﾞｲｽで、2型ﾀｲﾏ/ｶｳﾝﾀ動作を使用した場合は8ﾋﾞｯﾄ長で2型ﾀｲﾏ/ｶｳﾝﾀ×8、1型ﾀｲﾏ/ｶｳﾝﾀは変わらず16ﾋﾞｯﾄ長で×2のPWM出力数です。

また、ﾎﾟｰﾄCとEに割り当てられているﾀｲﾏ/ｶｳﾝﾀはそのﾎﾟｰﾄに新波形拡張(AWeX)または波形拡張(WeX)が実装されていれば、0型と1型を併せて切り換え時の沈黙時間挿入(DTI)持つ反転補完出力付きで使用することができます

ﾃﾞﾊﾞｲｽ名 | 単純PWM総数 | 補完出力数
[xmega] 64B3, 128B3, 8E5, 16E5, 32E5 | 4×1+2×1=6(全て16ﾋﾞｯﾄ長) または最大数で (8ﾋﾞｯﾄ)8×1+(16ﾋﾞｯﾄ)2×1=10 | 4×1=4 (16ﾋﾞｯﾄ長時のみ)
[xmega] 64B1, 128B1 | 4×2+2×1=10(全て16ﾋﾞｯﾄ長) または最大数で (8ﾋﾞｯﾄ)8×2+(16ﾋﾞｯﾄ)2×1=18 | 4×1=4 (16ﾋﾞｯﾄ長時のみ)
[xmega] 16D4, 32D4, 64D4, 128D4 | 4×3+2×1=14(全て16ﾋﾞｯﾄ長) | 4×1=4
[xmega] 16C4, 32C4 | 4×3+2×1=14(全て16ﾋﾞｯﾄ長) または最大数で (8ﾋﾞｯﾄ)8×2+(16ﾋﾞｯﾄ)4×1+(16ﾋﾞｯﾄ)2×1=22 | 4×1=4 (16ﾋﾞｯﾄ長時のみ)
[xmega] 16A4, 32A4, 64A4, 128A4 | 4×3+2×2=16(全て16ﾋﾞｯﾄ長) | 4×1=4
[xmega] 16A4U, 32A4U, 64A4U, 128A4U | 4×3+2×2=16(全て16ﾋﾞｯﾄ長) または最大数で (8ﾋﾞｯﾄ)8×3+(16ﾋﾞｯﾄ)2×2=28 | 4×1=4 (16ﾋﾞｯﾄ長時のみ)
[xmega] 32C3, 64C3, 128C3, 192C3, 256C3, 384C3 | 4×4+2×1=18(全て16ﾋﾞｯﾄ長) または最大数で (8ﾋﾞｯﾄ)8×4+(16ﾋﾞｯﾄ)2×1=34 | 4×1=4 (16ﾋﾞｯﾄ長時のみ)
[xmega] 32D3, 64D3, 128D3, 192D3, 256D3, 384D3 | 4×4+2×1=18(全て16ﾋﾞｯﾄ長) | 4×1=4
[xmega] 64A3, 128A3, 192A3, 256A3, 256A3B | 4×4+2×3=22(全て16ﾋﾞｯﾄ長) | 4×1=4
[xmega] 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU | 4×4+2×3=22(全て16ﾋﾞｯﾄ長) または最大数で (8ﾋﾞｯﾄ)8×4+(16ﾋﾞｯﾄ)2×3=38 | 4×1=4 (16ﾋﾞｯﾄ長時のみ)
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1 | 4×4+2×4=24(全て16ﾋﾞｯﾄ長) | 4×2=8
[xmega] 64A1U, 128A1U | 4×4+2×4=24(全て16ﾋﾞｯﾄ長) または最大数で (8ﾋﾞｯﾄ)8×4+(16ﾋﾞｯﾄ)2×4=40 | 4×2=8 (16ﾋﾞｯﾄ長時のみ)

■ 変調器

次のﾃﾞﾊﾞｲｽは変調器を含み、1つの変調出力ﾋﾟﾝが利用可能です。

ﾃﾞﾊﾞｲｽ名 | 構成
[tiny] 28 | 専用ﾊｰﾄﾞｳｪｱによる赤外線ﾘﾓｺﾝ用
[90CAN] 32, 64, 128 [90USB] 646, 647, 1286, 1287 [mega] 16U4, 32U4, 32U6, 64, 64A, 640, 128, 128A, 1280, 1281, 2560, 2561 | 8ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀと16ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀの比較出力合成

■ 起動ﾀｲﾏ

現状、[mega] 406 だけに実装されています。 このﾀｲﾏは131kHz内蔵低速RC発振器または外部32kHzｸﾘｽﾀﾙ用発振器からのｸﾛｯｸを使用します。 本ﾀｲﾏは基本的に低消費電力動作下での計時用です。


AVR選択: 直列入出力

直列入出力

直列入出力には次の種類があります。
  • UART
  • USART
  • LIN/UART
  • SPI (直列周辺ｲﾝﾀｰﾌｪｰｽ)
  • USI (多用途直列 ｲﾝﾀｰﾌｪｰｽ)
  • TWI (I2C、2線直列 ｲﾝﾀｰﾌｪｰｽ)
  • CAN
  • USB

■ UART, USART, EUSART

UARTは俗に言うRS-232を支援します。 USARTはそれに加え、SPIに類似した同期直列通信も支援します。 EUSARTは17ﾋﾞｯﾄ長までのﾃﾞｰﾀとﾏﾝﾁｪｽﾀ符号も扱えます。 ﾃﾞﾊﾞｲｽによって、これらに対する付加機能が異なります。

ﾃﾞﾊﾞｲｽ名 | ﾏﾙﾁ ﾌﾟﾛｾｯｻ 通信 | 2倍速 動作 | 同期 通信 USART | ﾏｽﾀ SPI 動作 | CTS RTS 制御 | ﾌﾚｰﾑ 開始検出 割り込み | DALI EUSART | IrDA支援
[90S] 2313, 4414, 4434, 8515, 8535 [mega] 603, 103 | - | - | - | - | - | - | - | -
[90S] 2333, 4433 | ○ | - | - | - | - | - | - | -
[mega] 83, 161, 163 | ○ | ○ | - | - | - | - | - | -
[90CAN] 32, 64, 128 [tiny] 2313 [mega] 8, 8A, 8515, 8535, 16, 16A, 162, 165, 165A, 165P, 165PA, 169, 169A, 169P, 169PA, 32, 32A, 323, 325, 325A, 325P, 325PA, 329, 329A, 329P, 329PA, 3250, 3250A, 3250P, 3250PA, 3290, 3290A, 3290P, 3290PA, 64, 64A, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P, 128, 128A | ○ | ○ | ○ | - | - | - | - | -
[90USB] 646, 647, 1286, 1287 [tiny] 2313A, 4313 [mega] 48, 48A, 48P, 48PA, 88, 88A, 88P, 88PA, 164A, 164P, 164PA, 168, 168A, 168P, 168PA, 32U6, 324A, 324P, 324PA, 328, 328P, 640, 644, 644A, 644P, 644PA, 1280, 1281, 1284, 1284P, 2560, 2561 | ○ | ○ | ○ | ○ | - | - | - | -
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A1U, 128A1U, 64A3, 128A3, 192A3, 256A3, 256A3B, 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU, 16A4, 32A4, 64A4, 128A4, 16A4U, 32A4U, 64A4U, 128A4U, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 64B1, 128B1, 64B3, 128B3, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | ○ | ○ | ○ | ○ | - | - | - | ○
[90USB] 82, 162 [mega] 8U2, 16U2, 16U4, 32U2, 32U4 | ○ | ○ | ○ | ○ | ○ | - | - | -
[tiny] 441, 828, 841, 1634[mega] 48PB, 88PB, 168PB | ○ | ○ | ○ | ○ | - | ○ | - | -
[90PWM] 2, 2B, 216, 3, 3B, 316 | ○ | ○ | ○ | - | - | - | ○ | -

■ LIN/UART

[tiny] 87, 167 と [mega] 16M1, 32M1, 64M1にのみ存在します。 LIN(局所相互連結網)は本質的にUART機能の部分を流用して実現できます。 故にLIN/UART部署は8ﾋﾞｯﾄ ﾃﾞｰﾀ、1停止ﾋﾞｯﾄに制限したUART機能も支援します。 LIN規約に関してはLIN1.3とLIN2.1が支援されます。

■ SPI

ﾃﾞﾊﾞｲｽによって付加機能が異なります。

ﾃﾞﾊﾞｲｽ名 2倍速動作 ﾋﾟﾝ切替
[90S] 2333, 4414, 4433, 4434, 8515, 8535 [mega] 603, 103--
[90CAN] 32, 64, 128 [90USB] 82, 162, 646, 647, 1286, 1287 [tiny] 20, 40, 48, 828, 87, 88, 167 [mega] 48, 48A, 48P, 48PA, 48PB, 8, 8A, 8U2, 83, 8515, 8535, 88, 88A, 88P, 88PA, 88PB, 8HVA, 16, 16A, 16HVB, 16U2, 16U4, 161, 162, 163, 164A, 164P, 164PA, 165, 165A, 165P, 165PA, 168, 168A, 168P, 168PA, 168PB, 169, 169A, 169P, 169PA, 169PA, 16HVA, 32, 32A, 32HVB, 32U2, 32U4, 32U6, 323, 324A, 324P, 324PA, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 328, 328P, 329, 329A, 329P, 329PA, 3290A, 3290P, 3290PA, 64, 64A, 640, 644, 644A, 644P, 644PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P, 128, 128A, 1280, 1281, 1284, 1284P, 2560, 2561 [xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A1U, 128A1U, 64A3, 128A3, 192A3, 256A3, 256A3B, 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU, 16A4, 32A4, 64A4, 128A4, 16A4U, 32A4U, 64A4U, 128A4U, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 64B1, 128B1, 64B3, 128B3, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5○-
[tiny] 441, 841 [90PWM] 81, 161, 1, 2, 2B, 216, 3, 3B, 316 [mega] 16M1, 32M1, 64M1○○

ﾋﾟﾝ切替機能はSPIで使用する各信号に対し、2組のﾋﾟﾝ配置が定義されており、そのどちらかを切り替えることができます。 この機能によって、時分割による2組のSPI通信や、実装書き込みに使用する場合の回路制限が低減できます。

■ USI

ﾃﾞﾊﾞｲｽによって利用可能なﾀｲﾏ/ｶｳﾝﾀ0からのｸﾛｯｸ元と付加機能が異なります。

ﾃﾞﾊﾞｲｽ名 | T/C0接続 | 受信ﾊﾞｯﾌｧ | ﾋﾟﾝ切替
[tiny] 2313, 26 | TOV0 | - | -
[mega] 165, 165A, 165P, 165PA, 169, 169A, 169P, 169PA, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P | OCF0A | - | -
[tiny] 2313A, 24, 24A, 25, 43U, 4313, 44, 44A, 45, 84, 84A, 85 | OCF0A | ○ | -
[tiny] 261, 261A, 461, 461A, 861, 861A, 87, 167 | OCF0A | ○ | ○

ﾋﾟﾝ切替機能はUSIで使用する各信号に対し、2組のﾋﾟﾝ配置が定義されており、そのどちらかを切り替えることができます。 この機能によって、時分割による2組のSUI通信や、回路制限が低減できます。

■ TWI

ﾃﾞﾊﾞｲｽによって若干機能が異なります。

ﾃﾞﾊﾞｲｽ名 | 主/従動作 | 最大速度 | ﾊﾞｽ接続/切断検出
[mega] 16HVB, 32HVB, 406 | 主/従 | 100kHz | ○
[mega] 83, 163 | 主/従 | 217kHz | -
[90CAN] 32, 64, 128 [90USB] 646, 647, 1286, 1287 [tiny] 48, 88 [mega] 48, 48A, 48P, 48PA, 48PB, 8, 8A, 8535, 88, 88A, 88P, 88PA, 88PB, 16, 16A, 16U4, 164A, 164P, 164PA, 168, 168A, 168P, 168PA, 168PB, 32, 32A, 32U4, 32U6, 323, 324A, 324P, 324PA, 328, 328P, 64, 64A, 640, 644, 644A, 644P, 644PA, 128, 128A, 1280, 1281, 1284, 1284P, 2560, 2561 [xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A1U, 128A1U, 64A3, 128A3, 192A3, 256A3, 256A3B, 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU, 16A4, 32A4, 64A4, 128A4, 16A4U, 32A4U, 64A4U, 128A4U, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 64B1, 128B1, 64B3, 128B3, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | 主/従 | 400kHz | -
[tiny] 20, 40, 441, 828, 841, 1634 | 従 | 400kHz | -

■ CAN

[90CAN] 32, 64, 128 [mega] 16M1, 32M1, 64M1にのみ存在し、CAN制御器に対するﾃﾞﾊﾞｲｽによる差異はありません。 このCAN制御器はCAN2.0AとCAN2.0B仕様を支援します。

■ USB

ﾃﾞﾊﾞｲｽによって若干機能が異なります。

ﾃﾞﾊﾞｲｽ名 | 装置/ﾎｽﾄ･OTG機能
[90USB] 82, 162, 646, 1286 [mega] 8U2, 16U2, 16U4, 32U2, 32U4, 32U6 [xmega] 64A1U, 128A1U, 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU, 16A4U, 32A4U, 64A4U, 128A4U, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 64B1, 128B1, 64B3, 128B3 | 装置制御器のみ
[90USB] 647, 1287 | ﾎｽﾄ･OTG/装置制御器


AVR選択: ｱﾅﾛｸﾞ入出力

ｱﾅﾛｸﾞ入出力

ｱﾅﾛｸﾞ入出力には次の種類があります。
  • ｱﾅﾛｸﾞ比較器
  • A/D変換器
  • D/A変換器

■ ｱﾅﾛｸﾞ比較器

■ xmega以外

極一部のﾃﾞﾊﾞｲｽを除いて、AVRには1つのｱﾅﾛｸﾞ比較器があります。

  • [90PWM] 1, 2, 2B, 216には2つ、[90PWM] 81, 161, 3, 3B, 316には3つ、[mega] 16M1, 32M1, 64M1には4つの、他のﾃﾞﾊﾞｲｽと異なる構造のｱﾅﾛｸﾞ比較器があります。
  • [tiny] 261, 261A, 461, 461A, 861, 861Aは3つのｱﾅﾛｸﾞ比較器用ﾋﾟﾝを持ち、この3ﾋﾟﾝ内の2ﾋﾟﾝを非反転と反転の入力へ任意接続できます。
  • [tiny] 441, 841は若干構成が異なる2つのｱﾅﾛｸﾞ比較器を持ちます。
  • [tiny] 441, 841, 828は入力ﾋｽﾃﾘｼｽ(なし、20mV、50mV)を設定することができます。
  • [mega] 8U2, 16U2, 32U2は反転入力としてAIN1～6の6つのﾋﾟﾝを持ち、それらの1つを選択することができます。
  • [mega] 16U4, 32U4には標準反転入力(AIN1)ﾋﾟﾝがなく、反転入力はA/D変換多重器を介しての接続だけができます。
  • [mega] 48PB, 88PB, 168PBにはｱﾅﾛｸﾞ比較器出力ﾋﾟﾝがあります。
以下のﾃﾞﾊﾞｲｽのｱﾅﾛｸﾞ比較器は、内部で次の信号を接続できます。

ﾃﾞﾊﾞｲｽ名 | 選択可能な信号
[tiny] 2313, 2313A, 4313 [mega] 162 | 1.1V内部基準電圧
[tiny] 12, 15 [90S] 2333, 4433 [mega] 161 | 1.22V内部基準電圧
[mega] 8515 | 1.23V内部基準電圧
[90CAN] 32, 64, 128 [90USB] 82, 162, 646, 647, 1286, 1287 [tiny] 13, 13A, 20, 24, 24A, 25, 261, 261A, 40, 43U, 44, 44A, 441, 45, 461, 461A, 48, 828, 84, 84A, 841, 85, 861, 861A, 87, 88, 167, 1634 [mega] 48, 48A, 48P, 48PA, 48PB, 88, 88A, 88P, 88PA, 88PB, 16U4, 164A, 164P, 164PA, 165, 165A, 165P, 165PA, 168, 168A, 168P, 168PA, 168PB, 169, 169A, 169P, 169PA, 32U4, 32U6, 324A, 324P, 324PA, 325, 325A, 325P, 325PA, 328, 328P, 329, 329A, 329P, 329PA, 3250, 3250A, 3250P, 3250PA, 3290, 3290A, 3290P, 3290PA, 640, 644, 644A, 644P, 644PA, 645, 645A, 645P, 649, 649A, 649P, 6450, 6450A, 6450P, 6490A, 6490P, 1280, 1281, 1284, 1284P, 2560, 2561 | 1.1V内部基準電圧, A/D変換器入力
[mega] 8U2, 16U2, 32U2 | 1.1V内部基準電圧, AIN1～6反転入力
[tiny] 26 | 1.18V内部基準電圧, A/D変換器入力
[mega] 83, 163, 323 | 1.22V内部基準電圧, A/D変換器入力
[mega] 8, 8A, 8535, 16, 16A, 32, 32A, 64, 64A, 128, 128A | 1.23V内部基準電圧, A/D変換器入力
[90PWM] 81, 161, 1, 2, 2B, 216, 3, 3B, 316 [mega] 16M1, 32M1, 64M1 | 2.56V内部基準電圧, AVCC, AREF, D/A変換器出力, 他
注 加えて、[tiny] 87, 167は反転入力へ2.56V内部基準電圧とその1/2,1/4,1/8の電圧を任意接続できます。

■ xmega

ｱﾅﾛｸﾞ比較器は1対毎にﾎﾟｰﾄAとﾎﾟｰﾄBに割り当てられています。これはxmegaA系に関して、ﾎﾟｰﾄA,Bがｱﾅﾛｸﾞ系ﾎﾟｰﾄとして定義されていることによります。 1対のｱﾅﾛｸﾞ比較器は以下の特徴を持ちます(以下のPx表記内のxはAまたはB)。

  • 高速動作と低電力動作の切り換え
  • Px6～0とD/A変換器出力から選択可能な非反転入力
  • Px7,5,3,1,0、D/A変換器出力、ﾊﾞﾝﾄﾞｷﾞｬｯﾌﾟ(1.10V)基準電圧、VCC×(n/64)から選択可能な反転入力 (n=1～64)
  • Px7へ比較器出力可能
  • 0,25mV,50mVから選択可能なﾋｽﾃﾘｼｽ
  • 窓以上、窓内、窓以下を判定できる窓動作
[xmega]は2つのｱﾅﾛｸﾞ比較器を1対として使用する窓動作(ｳｨﾝﾄﾞｳ比較器機能)が付加されており、このために2つ単位で実装されています。

ﾃﾞﾊﾞｲｽ名 | 比較器数
[xmega] 16A4, 16A4U, 32A4, 32A4U, 64A4, 32A4U, 128A4, 128A4U, 64B3, 128B3, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | 2 (1対)
[xmega] 64A1, 64A1U, 128A1, 128A1U, 192A1, 256A1, 384A1, 64A3, 64A3U, 128A3, 128A3U, 192A3, 192A3U, 256A3, 256A3U, 256A3B, 256A3BU, 64B1, 128B1, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3 | 4 (2対)

■ A/D変換器

■ xmega以外

AVRのA/D変換器は例外を除いて10ﾋﾞｯﾄ逐次比較変換型A/D変換器で、多重器によるｼﾝｸﾞﾙ ｴﾝﾄﾞ入力が基本です。 増幅器を持つﾃﾞﾊﾞｲｽでは例外を除いて多重器出力を増幅します。

  • [tiny] 5, 10は8ﾋﾞｯﾄ逐次比較変換型A/D変換器です。
  • [mega] 8HVA, 16HVA, 16HVB, 32HVB, 406は他のﾃﾞﾊﾞｲｽと異なり、一般電圧測定用の12ﾋﾞｯﾄ⊿∑A/D変換器とｸｰﾛﾝ ｶｸﾝﾀを形成する高精度12ﾋﾞｯﾄ⊿∑A/D変換器があり、各々専用の入力ﾋﾟﾝ群を持ちます。
  • [tiny] 48, 88と[mega] 48, 48A, 48P, 48PA, 8, 8A, 88, 88A, 88P, 88PA, 168, 168A, 168P, 168PA, 328, 328Pのﾁｬﾈﾙ数は外囲器によって異なり、28DIP,28QFN/MLFが6、32TQFP,32QFN/MLFが8ﾁｬﾈﾙです。
以下のﾃﾞﾊﾞｲｽのA/D変換器は次の特別な機能があります。

機能＼ﾃﾞﾊﾞｲｽ名 |  | [90S] 2333 4433 | [tiny] 13 13A | [tiny] 20 40 43U | [tiny] 1634 | [tiny] 828 | [tiny] 15 | [tiny] 24 24A 44 44A 84 84A | [tiny] 441 841 | [tiny] 25 45 85 | [tiny] 26 | [tiny] 87 167 | [tiny] 261 261A 461 461A 861 861A | [90PWM] 81 161 1 2 2B 216 3 3B 316 | [mega] 83 163 323 | [mega] 8 8A | [mega] 48 88 168 | [tiny] 48 88 [mega] 48A 48P 48PA 48PB 88A 88P 88PA 88PB 168A 168P 168PA 168PB 328 328P | [mega] 16U4 32U4 | [mega] 165,165A 165P,165PA 169,169A 169P,169PA 325,325A 325P,325PA 329,329A 329P,329PA 3250,3250A 3250P,3250PA 3290,3290A 3290P,3290PA 645,645A 645P,649 649A,649P 6450,6450A 6450P,6490 6490A,6490P | [mega] 8535 16 16A 32 32A 64 64A 128 128A | [mega] 164A 164P 164PA 324A 324P 324PA 644 644A 644P 644PA 1284 1284P | [90CAN] 32,64 128 [90USB] 646 647 1286 1287 [mega] 32U6 | [mega] 640 1280 1281 2560 2561 | [mega] 4HVD 8HVD | [mega] 8HVA 16HVA 16HVB 32HVB 406
差動入力 | 利得(倍) | - | - | - | - | - | 1/20 | 1/20 | 1/20/100 | 1/20 | 1/20 | 8/20 | 1/8/20/32 | 5/10/20/40 | - | - | - | - | 1/10/40/200 | 1 | 1/200 | 1/200 | 1/10/200 | 1/10/200 | 0.2/1 | 0.2/1
 | 単極(＋)/両極(±) | - | - | - | - | - | - | 単極/両極 | 両極 | 単極/両極 | 両極 | 単極/両極 | 単極/両極 | 両極 | - | - | - | - | - | 両極 | 両極 | 両極 | 両極 | 両極 | - | -
 | ｵﾌｾｯﾄ校正 | - | - | - | - | - | 〇 | 〇 | 〇 | 〇 | 〇 | - | 〇 | 〇 | - | - | - | - | - | 〇 | 〇 | 〇 | 〇 | 〇 | - | -
特殊入力 | GND | - | - | 〇 | 〇 | 〇 | - | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | - | -
 | 内部基準電圧(V) | 1.22 | - | 1.1 | 1.1 | 1.1 | - | 1.1 | 1.1 | 1.1/2.56 | 1.18 | 1.1 AVcc/4 | 1.1/2.56 | 1.1 | 1.22 | 1.23 | 1.1 | 1.1 | 1.1 | 1.1 | 1.23 | 1.1 | 1.1 | 1.1 | - | -
 | 温度測定 | - | - | 〇 | 〇 | 〇 | - | 〇 | 〇 | 〇 | - | 〇 | 〇 | - | - | - | - | 〇 | 〇 | - | - | - | - | - | 〇 | 〇
A/D基準電圧 | VCC/AVCC | - | VCC | VCC | VCC | VCC | VCC | VCC | VCC | VCC | AVCC | AVCC | AVCC | AVCC | AVCC | AVCC | AVCC | AVCC | AVCC | AVCC | AVCC | AVCC | AVCC | AVCC | - | -
 | AREF | 〇 | - | - | 〇 | - | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | - | 〇
 | 内部基準電圧(V) | - | 1.1 | 1.1 | 1.1 | 1.1 | 2.56 | 1.1 | 1.1/2.2/4.096 | 1.1/2.56 | 2.56 | 1.1/2.56 | 1.1/2.56 | 2.56 | 2.56 | 2.56 | 1.1 | 1.1 | 2.56 | 1.1 | 2.56 | 1.1/2.56 | 2.56 | 1.1/2.56 | 1.1 | -
割り込み起動自動変換 |  | - | 〇 | 〇 | 〇 | 〇 | - | 〇 | 〇 | 〇 | - | 〇 | 〇 | 〇 | - | - | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | 〇 | - | -

注
  • 上記[mega] 4HVD, 8HVD, 8HVA, 16HVA, 16HVB, 32HVB, 406の利得表記はｼﾝｸﾞﾙ ｴﾝﾄﾞ入力の利得で、本ﾃﾞﾊﾞｲｽに差動入力はありません。
  • [mega] 8535, 16A, 164A, 164P, 164PA, 324A, 324P, 324PA, 644, 644A, 644P, 644PA, 1284, 1284Pの差動入力はTQFP,QFN/MLF,DRQFN外囲器だけが保証されます。
  • [90PWM] 81, 161, 1, 2, 2B, 216, 3, 3B, 316 [mega] 16M1, 32M1, 64M1の増幅器は他ﾃﾞﾊﾞｲｽと異なり、多重器の前にあります。

■ xmega

[xmega]はｱﾅﾛｸﾞ比較器と同様にﾎﾟｰﾄAとﾎﾟｰﾄBのｱﾅﾛｸﾞ系ﾎﾟｰﾄに対して割り当てられています。 ｱﾅﾛｸﾞ比較器と異なり、A/D変換器の場合は1つのA/D変換器が必ずﾎﾟｰﾄxと対応するとは限りません。 A/D変換器が1つで入力ﾁｬﾈﾙが9以上の場合に、そのA/D変換器に対するﾁｬﾈﾙはﾎﾟｰﾄAとﾎﾟｰﾄBに渡ります。

[xmega]のA/D変換器は他のAVRと異なり、12ﾋﾞｯﾄ逐次比較変換型ですが、更にﾊﾟｲﾌﾟﾗﾝ化されていて1変換ｸﾛｯｸ毎に別の入力の変換を行うことができるものもあります。 このﾊﾟｲﾌﾟﾗｲﾝ化A/D変換器は結果が求められるまでの変換時間を除いて、1変換ｸﾛｯｸ毎に変換を行うのと等価です。 このﾊﾟｲﾌﾟﾗｲﾝでは1変換ｸﾛｯｸ毎に2ﾋﾞｯﾄ分を変換します。 採取/保持(S/H)の半ｻｲｸﾙがあるので、1変換に必要な実ｸﾛｯｸ数は0.5+12/2=6.5で、結果として1変換ｸﾛｯｸ単位で7ｻｲｸﾙになります。 このﾊﾟｲﾌﾟﾗｲﾝに対応するﾁｬﾈﾙ(入力ﾋﾟﾝに対するﾁｬﾈﾙではなく、ﾊﾟｲﾌﾟﾗｲﾝ化A/D変換器での同時変換ﾁｬﾈﾙ)はA/D変換器毎に4つあります。 従って、1変換ｸﾛｯｸ毎に4つの入力を(1変換ｸﾛｯｸずれで)同時に変換することができます。 A/D変換器は以下の特徴を持ちます(以下のPx表記内のxはAまたはB)。

  • ﾊﾟｲﾌﾟﾗｲﾝなしA/D変換器は最大200k採取/秒、ﾊﾟｲﾌﾟﾗｲﾝ化A/D変換器は最大2M採取/秒(変換時間:12ﾋﾞｯﾄ=3.5μs,8ﾋﾞｯﾄ=2.5μs)
  • Px7～0、ﾊﾞﾝﾄﾞｷﾞｬｯﾌﾟ(1.10V)基準電圧、VCC/1.6、D/A変換器出力(D/A変換器付きﾃﾞﾊﾞｲｽのみ)、温度感知器から選択可能なｼﾝｸﾞﾙ ｴﾝﾄﾞ入力
  • Px7～0(非反転入力)とPx3～0(利得なし反転入力)、Px7～4(利得付き反転入力)から選択可能な差動入力
  • 1,2,4,8,16,32,64倍の利得付き、符号付と符号なしの差動入力
ﾃﾞﾊﾞｲｽ名 | ﾊﾟｲﾌﾟﾗｲﾝ化 | A/D変換器当たりのﾁｬﾈﾙ数×A/D変換器数
[xmega] 16A4, 16A4U, 32A4, 32A4U, 64A4, 64A4U, 128A4, 128A4U | ○ | 12×1
[xmega] 16C4, 32C4, 16D4, 32D4, 64D4, 128D4 | - | 12×1
[xmega] 64A1, 64A1U, 128A1, 128A1U, 192A1, 256A1, 384A1, 64A3, 64A3U, 128A3, 128A3U, 192A3, 192A3U, 256A3, 256A3U, 256A3B, 256A3BU | ○ | 8×2
[xmega] 64B1, 128B1 | - | 8×2
[xmega] 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 8E5, 16E5, 32E5 | - | 16×1
[xmega] 64B3, 128B3 | - | 8×1
  • E5系は他と異なり、自動平均化などの改良機能を持ちます。

■ D/A変換器

■ xmega以外

現在、[90PWM] 81, 161, 2, 2B, 216, 3, 3B, 316 [mega] 16M1, 32M1, 64M1 だけに1つの10ﾋﾞｯﾄD/A変換器があります。 然しながら、[90PWM] 2, 2B, 216 はD/A出力に対する外部出力ﾋﾟﾝが存在しないため、内部使用に限られます。 このD/A変換器は高速で完全なｱﾅﾛｸﾞ信号を出力し、その出力ﾋﾟﾝの出力ｲﾝﾋﾟｰﾀﾞﾝｽは1kΩ未満([mega] 16M1, 32M1, 64M1は約100Ω)です。

■ xmega

[xmega]はｱﾅﾛｸﾞ比較器やA/D変換器と同様にﾎﾟｰﾄAとﾎﾟｰﾄBのｱﾅﾛｸﾞ系ﾎﾟｰﾄに対して割り当てられています。 D/A変換器はﾎﾟｰﾄ毎に割り当てられ、1つのD/A変換器は2ﾁｬﾈﾙの出力が可能で、ﾃﾞﾊﾞｲｽによってこの2ﾁｬﾈﾙ化の方法が異なり、個別の2つのD/A変換部を持つﾃﾞﾊﾞｲｽと、1つのD/A変換部で2つの採取/保持(S/H)を使用する時分割のﾃﾞﾊﾞｲｽがあります。 D/A変換器は以下の特徴を持ちます(以下のPx表記内のxはAまたはB)。

  • 標準動作と低電力動作の切り換え
  • 12ﾋﾞｯﾄ、最大1M採取/秒
  • 内部1.0V基準電圧、AVCC、ﾎﾟｰﾄAのAREF外部入力、ﾎﾟｰﾄBのAREF外部入力Px7～0から選択可能な基準電圧(出力電圧範囲)
ﾃﾞﾊﾞｲｽ名 | 2ch化種別 | D/A変換器数
[xmega] 16A4, 32A4, 64A4, 128A4, 64A3, 128A3, 192A3, 256A3, 256A3B | S/H | 1
[xmega] 16A4U, 32A4U, 64A4U, 128A4U, 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU | 個別 | 1
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1 | S/H | 2
[xmega] 64A1U, 128A1U | 個別 | 2

■ 定電流源(ISRC)

■ xmega以外

現在、[tiny] 87, 167 と [mega] 16M1, 32M1, 64M1 だけに1つ100μA定電流源があります。 これはLIN節点(ﾉｰﾄﾞ)ｱﾄﾞﾚｽ設定での利用を意図したもので、外部抵抗器の値による電圧値としてA/D変換測定が可能です。

■ xmega

[xmega]はｱﾅﾛｸﾞ比較器ﾋﾟﾝの機能として低電流源出力機能を持つﾃﾞﾊﾞｲｽがあります。 その場合は負入力ﾋﾟﾝに出力されますので出力数はｱﾅﾛｸﾞ比較器数と一致します。

ﾃﾞﾊﾞｲｽ名 | 比較器数
[xmega] 16A4U, 32A4U, 32A4U, 128A4U, 64B3, 128B3, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | 2 (1対)
[xmega] 64A1U, 128A1U, 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU, 64B1, 128B1, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3 | 4 (2対)


AVR選択: 命令

命令

ﾃﾞﾊﾞｲｽによって利用可能な命令数は異なります。 これはAVR開発当初の命令体系を元に、その後の命令拡張などによって数種類になりました。 これらは以下の理由で命令数が決定されています。
  • 基本的にｺｱ Ver.によって利用可能な命令数が異なります。
  • AVRのﾌﾟﾛｸﾞﾗﾑ ｶｳﾝﾀ(PC)操作命令は基本的に相対ｱﾄﾞﾚｽ指定で行なわれます。 この相対ｱﾄﾞﾚｽ指定は12ﾋﾞｯﾄですので4K語(8Kﾊﾞｲﾄ)を指定できます。 従ってﾌﾗｯｼｭ ﾒﾓﾘ容量が8Kﾊﾞｲﾄ越える(現状は16Kﾊﾞｲﾄ以上)場合は、必然的に直接ｱﾄﾞﾚｽ指定形式のﾌﾟﾛｸﾞﾗﾑ ｶｳﾝﾀ(PC)操作命令が追加されます。

    64Kﾊﾞｲﾄを越える場合、更にRAMPZﾚｼﾞｽﾀ使用の拡張ﾌﾟﾛｸﾞﾗﾑ領域ﾃﾞｰﾀ取得(ELPM)命令が追加されます。

  • 自己ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ機能持つﾃﾞﾊﾞｲｽは、その機能を支援するためのﾌﾟﾛｸﾞﾗﾐﾝｸﾞ(SPM)命令が追加されます。
  • 内蔵ﾃﾞﾊﾞｯｸﾞ機能を持つﾃﾞﾊﾞｲｽは、その機能を支援するための一時停止(BREAK)命令が追加されます。
  • AVU8Lｺｱは基本的に下表の種別3に相当する命令ですが、ﾒﾓﾘ空間構成がxmegaに近く、また制限された機能のため、他と若干異なります。
    • ﾌﾗｯｼｭ ﾒﾓﾘがﾃﾞｰﾀ空間に投影される構造のため、LPM命令はありません。
    • LDSとSTSの命令は0番地からの128ﾊﾞｲﾄに制限されます。それによって2語ではなく1語命令です。
    • 上記によってその効果が薄れるために、LDDとSTDの命令が廃止されています。
    • 上記の廃止によって6ﾋﾞｯﾄ+1語の加算回路が無くなるため、ADIWとSBIWの命令が廃止されています。

ﾃﾞﾊﾞｲｽに対応する具体的な命令実装状況を次に示します。

種別 番号 | ﾃﾞﾊﾞｲｽ名 | 命令数 | 追加命令
1 | [90S] 1200 | 89 | (最低限命令のみ)
2 | [tiny] (旧10), 11, 12, 15, 28 | 90 | 1 に加え、LPM
3 | [90C] 8534 [90S] 2313, 2323, 2343, 2333, 4414, 4433, 4434, 8515, 8535 [tiny] 22 | 118 | 2 に加え、ADIW, SBIW, IJMP, ICALL, LD Rd,X, LD Rd,X+, LD Rd,-X, LD Rd,Y, LD Rd,Y+, LD Rd,-Y, LDD Rd,Y+q, LD Rd,Z+, LD Rd,-Z, LDD Rd,Z+q, LDS, ST X,Rr, ST X+,Rr, ST -X,Rr, ST Y,Rr, ST Y+,Rr, ST -Y,Rr, STD Y+q,Rr, ST Z+,Rr, ST -Z,Rr, STD Z+q,Rr, STS, PUSH, POP
4 | [tiny] 26 | 119 | 3 に加え、LPM Rd,Z
5 | [mega] 603, 103 | 121 | 3 に加え、JMP, CALL, ELPM
6 | [tiny] 13, 13A, 2313, 2313A, 24, 24A, 25, 261, 261A, 43U, 4313, 44, 44A, 441, 45, 461, 461A, 48, 828, 84, 84A, 841, 85, 861, 861A, 87, 88 | 123 | 4 に加え、MOVW, LPM Rd,Z+, SPM, BREAK
7 | [mega] 8U2, 16U2, 32U4 [90USB] 82, 162 [tiny] 167, 1634 | 125 | 6 に加え、JMP, CALL
8 | [mega] 8, 8A, 83, 8515, 8535 | 128 | 4 に加え、MOVW, LPM Rd,Z+, SPM, MUL, MULS, MULSU, FMUL, FMULS, FMULSU
9 | [mega] 48, 48A, 48P, 48PA, 48PB, 88, 88A, 88P, 88PA, 88PB, 4HVD, 8HVA, 8HVD [90PWM] 81, 1, 2, 2B, 3, 3B | 129 | 8 に加え、BREAK
10 | [mega] 161, 163 [90PWM] 161 | 130 | 8 に加え、JMP, CALL
11 | [mega] 16, 16A, 16HVB, 16M1, 16U4, 162, 164A, 164P, 164PA, 165, 165A, 165P, 165PA, 168, 168A, 168P, 168PA, 168PB, 169, 169A, 169P, 169PA, 16HVA, 32, 32A, 32HVB, 32M1, 32U4, 32U6, 323, 324A, 324P, 324PA, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 328, 328P, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA, 406, 64, 64A, 64M1, 640, 644, 644A, 644P, 644PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P [90PWM] 216, 316 [90USB] 646, 647 | 131 | 10 に加え、BREAK
12 | [mega] 128, 128A, 1280, 1281, 1284, 1284P [90CAN] 32, 64, 128 (注1) [90USB] 1286, 1287 | 134 | 11 に加え、ELPM, ELPM Rd,Z, ELPM Rd,Z+
13 | [mega] 2560, 2561 | 136 | 12 に加え、EIJMP, EICALL
14 | [xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A3, 128A3, 192A3, 256A3, 256A3B, 16A4, 32A4, 64A4, 128A4 | 138 | 13 に加え、SPM Z+, DES
15 | [xmega] 32C3, 64C3, 128C3, 192C3, 256C3, 16C4, 32C4, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | 141 | 13 に加え、SPM Z+, LAC, LAS, LAT, XCH
16 | [xmega] 64A1U, 128A1U, 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU, 16A4U, 32A4U, 64A4U, 128A4U, 64B1, 128B1, 64B3, 128B3, 384C3 | 142 | 15 に加え、DES

注1 [90CAN] 32, 64 は本質的にELPM命令を必要としませんが、AT90CAN128の単純なﾒﾓﾘ減少版のため、ELPM命令と関連するRAMPZﾚｼﾞｽﾀが実装されています。

種別番号1から2へは初期の小規模改良です。 2から3へで大幅な拡張が行なわれ、初期の系統が完了しました。 5は単なるﾌﾗｯｼｭ ﾒﾓﾘ容量増加による3からの必然による追加です。 3から6へで若干の拡張が行なわれ、これが現状の[tiny]系統の主流です。 4は3から6移行期の中間製品と言えます。 4から8へで基本的に乗算命令が追加され、内蔵ﾃﾞﾊﾞｯｸﾞ機能対応を除いて現状[mega]系統の基礎が完了しました。 7と10は単なるﾌﾗｯｼｭ ﾒﾓﾘ容量増加による各々6と8からの必然による追加です。 9で内蔵ﾃﾞﾊﾞｯｸﾞ機能対応となり、これが現状の[mega]系統の基本形です。 11, 12, 13は単なるﾌﾗｯｼｭ ﾒﾓﾘ容量増加による9からの必然による追加です。 13から14～16は基本的に[xmega]系統新設命令による増加ですが、DESとLAC,LAS,LAT,XCH命令の有無で分類されます。

上記で基準とした最低限命令と追加命令の一覧を次に示します。

最低限命令群 | 追加命令群
算術、論理演算系命令
ADD, ADC, SUB, SUBI, SBC, SBCI, AND, ANDI, OR, ORI, EOR, COM, NEG, SBR, CBR, INC, DEC, TST, CLR, SER | ADIW, SBIW, MUL, MULS, MULSU, FMUL, FMULS, FMULSU, DES
分岐系命令
RJMP, RCALL, RET, RETI, CPSE, CP, CPC, CPI, SBRC, SBRS, SBIC, SBIS, BRBS, BRBC, BREQ, BRNE, BRCS, BRCC, BRSH, BRLO, BRMI, BRPL, BRGE, BRLT, BRHS, BRHC, BRTS, BRTC, BRVS, BRVC, BRIE, BRID | IJMP, EIJMP, JMP, ICALL, EICALL, CALL
ﾃﾞｰﾀ移動系命令
MOV, LDI, LD Rd,Z, ST Z,Rr, IN, OUT | MOVW, LD Rd,X, LD Rd,X+, LD Rd,-X, LD Rd,Y, LD Rd,Y+, LD Rd,-Y, LDD Rd,Y+q, LD Rd,Z+, LD Rd,-Z, LDD Rd,Z+q, LDS, ST X,Rr, ST X+,Rr, ST -X,Rr, ST Y,Rr, ST Y+,Rr, ST -Y,Rr, STD Y+q,Rr, ST Z+,Rr, ST -Z,Rr, STD Z+q,Rr, STS, LPM, LPM Rd,Z, LPM Rd,Z+, ELPM, ELPM Rd,Z, ELPM Rd,Z+, SPM, SPM Z+, PUSH, POP, LAC, LAS, LAT, XCH
ﾋﾞｯﾄ関係系命令
SBI, CBI, LSL, LSR, ROL, ROR, ASR, SWAP, BSET, BCLR, BST, BLD, SEC, CLC, SEN, CLN, SEZ, CLZ, SEI, CLI, SES, CLS, SEV, CLV, SET, CLT, SEH, CLH |
MCU制御系命令
NOP, SLEEP, WDR | BREAK


AVR選択: ﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞ

ﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞ

■ ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ

AVR選択一覧表に於ける「書き込み」項目の略号は次の意味です。

略号 | 意味 | 備考
LS | 低電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (ISP) | 殆ど全てのAVRが可能
LP | 低電圧並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ | 90C8534のみ使用(例外的)
HS | 高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ | 基本的にDIP14ﾋﾟﾝ以下相当のﾃﾞﾊﾞｲｽ
HP | 高電圧並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ | 基本的にDIP20ﾋﾟﾝ以上相当のﾃﾞﾊﾞｲｽ
自己 | SPM命令による自己ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ | 基本的にﾌﾞｰﾄ ﾛｰﾀﾞで使用
TPI | TPI使用ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ | AVR8L系の標準外部ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ法
PDI | PDI使用ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ | xmega系の標準外部ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ法

この他に次項の「内蔵ﾃﾞﾊﾞｯｸﾞ機能」で示されるﾃﾞﾊﾞｯｸﾞWIRE、JTAG、PDI経由でも例外を除いてﾌﾟﾛｸﾞﾗﾐﾝｸﾞが行なえます。

低電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞでは直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽ許可(SPIEN)ﾋｭｰｽﾞが操作できません。 また、一部(初期)のﾃﾞﾊﾞｲｽでは特定の一部のﾋｭｰｽﾞを操作できません。

各書き込み方法は対象ﾃﾞﾊﾞｲｽのﾃﾞｰﾀｼｰﾄを参照してください。

■ 内蔵ﾃﾞﾊﾞｯｸﾞ機能

一般的にAVR Studioを使用して実装状態のままで実動作ﾃﾞﾊﾞｯｸﾞを行なう機能です。 基本的に或る時期以降の製品で、DIP28ﾋﾟﾝ以下相当のﾃﾞﾊﾞｲｽにはﾃﾞﾊﾞｯｸﾞWIRE(dW)、8Kﾊﾞｲﾄを越えるﾌﾗｯｼｭ ﾒﾓﾘで且つDIP40ﾋﾟﾝ以上相当のﾃﾞﾊﾞｲｽにはJTAGが実装されています。

JTAG

直列接続のJTAGｲﾝﾀｰﾌｪｰｽを介して、ﾌﾗｯｼｭ ﾒﾓﾘやEEPROMの書き換えが行えます。 また、内蔵ﾃﾞﾊﾞｯｸﾞ機能を利用し、外部からCPU内部のﾚｼﾞｽﾀ、I/Oﾚｼﾞｽﾀなどの値を取得/設定もできます。 本機能を利用するには、内蔵ﾃﾞﾊﾞｯｸﾞ機能許可(OCDEN)ﾋｭｰｽﾞとJTAGｲﾝﾀｰﾌｪｰｽ許可(JTAGEN)ﾋｭｰｽﾞを共にﾌﾟﾛｸﾞﾗﾑ(0)しなければなりません。 また、応用ﾌﾟﾛｸﾞﾗﾑに於いて、一般的にMCU制御ﾚｼﾞｽﾀ(MCUCR)内にあるJTAGｲﾝﾀｰﾌｪｰｽ禁止(JTD)ﾋﾞｯﾄを1に設定してはいけません。

JTAGの機能と動作については、対象ﾃﾞﾊﾞｲｽのﾃﾞｰﾀｼｰﾄを参照してください。

ﾃﾞﾊﾞｯｸﾞWIRE(dW)

1本の双方向入出力線を使用するﾃﾞﾊﾞｯｸﾞWIRE(dW)も類似した機能を持ちます。 本機能を利用するには、ﾃﾞﾊﾞｯｸﾞWIRE許可(DWEN)ﾋｭｰｽﾞをﾌﾟﾛｸﾞﾗﾑ(0)しなければなりません。

ﾃﾞﾊﾞｯｸﾞWIRE(dW)の詳細については対象ﾃﾞﾊﾞｲｽのﾃﾞｰﾀｼｰﾄを参照してください。

PDI

PDI(ﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞ用ｲﾝﾀｰﾌｪｰｽ)は[xmega]系だけで提供されます。 これはRESET/PDI_CLKﾋﾟﾝとPDI_DATA専用ﾋﾟﾝの2ﾋﾟﾝによる双方向通信を使用してﾌﾟﾛｸﾞﾗﾐﾝｸﾞ及びﾃﾞﾊﾞｯｸﾞを行います。

■ ﾌﾞｰﾄ ﾛｰﾀﾞ

基本的に或る時期以降のmega系用ｺｱとxmega系のﾃﾞﾊﾞｲｽにはﾌﾞｰﾄ ﾛｰﾀﾞ支援機能があります。 この機能はﾌﾗｯｼｭ ﾒﾓﾘ内の応用ﾌﾟﾛｸﾞﾗﾑ領域をﾌﾞｰﾄ ﾛｰﾀﾞ領域から書き換えることが主な目的です。 基本的に、この書き換え中もﾌﾞｰﾄ ﾛｰﾀﾞ領域のﾌﾟﾛｸﾞﾗﾑは動作が可能ですので、外部からの書き換え用ﾌﾟﾛｸﾞﾗﾑ ﾃﾞｰﾀを受信しながらの書き換えができます。 これを支援するために、ﾍﾞｸﾀがﾌﾞｰﾄ ﾛｰﾀﾞ領域の先頭部分へ移動できる機能も含まれます。
  • [90USB] 82, 162, 646, 647, 1286, 1287と[mega] 8U2, 16U2, 16U4, 32U2, 32U4, 32U6はHWBEﾋｭｰｽﾞによってﾘｾｯﾄ時にﾌﾞｰﾄ ﾛｰﾀﾞ実行をHWBﾋﾟﾝで制御することもできます。
  • [xmega]系はﾌﾞｰﾄ ﾛｰﾀﾞ領域容量が固定で、BOOTSZﾋｭｰｽﾞもありません。
これらの機能を持つﾃﾞﾊﾞｲｽとその種別は以下で示されます。 ﾌﾞｰﾄ ﾛｰﾀﾞ領域先頭ｱﾄﾞﾚｽ欄の( )内はﾌﾞｰﾄ ﾛｰﾀﾞ領域ﾊﾞｲﾄ容量です。 ﾌﾞｰﾄ ﾛｰﾀﾞ領域ﾘｾｯﾄ選択(BOOTRST)ﾋﾞｯﾄが存在するﾃﾞﾊﾞｲｽはﾘｾｯﾄ ﾍﾞｸﾀをﾌﾞｰﾄ ﾛｰﾀﾞ領域先頭ｱﾄﾞﾚｽに変更できます。 割り込みﾍﾞｸﾀ選択(IVSEL)ﾋﾞｯﾄが存在するﾃﾞﾊﾞｲｽは割り込みﾍﾞｸﾀをﾌﾞｰﾄ ﾛｰﾀﾞ領域先頭ｱﾄﾞﾚｽ+(1または2)からに変更できます(8Kﾊﾞｲﾄ以内のﾃﾞﾊﾞｲｽは+1、8Kﾊﾞｲﾄを越えるﾃﾞﾊﾞｲｽは+2)。

ﾃﾞﾊﾞｲｽ名 | ﾌﾞｰﾄ領域先頭ｱﾄﾞﾚｽ(BOOTSZ) (容量はﾊﾞｲﾄ値) |  |  |  | 切り替えﾋﾞｯﾄ
 | 11 | 10 | 01 | 00 | BOOTRST | IVSEL
[tiny] 828 [mega] 8, 8A, 8515, 8535, 88, 88A, 88P, 88PA, 88PB [90PWM] 81, 1, 2, 2B, 3, 3B | $0F80 (256) | $0F00 (512) | $0E00 (1K) | $0C00 (2K) | ○ | ○
[90USB] 82 [mega] 8U2 | $0F00 (512) | $0E00 (1K) | $0C00 (2K) | $0800 (4K) | ○ | ○
[mega] 161 | $1E00 (1K) |  |  |  | ○ | -
[mega] 163 | $1F80 (256) | $1F00 (512) | $1E00 (1K) | $1C00 (2K) | ○ | -
[mega] 16, 16A, 162, 164A, 164P, 164PA, 165, 165A, 165P, 165PA, 168, 168A, 168P, 168PA, 168PB, 169, 169A, 169P, 169PA | $1F80 (256) | $1F00 (512) | $1E00 (1K) | $1C00 (2K) | ○ | ○
[90PWM] 161, 216, 316 [90USB] 162 [mega] 16HVB, 16M1, 16U2, 16U4 | $1F00 (512) | $1E00 (1K) | $1C00 (2K) | $1800 (4K) | ○ | ○
[mega] 32, 32A, 32HVB, 32M1, 32U2, 32U4, 32U6, 323, 324A, 324P, 324PA, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 328, 328P, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA | $3F00 (512) | $3E00 (1K) | $3C00 (2K) | $3800 (4K) | ○ | ○
[90CAN] 32 | $3E00 (1K) | $3C00 (2K) | $3800 (4K) | $3000 (8K) | ○ | ○
[mega] 406 | $4F00 (512) | $4E00 (1K) | $4C00 (2K) | $4800 (4K) | ○ | ○
[mega] 64, 64A, 64M1, 640, 644, 644A, 644P, 644PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P [90CAN] 64 [90USB] 646, 647 | $7E00 (1K) | $7C00 (2K) | $7800 (4K) | $7000 (8K) | ○ | ○
[mega] 128, 128A, 1280, 1281, 1284, 1284P [90CAN] 128, [90USB] 1286, 1287 | $FE00 (1K) | $FC00 (2K) | $F800 (4K) | $F000 (8K) | ○ | ○
[mega] 2560, 2561 | $1FE00 (1K) | $1FC00 (2K) | $1F800 (4K) | $1F000 (8K) | ○ | ○
[xmega] 8E5 | $1000 (2K) |  |  |  | ○ | ○
[xmega] 16A4, 16A4U, 16C4, 16D4, 16E5 | $2000 (4K) |  |  |  | ○ | ○
[xmega] 32A4, 32A4U, 32C3, 32C4, 32D3, 32D4, 32E5 | $4000 (4K) |  |  |  | ○ | ○
[xmega] 64A1, 64A1U, 64A3, 64A3U, 64A4, 64A4U, 64B1, 64B3, 64C3, 64D3, 64D4 | $8000 (4K) |  |  |  | ○ | ○
[xmega] 128A1, 128A1U, 128A3, 128A3U, 128A4, 128A4U, 128B1, 128B3, 128C3, 128D3, 128D4 | $10000 (8K) |  |  |  | ○ | ○
[xmega] 192A1, 192A3, 192A3U, 192C3, 192D3 | $18000 (8K) |  |  |  | ○ | ○
[xmega] 256A1, 256A3, 256A3U, 256A3B, 256A3BU, 256C3, 256D3 | $20000 (8K) |  |  |  | ○ | ○
[xmega] 384A1, 384C3, 384D3 | $30000 (8K) |  |  |  | ○ | ○

注 [90PWM] 161, 216, 316、[90USB] 82, 162、[mega] 8U2, 16M1, 16U2, 16U4が他のAVRと異なり、ﾌﾗｯｼｭ ﾒﾓﾘ容量に対応したﾌﾞｰﾄ ﾛｰﾀﾞ領域容量ではないことに注意してください。 またAT90CAN32がAT90CAN128の単純なﾒﾓﾘ減少版のため、64Kや128K版と同容量になっていることにも注意してください。


AVR選択: 参考情報

参考情報

  • 2001年6月14日付けﾃﾞﾊﾞｲｽ名変更により、以下のﾃﾞﾊﾞｲｽが発表当初の名称から新たなﾃﾞﾊﾞｲｽ名に変更されました。

    ATmega164→ATmega16
    ATmega32→ATmega323ATmega32の名称はATmega323の後継品に割り当てられました。
    ATmega104→ATmega128

  • 以下のﾃﾞﾊﾞｲｽ名が関連資料中に出現していますが、ﾃﾞﾊﾞｲｽ系資料では確認できません。

    ATtiny19,ATtiny63

    AVRｱｾﾝﾌﾞﾗの.DEVICE擬似命令で確認したところ、ATtiny19は過去存在/未公開です。 同じくATtiny16が認知されますので、このﾃﾞﾊﾞｲｽも存在する(した?)可能性があるようですが、結果的にATtiny26になったのかもしれません。

  • 2006年、以下のﾃﾞﾊﾞｲｽが発表当初の名称から変更されました。
    ATmega165→ATmega165P(ATmega165とATmega165PはRESETﾋﾟﾝへのPG5追加とpicoPower技術製造を除いてﾃﾞｰﾀｼｰﾄ上等価)
    ATmega169→ATmega169P(ATmega165とATmega165PはRESETﾋﾟﾝへのPG5追加とpicoPower技術製造を除いてﾃﾞｰﾀｼｰﾄ上等価)
    ATmega164→ATmega164P
    ATmega324→ATmega324P
    ATmega644→ATmega644P一部出荷されたATmega644はpicoPower技術製造によってATmega644Pへ移行

    165,169については発表当初の一時期PG5が存在していましたが、その後に全ての資料から削除されました。 従って165P,169PについてはpicoPower技術製造を除いて本来の当初予定製品と考えられます。
    164,324,644については発表時に於いて164,324のUSART×2に対して644がUSART×1とUSART数が異なっていましたが、644Pでは同数(=2)になります。 従って、基本的に164P,324P,644Pは各々164,324,644のpicoPower技術化ですが、644→644Pは結果的に機能強化も含まれます。

  • 2006年3月から、picoPower技術(超低消費電力)製品(末尾P付き)への移行が行われています。
    ATmega48→ATmega48P・ﾃﾞｰﾀｼｰﾄ公開済み
    ATmega88→ATmega88P・ﾃﾞｰﾀｼｰﾄ公開済み
    ATmega168→ATmega168P・ﾃﾞｰﾀｼｰﾄ公開済み
    -→ATmega328P・ﾃﾞｰﾀｼｰﾄ公開済み
    (ATmega164)→ATmega164P・ﾃﾞｰﾀｼｰﾄ公開済み
    (ATmega324)→ATmega324P・ﾃﾞｰﾀｼｰﾄ公開済み
    ATmega644→ATmega644P・ﾃﾞｰﾀｼｰﾄ公開済み
    -→ATmega1284P・ﾃﾞｰﾀｼｰﾄ公開済み
    ATmega165→ATmega165P (休止中のBOD停止機能なし)・ﾃﾞｰﾀｼｰﾄ公開済み
    ATmega325→ATmega325P・ﾃﾞｰﾀｼｰﾄ公開済み
    ATmega3250→ATmega3250P・ﾃﾞｰﾀｼｰﾄ公開済み
    ATmega645→ATmega645P
    ATmega6450→ATmega6450P
    ATmega169→ATmega169P (休止中のBOD停止機能なし)・ﾃﾞｰﾀｼｰﾄ公開済み
    ATmega329→ATmega329P・ﾃﾞｰﾀｼｰﾄ公開済み
    ATmega3290→ATmega3290P・ﾃﾞｰﾀｼｰﾄ公開済み
    ATmega649→ATmega649P
    ATmega6490→ATmega6490P
  • 2008年、製法変更による現行製品(末尾A付きへの)移行が行われています。 これらは現行製品に対して基本的に電気的特性以外は同じですが、同時に改良変更が行われた一部の製品では一部機能が異なるものもあります。 基本的にこれらの製品は末尾にAが付きますが、一部のpicoPower製品でAが付かないことに注意してください。 これは既に動作電圧範囲が異なる(末尾なしの標準品とV付きの低電圧品の)picoPower製品が供給されていた製品に対しては末尾にAが付き、それらが供給されていなかった製品について末尾のPだけでAが付きません。
  • 2008年、低価格小規模向けに機能を制限したAVR8Lｺｱが新設され、その第1段がATtiny10ですが、この名称がかなり以前に製造終了品となったATtiny11のOTP(ﾜﾝﾀｲﾑ ﾌﾟﾛｸﾞﾗﾏﾌﾞﾙ)品と同じですので注意してください。
  • 2010年、一部の製品について、車載用ではなく通常製品で拡張温度製品(～105℃など)が供給され始めました。


AVR選択: 施錠/ﾋｭｰｽﾞ ﾋﾞｯﾄ

施錠/ﾋｭｰｽﾞ ﾋﾞｯﾄ

■ 施錠ﾋﾞｯﾄ

LB2とLB1は基本的にﾒﾓﾘに対する外部からの読み書き保護設定です。 [xmega]系以外のBLB12,11とBLB02,01はﾌﾞｰﾄ ﾛｰﾀﾞ支援機能を持つﾃﾞﾊﾞｲｽに存在し、各々応用ﾌﾟﾛｸﾞﾗﾑ領域とﾌﾞｰﾄ ﾛｰﾀﾞ領域に対する自己ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ(LPM, ELPM, SPM命令)保護です。 [xmega]系のBLBB1,0、BLBA1,0、BLBAT1,0は各々、ﾌﾞｰﾄ ﾛｰﾀﾞ領域、応用ﾌﾟﾛｸﾞﾗﾑ領域、応用表領域に対する自己ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ(LPM, ELPM, SPM命令)保護です。

ここでの表記はLB2,LB1ですが、AVR8Lﾃﾞﾊﾞｲｽの施錠ﾋﾞｯﾄ名はNVB2,NVLB1です。

ﾃﾞﾊﾞｲｽ名 | 施錠ﾋﾞｯﾄ
 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
[90C] 8534 [90S] 1200, 2313, 2323, 2343, 2333, 4414, 4433, 4434, 8515, 8535 [tiny] (旧10), 11, 12, 15, 22, 28 [mega] 603, 103 | - | - | - | - | - | LB2 | LB1 | -
[tiny] 4, 5, 9, 10, 13, 13A, 20, 2313, 2313A, 24, 24A, 25, 26, 261, 261A, 40, 43U, 4313, 44, 44A, 441, 45, 461, 461A, 48, 84, 84A, 841, 85, 861, 861A, 87, 88, 167, 1634 [mega] 48, 48A, 48P, 48PA, 48PB, 4HVD, 8HVD, 8HVA, 16HVA | - | - | - | - | - | - | LB2 | LB1
[90CAN] 32, 64, 128 [90PWM] 81, 161, 1, 2, 2B, 216, 3, 3B, 316 [90USB] 82, 162, 646, 647, 1286, 1287 [tiny] 828 [mega] 8, 8A, 8U2, 8515, 8535, 88, 88A, 88P, 88PA, 88PB, 16, 16A, 16HVB, 16M1, 16U2, 16U4, 161, 162, 163, 164A, 164P, 164PA, 165, 165A, 165P, 165PA, 168, 168A, 168P, 168PA, 168PB, 169, 169A, 169P, 169PA, 32, 32A, 32HVB, 32M1, 32U2, 32U4, 32U6, 323, 324A, 324P, 324PA, 325, 325A, 325P, 325PA, 3250, 3250A, 3250P, 3250PA, 328, 328P, 329, 329A, 329P, 329PA, 3290, 3290A, 3290P, 3290PA, 406, 64, 64A, 64M1, 640, 644, 644A, 644P, 644PA, 645, 645A, 645P, 6450, 6450A, 6450P, 649, 649A, 649P, 6490, 6490A, 6490P, 128, 128A, 1280, 1281, 1284, 1284P, 2560, 2561 | - | - | BLB12 | BLB11 | BLB02 | BLB01 | LB2 | LB1
[xmega] 64A1, 128A1, 192A1, 256A1, 384A1, 64A1U, 128A1U, 64A3, 128A3, 192A3, 256A3, 256A3B, 64A3U, 128A3U, 192A3U, 256A3U, 256A3BU, 16A4, 32A4, 64A4, 128A4, 16A4U, 32A4U, 64A4U, 128A4U, 64B1, 128B1, 64B3, 128B3, 32C3, 64C3, 128C3, 192C3, 256C3, 384C3, 16C4, 32C4, 32D3, 64D3, 128D3, 192D3, 256D3, 384D3, 16D4, 32D4, 64D4, 128D4, 8E5, 16E5, 32E5 | BLBB1 | BLBB0 | BLBA1 | BLBA0 | BLBAT1 | BLBAT0 | LB2 | LB1

施錠ﾋﾞｯﾄ | 意味
BLB12, BLB11またはBLBB1, BLBB0 | 対ﾌﾞｰﾄ ﾛｰﾀﾞ領域(自己ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)保護
BLBAT1, BLBAT0 | 対応用表領域(自己ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)保護
BLB02, BLB01またはBLBA1, BLBA0 | 対応用ﾌﾟﾛｸﾞﾗﾑ領域(自己ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)保護
LB2, LB1 | 対外部ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ保護

■ ﾋｭｰｽﾞ ﾋﾞｯﾄ

■ xmega以外

ﾋｭｰｽﾞ ﾋﾞｯﾄはﾃﾞﾊﾞｲｽによって、その数と内容が異なります。 ﾋｭｰｽﾞ ﾋﾞｯﾄはﾊﾞｲﾄ単位で最大3ﾊﾞｲﾄです。 これらは各々、下位ﾋｭｰｽﾞ、上位ﾋｭｰｽﾞ、拡張ﾋｭｰｽﾞと呼ばれます。

AVR8Lﾃﾞﾊﾞｲｽでの名称は形態設定ﾊﾞｲﾄです。

ﾃﾞﾊﾞｲｽ名 | 拡張ﾋｭｰｽﾞ |  |  |  |  |  |  |  | 上位ﾋｭｰｽﾞ |  |  |  |  |  |  |  | 下位ﾋｭｰｽﾞ
 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
[tiny] 4, 5, 9, 10 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | CKOUT | WDTON | RSTDISBL
[tiny] 20, 40 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | - | CKOUT | WDTON | RSTDISBL
[90C] 8534 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | -
[tiny] 22 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | SPIEN | - | - | - | - | -
[90S] 1200, 2343 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | SPIEN | - | - | - | - | RCEN
[90S] 2313, 2323, 4414, 4434, 8515, 8535 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | SPIEN | - | - | - | - | FSTRT
[tiny] 28 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | INTCAP | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[tiny] (旧10), 11 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | FSTRT | RSTDISBL | CKSEL2 | CKSEL1 | CKSEL0
[tiny] 12 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | BODLEVEL | BODEN | SPIEN | RSTDISBL | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[tiny] 15 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | BODLEVEL | BODEN | SPIEN | RSTDISBL | - | - | CKSEL1 | CKSEL0
[90S] 2333, 4433 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | SPIEN | BODLEVEL | BODEN | CKSEL2 | CKSEL1 | CKSEL0
[mega] 603, 103 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | SPIEN | - | EESAVE | - | SUT1 | SUT0
[mega] 161 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | BOOTRST | SPIEN | SUT | - | CKSEL2 | CKSEL1 | CKSEL0
[tiny] 26 | - | - | - | - | - | - | - | - | - | - | - | RSTDISBL | SPIEN | EESAVE | BODLEVEL | BODEN | PLLCK | CKOPT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[tiny] 13, 13A | - | - | - | - | - | - | - | - | - | - | - | SELFPRGEN | DWEN | BODLEVEL1 | BODLEVEL0 | RSTDISBL | SPIEN | EESAVE | WDTON | CKDIV8 | SUT1 | SUT0 | CKSEL1 | CKSEL0
[mega] 163 | - | - | - | - | - | - | - | - | - | - | - | - | - | BOOTSZ1 | BOOTSZ0 | BOOTRST | BODLEVEL | BODEN | SPIEN | - | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 8515 | - | - | - | - | - | - | - | - | S8515C | WDTON | SPIEN | CKOPT | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | BODLEVEL | BODEN | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 8535 | - | - | - | - | - | - | - | - | S8535C | WDTON | SPIEN | CKOPT | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | BODLEVEL | BODEN | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 8, 8A | - | - | - | - | - | - | - | - | RSTDISBL | WDTON | SPIEN | CKOPT | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | BODLEVEL | BODEN | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[tiny] 2313, 2313A, 4313 | - | - | - | - | - | - | - | SELFPRGEN | DWEN | EESAVE | SPIEN | WDTON | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | RSTDISBL | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[tiny] 24, 24A, 25, 261, 261A, 43U, 44, 44A, 45, 461, 461A, 48, 84, 84A, 85, 861, 861A, 87, 88, 167 [mega] 48, 48A, 48P, 48PA, 48PB | - | - | - | - | - | - | - | SELFPRGEN | RSTDISBL | DWEN | SPIEN | WDTON | EESAVE | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[tiny] 1634 | - | - | - | BODPD1 | BODPD0 | BODACT1 | BODACT0 | SELFPRGEN | RSTDISBL | DWEN | SPIEN | WDTON | EESAVE | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | CKDIV8 | CKOUT | - | SUT | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[tiny] 441, 841 | ULPOSCSEL2 | ULPOSCSEL1 | ULPOSCSEL0 | BODPD1 | BODPD0 | BODACT1 | BODACT0 | SELFPRGEN | RSTDISBL | DWEN | SPIEN | WDTON | EESAVE | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | CKDIV8 | CKOUT | - | SUT | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[tiny] 828 | BODPD1 | BODPD0 | BODACT1 | BODACT0 | - | BOOTSZ1 | BOOTSZ0 | BOOTRST | RSTDISBL | DWEN | SPIEN | WDTON | EESAVE | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | CKDIV8 | CKOUT | SUT1 | SUT0 | - | - | CKSEL1 | CKSEL0
[mega] 88, 88A, 88P, 88PA, 88PB, 168, 168A, 168P, 168PA, 168PB, 328, 328P | - | - | - | - | - | BOOTSZ1 | BOOTSZ0 | BOOTRST | RSTDISBL | DWEN | SPIEN | WDTON | EESAVE | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 323 | - | - | - | - | - | - | - | - | OCDEN | JTAGEN | SPIEN | - | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | BODLEVEL | BODEN | - | - | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 16, 16A, 32, 32A | - | - | - | - | - | - | - | - | OCDEN | JTAGEN | SPIEN | CKOPT | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | BODLEVEL | BODEN | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 64, 64A, 128, 128A | - | - | - | - | - | - | M103C | WDTON | OCDEN | JTAGEN | SPIEN | CKOPT | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | BODLEVEL | BODEN | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 325, 325P, 329, 329P, 3250, 3250P, 3290, 3290P, 645, 649, 6450, 6490 | - | - | - | - | - | BODLEVEL1 | BODLEVEL0 | RSTDISBL | OCDEN | JTAGEN | SPIEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 164A, 164P, 164PA, 324A, 324P, 324PA, 640, 644, 644A, 644P, 644PA, 1280, 1281, 1284, 1284P, 2560, 2561 | - | - | - | - | - | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | OCDEN | JTAGEN | SPIEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[90USB] 82, 162 [mega] 8U2, 16U2, 32U2 | - | - | - | - | HWBE | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | DWEN | RSTDISBL | SPIEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[90USB] 646, 647, 1286, 1287 [mega] 16U4, 32U4, 32U6 | - | - | - | - | HWBE | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | OCDEN | JTAGEN | SPIEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 165, 169 | - | - | - | - | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | - | OCDEN | JTAGEN | SPIEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 165A, 165P, 165PA, 169A, 169P, 169PA, 325A, 325PA, 3250A, 3250PA, 329A, 329PA, 3250A, 3250PA, 3290A, 3290PA, 645A, 645P, 649A, 649P, 6450A, 6450P, 6490A, 6490P | - | - | - | - | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | RSTDISBL | OCDEN | JTAGEN | SPIEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[90CAN] 32, 64, 128 | - | - | - | - | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | (TA0SEL) | OCDEN | JTAGEN | SPIEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 162 | - | - | - | M161C | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | - | OCDEN | JTAGEN | SPIEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[90PWM] 81, 161 | PSC2RB | PSC2RBA | PSCRRB | PSCRV | PSCINRB | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | RSTDISBL | DWEN | SPIEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[90PWM] 1, 2, 2B, 216 | PSC2RB | - | PSC0RB | PSCRV | - | BOOTSZ1 | BOOTSZ0 | BOOTRST | RSTDISBL | DWEN | SPIEN | WDTON | EESAVE | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[90PWM] 3, 3B, 316 | PSC2RB | PSC1RB | PSC0RB | PSCRV | - | BOOTSZ1 | BOOTSZ0 | BOOTRST | RSTDISBL | DWEN | SPIEN | WDTON | EESAVE | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 16M1, 32M1, 64M1 | - | - | PSCRB | PSCRVA | PSCRVB | BODLEVEL2 | BODLEVEL1 | BODLEVEL0 | RSTDISBL | DWEN | SPIEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | CKDIV8 | CKOUT | SUT1 | SUT0 | CKSEL3 | CKSEL2 | CKSEL1 | CKSEL0
[mega] 16HVB, 32HVB | - | - | - | - | - | - | - | - | - | - | - | CKDIV8 | DWEN | BOOTSZ1 | BOOTSZ0 | BOOTRST | WDTON | EESAVE | SPIEN | SUT2 | SUT1 | SUT0 | OSCSEL1 | OSCSEL0
[mega] 4HVD, 8HVD, 8HVA, 16HVA | - | - | - | - | - | - | - | - | - | - | - | - | - | - | OSCSEL1 | OSCSEL0 | WDTON | EESAVE | SPIEN | DWEN | SELFPRGEN | SUT2 | SUT1 | SUT0
[mega] 406 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | OCDEN | JTAGEN | WDTON | EESAVE | BOOTSZ1 | BOOTSZ0 | BOOTRST | SUT1 | SUT0 | CKSEL

ﾋｭｰｽﾞ ﾋﾞｯﾄ | 意味
BODACT1,0 | 活動中(活動動作とｱｲﾄﾞﾙ動作)でのBOD動作種別選択
BODEN | 低電圧検出(BOD)ﾘｾｯﾄ許可
BODLEVEL | 低電圧検出(BOD)ﾘｾｯﾄ電圧選択
BODLEVEL2～0 | 低電圧検出(BOD)ﾘｾｯﾄ電圧選択・許可/禁止
BODPD1,0 | 低電力(ｱｲﾄﾞﾙを除く休止)動作でのBOD動作種別選択
BOOTSZ1～0 | ﾌﾞｰﾄ ﾛｰﾀﾞ領域容量選択
BOOTRST | ﾌﾞｰﾄ ﾛｰﾀﾞ領域へのﾘｾｯﾄ許可
CKDIV8 | 8分周ｼｽﾃﾑ ｸﾛｯｸ許可
CKOPT | 発振器付加機能(ｸﾛｯｸ元依存機能)
CKSEL3～0 | ｼｽﾃﾑ ｸﾛｯｸ元選択
DWEN | 内蔵ﾃﾞﾊﾞｯｸﾞWIRE機能許可
EESAVE | ﾁｯﾌﾟ消去時EEPROM内容保護
FSTRT | ﾘｾｯﾄ起動時間を高速に設定
HWBE | ﾘｾｯﾄ時ﾊｰﾄﾞｳｪｱ ﾌﾞｰﾄ実行有無機能許可
INTCAP | XTALﾋﾟﾝに内部容量(ｺﾝﾃﾞﾝｻ)付加
JTAGEN | JTAGｲﾝﾀｰﾌｪｰｽ許可
M103C | ATmega103互換動作
M161C | ATmega161互換動作
OCDEN | 内蔵ﾃﾞﾊﾞｯｸﾞ機能許可
OSCSEL1～0 | 発振器選択
PLLCK | 内部PLLｼｽﾃﾑ ｸﾛｯｸ許可
PSC0RB | ﾘｾｯﾄ時電力段制御器0(PSC0)出力
PSC1RB | ﾘｾｯﾄ時電力段制御器1(PSC1)出力
PSC2RB | ﾘｾｯﾄ時電力段制御器2(PSC2)出力
PSC2RBA | ﾘｾｯﾄ時電力段制御器2(PSC2)の22と23の出力
PSCINRB | ﾘｾｯﾄ時(縮小)電力段制御器(PSC,PSCR)の入力動作
PSCRB | ﾘｾｯﾄ時電力段制御器(PSC)出力制御
PSCRRB | ﾘｾｯﾄ時縮小電力段制御器(PSCR)出力値
PSCRV | ﾘｾｯﾄ時電力段制御器n(PSCn)出力値
PSCRVA | ﾘｾｯﾄ時電力段制御器(PSC)A出力値
PSCRVB | ﾘｾｯﾄ時電力段制御器(PSC)B出力値
RCEN | ｳｫｯﾁﾄﾞｯｸﾞ用内部RC発振器をｼｽﾃﾑ ｸﾛｯｸに使用
RSTDISBL | RESETﾋﾟﾝ機能禁止(標準I/Oﾎﾟｰﾄ設定)
S8515C | AT90S4414/8515互換動作
S8535C | AT90S4434/8535互換動作
SELFPRGEN | 自己ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ許可
SPIEN | 低電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ許可
SUT, SUT2～0 | 起動時間選択
(TA0SEL) | (工場検査用予約:ﾌﾟﾛｸﾞﾗﾑ(0)設定禁止)
ULPOSCSEL2～0 | 超低電力(ULP)発振周波数選択
WDTON | ｳｫｯﾁﾄﾞｯｸﾞ常時ON(ﾃﾞﾊﾞｲｽ依存)

■ xmega

[xmega]系は基本的に全ﾃﾞﾊﾞｲｽ共通で、5ﾊﾞｲﾄのﾋｭｰｽﾞを持ちます。
ﾋｭｰｽﾞ ﾊﾞｲﾄ名 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
FUSEBYTE5 | - | - | BODACT1 | BODACT0 | EESAVE | BODLEVEL2 | BODLEVEL1 | BODLEVEL0
FUSEBYTE4 | - | - | - | RSTDISBL | STARTUPTIME1 | STARTUPTIME0 | WDLOCK | JTAGEN
FUSEBYTE2 | - | BOOTRST | TOSCSEL | - | - | - | BODPD1 | BODPD0
FUSEBYTE1 | WDWPER3 | WDWPER2 | WDWPER1 | WDWPER0 | WDPER3 | WDPER2 | WDPER1 | WDPER0
FUSEBYTE0 | JTAGUID7 | JTAGUID6 | JTAGUID5 | JTAGUID4 | JTAGUID3 | JTAGUID2 | JTAGUID1 | JTAGUID0

ﾋｭｰｽﾞ ﾋﾞｯﾄ | 意味
BODACT1,0 | 活動中(活動動作とｱｲﾄﾞﾙ動作)でのBOD動作種別選択
BODLEVEL2～0 | 低電圧検出(BOD)ﾘｾｯﾄ電圧選択・許可/禁止
BODPD1,0 | 低電力保持(ｱｲﾄﾞﾙを除く休止)動作でのBOD動作種別選択
BOOTRST | ﾌﾞｰﾄ ﾛｰﾀﾞ領域へのﾘｾｯﾄ許可
EESAVE | ﾁｯﾌﾟ消去時EEPROM内容保護
JTAGEN | JTAGｲﾝﾀｰﾌｪｰｽ許可
JTAGUID7～0 | JTAG使用者識別子(ID)
RSTDISBL | RESETﾋﾟﾝ機能禁止(標準I/Oﾎﾟｰﾄ設定)
STARTUPTIME1,0 | 始動時間選択
TOSCSEL | TOSC2,1代替ﾋﾟﾝ選択
WDLOCK | ｳｫｯﾁﾄﾞｯｸﾞ ﾀｲﾏ施錠
WDPER1,0 | ｳｫｯﾁﾄﾞｯｸﾞ初期周期選択
WDWPER1,0 | ｳｫｯﾁﾄﾞｯｸﾞ窓初期周期選択